Jump to content
  • 0
Sign in to follow this  
Ellilea

Error while trying to re-run DynDOLOD

Question

I have tried to re-run DynDOLOD after all since I had a mod that I chose to remove after further inspection. But I'm sadly getting some errors now. The log is quite long (pastebin says too long to upload it), so I've copied the last section for now. Should I upload the full log somewhere?

 

It mentions Legacy of the Dragonborn, but I haven't touched it since last running the program successfully. Could you clue me in in what could be wrong?

 

I'm using MO and after last running DD I moved its TexGen and World outputs into the MO mods file, not leaving any left over files in DD folder in Skyrim's root one.

[00:06:29.502]	Building a list of LOD objects, please wait...
[00:06:29.695]	  World NecroDragontailMountains
[00:06:29.707]	    Gathering references in NecroDragontailMountains "Dragontail Mountains" [WRLD:5F16749E] for STAT ACTI MSTT CONT FURN DOOR LIGH TREE 
[00:06:29.724]	    Filtering 972 references in NecroDragontailMountains "Dragontail Mountains" [WRLD:5F16749E] for LOD
[00:06:29.735]	      0 of 972 done
[00:06:30.014]	Saving objects LOD data to F:\Steam\steamapps\common\Skyrim\DynDOLOD\Edit Scripts\Export\LODGen_TES5_NecroDragontailMountains.txt
[00:06:30.027]	LOD references: 376, unique LOD objects: 39
[00:06:30.061]	DoLODThread NecroDragontailMountains
[00:06:30.083]	Creating mini atlas data
[00:06:30.229]	Gathering meshes for atlas creation
[00:06:30.242]	Processing meshes for atlas creation
[00:06:30.286]	No flat atlas created
[00:06:30.303]	Creating atlas textures F:\Steam\steamapps\common\Skyrim\DynDOLOD\DynDOLOD_Output\Textures\DynDOLOD\LOD\DynDOLOD_Atlas_NecroDragontailMountains.dds from 21 textures
[00:06:32.456]	Combining mini atlas map
[00:06:32.468]	Executing LODGen.exe
[00:06:32.497]	"F:\Steam\steamapps\common\Skyrim\DynDOLOD\Edit Scripts\LODGen.exe" --inputfile "F:\Steam\steamapps\common\Skyrim\DynDOLOD\Edit Scripts\Export\LODGen_TES5_NecroDragontailMountains.txt" --logfile "F:\Steam\steamapps\common\Skyrim\DynDOLOD\Logs\LODGen_TES5_NecroDragontailMountains_log.txt" --dontFixTangents --removeUnseenFaces --skyblivionTexPath
[00:06:33.139]	Master in NecroDragontailMountains found
[00:06:33.171]	Setting up 55225 cells with 0 active cells for 0 dynamic LOD objects for DynDOLOD - T
[00:06:33.202]	Adding LOD objects data with -1 entries
[00:06:33.224]	  Saved F:\Steam\steamapps\common\Skyrim\DynDOLOD\DynDOLOD_Output\skse\plugins\StorageUtilData\DynDOLOD_NecroDragontailMountains_Objects.json
[00:06:33.235]	No new active cells. No need to update NearGrids or FarGrids form lists
[00:06:33.260]	  Adding world index with 26 entries
[00:06:33.270]	  Adding 26 masters
[00:06:33.294]	  Saved F:\Steam\steamapps\common\Skyrim\DynDOLOD\DynDOLOD_Output\skse\plugins\StorageUtilData\DynDOLOD_Worlds.json
[00:06:33.304]	Updating 39 base records
[00:06:33.349]	Done
[00:06:33.372]	DoLODThread NecroDragontailMountains done
[00:06:33.390]	
[00:06:33.400]	Doing LOD for PalePass added by LegacyoftheDragonborn.esp
[00:06:33.410]	  Options 000000100111110011010100
[00:06:33.437]	  Dimensions -10, 32, -23, 8
[00:06:33.457]	Loading F:\Steam\steamapps\common\Skyrim\DynDOLOD\Edit Scripts\DynDOLOD\DynDOLOD_TES5.ini
[00:06:33.468]	Not found F:\Steam\steamapps\common\Skyrim\DynDOLOD\Edit Scripts\DynDOLOD\DynDOLOD_TES5_childworldlod_PalePass.txt
[00:06:33.491]	Found bunch of numbers: 4N7O6S0E5H3S45O8T73T1I7M7B3U1S6
[00:06:33.502]	Reading DynDOLOD.esp with 30831 records for PalePass
[00:06:34.332]	
[00:06:34.332]	Exception in unit prepare line 732: One or more errors occurred
[00:06:34.332]	
[00:06:34.332]	Check log lines above the exception for additional hints. Check the FAQ and search official forum for those errors.
[00:06:34.332]	If problem persists, post error report with contents of ..\DynDOLOD\logs\DynDOLOD_TES5_log.txt to official forum http://forum.step-project.com/topic/5011-dynamic-distant-objects-lod-dyndolod
[00:06:58.042]	Saving: Settings
[00:06:58.058]	Saving: Logs

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I've noticed that in three attempts it crashed on different points. I don't use Bashed Patch or any such thing (just Reqtificator that is allowed to run independent of DynDOLOD, before, after, whenever AFAIK), and it seemed a bit random. I deleted everything from MO's folder related to DynDOLOD (well, not resources, just the outputs) and it went okay.

 

I don't know what happened since these folders I removed were not in the folder where DynDOLOD creates its output files, but I guess that's okay? Not a symptom of some bigger issue? I have been very careful with my load order.

 

While I'm at it, thank you for making this utility and supporting it around here :) Mucho appreciacio.

Edited by Ellilea

Share this post


Link to post
Share on other sites
  • 0

If it has problems at different points, please posts (parts) of the log as well. The last few dozen couple lines like you already posted are enough for now.

 

When you say you deleted earlier output, does that also mean you delete the earler DynDOLOD.esp or just the meshes/textures/skse folder?

 

Instead of deleting I would rather recommend just hiding the folders/files or make a backup of the generated files for such test, so you can go back to  before like nothing happened.

 

 

Edit: See if updating to the test version from this post works better, in case you still have obscure problems.

Edited by sheson

Share this post


Link to post
Share on other sites
  • 0

Would've if I could've :(

 

I didn't copy the part of the log at the start, just glanced at it, then retried and then decided to copy since the error returned. Only seen that the first time it was not about Legacy, but a Dragonborn area. Dragonborn02? Something. I'm not sure. Definitely Dragonborn though, because I was turning off a Dawnguard-area mod and paid special attention to see if it's not somehow related.

 

By deleted earlier output I mean I deleted the entire two folders sitting in Mod Organizer/mods path. Then it worked. ESP was included in one of the folders. I thought it wouldn't make a difference since DynDOLOD outputs to Skyrim/DynDOLOD (I had no remaining output folders there) not Mod Organizer folders, but clearly I was wrong.

 

I had a backup of my working DD folders, yes, but my extra fresh install was successful so I removed them.

 

I'm sorry I can't be of more help, I made a stupid and didn't keep the logs from other tries :(

 

For now no more obscure problems. Well, I had a funny occurrence, I loaded a save that was made with the old setup and there was an airship above Whiterun but it disappeared when I stepped closer and never returned :D The save is trashed now anyway since I was removing mods, but it was intriguing. Sadly, just a ghost LOD I guess (wasn't there before either, mysterious thing) and I'll never find out what was inside it :(

Edited by Ellilea

Share this post


Link to post
Share on other sites
  • 0

Would've if I could've :(

 

I didn't copy the part of the log at the start, just glanced at it, then retried and then decided to copy since the error returned. Only seen that the first time it was not about Legacy, but a Dragonborn area. Dragonborn02? Something. I'm not sure. Definitely Dragonborn though, because I was turning off a Dawnguard-area mod and paid special attention to see if it's not somehow related.

 

By deleted earlier output I mean I deleted the entire two folders sitting in Mod Organizer/mods path. Then it worked. ESP was included in one of the folders. I thought it wouldn't make a difference since DynDOLOD outputs to Skyrim/DynDOLOD (I had no remaining output folders there) not Mod Organizer folders, but clearly I was wrong.

 

I had a backup of my working DD folders, yes, but my extra fresh install was successful so I removed them.

 

I'm sorry I can't be of more help, I made a stupid and didn't keep the logs from other tries :(

 

For now no more obscure problems. Well, I had a funny occurrence, I loaded a save that was made with the old setup and there was an airship above Whiterun but it disappeared when I stepped closer and never returned :D The save is trashed now anyway since I was removing mods, but it was intriguing. Sadly, just a ghost LOD I guess (wasn't there before either, mysterious thing) and I'll never find out what was inside it :(

 

That's OK. If everything works now don't worry about it. "Ghost" LOD happens when not cleaning a save before introducing a new DynDOLOD.esp

Edited by sheson

Share this post


Link to post
Share on other sites
  • 0

Aye, but the fun part was, the ship wasn't there in the old setup :D It had never been there. It appeared after the new setup and disappeared just as quickly never to come back again whether I went further away or closer towards it. If that's a normal anomaly then aw, no ghosts or mysteries in my game :<

Share this post


Link to post
Share on other sites
  • 0

Aye, but the fun part was, the ship wasn't there in the old setup :D It had never been there. It appeared after the new setup and disappeared just as quickly never to come back again whether I went further away or closer towards it. If that's a normal anomaly then aw, no ghosts or mysteries in my game :

 

That happens because the save game remembers position/rotation of references, but not the model. If the new plugin uses the same form id for a reference, it will use the model data from the plugin with the position/rotation from the save.

 

It only purges the position/rotation for references if the associated plugin is not in the load order when loading. Ergo "clean" save.

 

So, it is fully expected to see the wrong models at dynamic LOD locations when save is not cleaned of that data.

Edited by sheson

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.