Jump to content
  • 0

TES5Edit Generate LOD (via MO) not working



I'm hoping this is a simple fix though I can't figure it out. 


If I launch TES5Edit via MO and then try to Generate LOD (after selecting "Other" in the dropdown menu after right clicking the plugin) nothing happens. No window opens. No error. Nothing. It's as if I didn't click the Generate LOD option at all and the menu just disappears. 


If I try to do this outside of Mod Organizer (just launching TES5Edit from the folder that I created for it) everything works as it should. 


-I've gone back and have given permissions to any folder that didn't have them.

-I've tried applying "Run As Administrator" to every .exe just to check if that was the issue.

-I've launched MO from the .exe instead of the shortcut to it. 

-I've reinstalled TES5Edit

-I've upgraded to the version of xEdit on the Fallout 4 nexus site after the fact and tried again

-I am using Mod Organizer v1.3.11


Even more strange  I can clean mods just fine launching TES5Edit via MO. So TES5Edit IS "working" via MO. Just the Generate LOD options seems to be "dead" unless I launch TES5Edit on its own (not through MO). 


Edit:... even more messed up now lol

Outside of MO i can generate LOD for all of the following.




-Skyrim Flora Overhaul.esp


In Mod Organizer I CAN

generate LOD for Dawnguard.esm ... but not the other two. I dont "get it". lol


Edit2: If I Apply Script and try to run LODGen there are no options at all in the world dropdown menu. Via MO it's as if the tamriel world spaces don't exist. If I Apply Script (launching TES5Edit on it's own) outside of MO I get the world menu drop down options as normal.


Edit 3: When running TES5Edit on it's own, as mentioned the LODGen Options window opens for the plugins, however, the Split Atlas Button isn't there. ... I'm lost lol


for anyone wondering what I'm actually doing is I'm trying to Split Atlas as I'm at the end of a tutorial Tree LOD BillBoard Creation and this is the only step that I can't move forward on. I've watched Sheson's video and the video is easy to follow I just don't have the options that I "should". 

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

While TES5LODGen is a renamed TES5Edit, there is still a minor difference between them. When you launch TES5LODGen, it shows you the list of all worldspaces from all loaded mods, while TES5Edit will show worldspaces only from a mod you right clicked on. If there are no worldspaces that fit for LOD generation, the window will not even open in TES5Edit. Worldspaces "fit" for generation are the ones that have exising lodsettings file which is usually packed in BSA archives. Since MO with turned on BSA management hides them from other application except for itself and the game, xEdit/xLODGen can't access lodsetting files and won't work.

You either need to disable BSA management in MO, don't use MO or unpack archives.

Edited by zilav
  • +1 1
Link to comment
Share on other sites

  • 0

Thank you to Sheson for putting ideas in my head = )


The only way that I could get this to work via MO was going into the Archives tab and extracting the Skyrim - Meshes.bsa into the Skyrim\Data folder. I still don't have the Split Atlas button yet...

Link to comment
Share on other sites

  • 0

... and to get the Atlas option I needed to hold Shift when Selection Generate LOD... I assumed that holding shift was to speed up the process (its not lol)... and since I didn't have anything appear until I unpacked the BSA I stopped pushing Shift.... Now holding Shift down when selection Generate LOD with the BSA's unpacked all is right with Tamriel once again... Thank you to all of you reading =)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.