Jump to content
  • 0
Lagosaurus

SKSE .ini Settings Not Working

Question

The issue turned out to be improper text file encoding (using a more sofisticated text editor allows viewing/saving various encoding formats). proper format is either ASCII or UTF-8.

This has been frustrating me to no end. My SKSE.ini settings are not working, resulting in an ILS any time I try to enter an exterior cell.

 

  • SKSE is properly installed.
  • The SKSE.ini file is in the proper location in MO.
  • The SKSE.ini file is formatted properly.
  • The -forcesteamloader argument is already set.

 

Despite that, the memory patch settings in the .ini file refuse to take effect. I've tried everything that I can think of outside of using SSME to no avail, MemoryBlocksLog returns 256/256 every time.

 

Current SKSE.ini file:

[General]
ClearInvalidRegistrations=1


[Memory]
DefaultHeapInitialAllocMB=768
ScrapHeapSizeMB=256


[Display]
iTintTextureResolution=2048
Edited by z929669

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

According to the original post, the skse.ini settings are 768/256 so the first line in Memory Blocks Log should be 512/256 but is 256/256 instead. This seems to indicate either skse_loader.exe isn't running, it isn't finding the skse.ini file, or there's a typo somewhere in the skse.ini that is causing it not to read the entries correctly. I ruled out skse_loader.exe not running because he added the -forcesteamloader argument and (correct me I'm mistaken) Memory Blocks Log doesn't work with skse_loader running.

 

You know, thinking about this in more depth, is it possible that skse.ini is stored in Unicode format? Seems I ran into an issue a while back with an ini file not being read and I finally figured out the bloody thing was in Unicode instead of ANSI/ASCII.

 

 

[General]
ClearInvalidRegistrations=1

[Memory]
DefaultHeapInitialAllocMB=768
ScrapHeapSizeMB=256

[Display]
iTintTextureResolution=2048

Share this post


Link to post
Share on other sites
  • 0

Make sure the file is actually named SKSE.ini. Windows hides file extensions by default, so it's fairly easy to mistakenly end up with a file named SKSE.ini.txt.

Share this post


Link to post
Share on other sites
  • 0

Make sure the file is actually named SKSE.ini. Windows hides file extensions by default, so it's fairly easy to mistakenly end up with a file named SKSE.ini.txt. 

The file itself is named and formatted properly.

 

6ca8dec1cc6fc85975800bab19d0a07a.png

Share this post


Link to post
Share on other sites
  • 0

*cough* Sticky *cough*

 

Key point being "Skyrim\Data\skse\"

I already tried "Skyrim\Data\skse" and it didn't work either. It shouldn't make any difference whether you put it in a MO virtual folder or the data directory anyways.

Share this post


Link to post
Share on other sites
  • 0

It should be in the SKSE folder in the SKSE mod in Mod Organizer. If you're looking at this in Windows Explorer, the full path should be something like this:

C:\ModOrganizer\mods\skse 1 07 03\SKSE\skse.ini

If you're not using Mod Organizer, it should be in the data\SKSE folder like this:

 

 

C:\Games\Steam\SteamApps\common\Skyrim\Data\SKSE\skse.ini

 

YiV7RZHhMSwsaq07

Share this post


Link to post
Share on other sites
  • 0

It should be in the SKSE folder in the SKSE mod in Mod Organizer. If you're looking at this in Windows Explorer, the full path should be something like this:

C:\ModOrganizer\mods\skse 1 07 03\SKSE\skse.ini

If you're not using Mod Organizer, it should be in the data\SKSE folder like this:

C:\Games\Steam\SteamApps\common\Skyrim\Data\SKSE\skse.ini

YiV7RZHhMSwsaq07

That is the same setup that I already have, which I showed in the previous post.

Share this post


Link to post
Share on other sites
  • 0

When you do, be sure to remove/rename the INI in the SKSE mod, as MO will use that instead of the one in the Skyrim folder.

Share this post


Link to post
Share on other sites
  • 0

can you please place the skse.ini in the skyrim directory to test and see.

 

When you do, be sure to remove/rename the INI in the SKSE mod, as MO will use that instead of the one in the Skyrim folder.

 

I have already tried both suggestions, neither of them worked.

Share this post


Link to post
Share on other sites
  • 0

Hmm, can you delete the memoryblockslog.log from the overwrite folder and the re run skyrim and then report back

Share this post


Link to post
Share on other sites
  • 0

Hmm, can you delete the memoryblockslog.log from the overwrite folder and the re run skyrim and then report back

Same result, 256/256.

Share this post


Link to post
Share on other sites
  • 0

I maybe having a 'senior moment' or failing completely to see the issue, but isn't this a case of Skyrim just not using that much memory in the first block?

 

Is this actually an issue? I can run a minimal modded game and my first block will be lucky to break 200MB.

 

This is the log of my "Basic character" profile:

[spoiler=Memory Block log]logging of blocks enabled
logging max values only
Timer disabled
Block1 Block2
512MB 256MB
85 8
85 8
85 9
...
178 98
179 98
179 99
190 99
195 99

 

Share this post


Link to post
Share on other sites
  • 0

Oh, that... That isn't something that I was expecting.

Is that a bug?

 

Anyway, I'll add it to the op soon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.