Jump to content
  • 0
Sign in to follow this  
AlexanderADM

Dual Sheath Redux Patch ( SkyProc Patcher ) will not produce a patch

Question

As the title says DSR Patcher isn't working correctly and I've attempted quite a few ways of making it work, to go more in depth I've tried all 3 files from within MO ( as stated on the wiki ), obviously the 64bit bat file will not work, Running the jar directly with the argument returns the following error ' A Java Exception has occured ' and the program just shuts off without any error logs within MO, the 32bit bat file will start the DSR Patcher correctly and allow me to click the patch button yet when I do so it returns the following "This patcher requires the following mods, please add them to your load order: Dual Sheath Redux.esp". I've verified multiple times that the esp is active, I even reinstalled DSR 3 times, and I've rerun LOOT for sorting a number of times and also rebuilt the Wrye Bashed Patch a few times. Amongst others I've tried replacing the hook.dll ( or whatever the name is ) which was listed as possible problem with older versions from a pinned thread nonetheless that did not work. I am following the STEP Guide for STEP:Extended and I've added a handful of mods while following all of the instructions bit by bit ( I've been doing that all day ), amongst the mods installed there is : Immersive Weapons, Immersive Armors, Immersive Patrols,Skyrim Immersive Creatures, Immersive Settlements, Immersive Citizens - AI Overhaul, Wyrmstooth, Falskaar, Frostfal, Cloaks of Skyrim, Winter is Coming, Hunterborn, OBIS Organized Bandits In Skyrim, Realistic Needs and Diseases ( all of these have been patched to ensure functionality with STEP:Extended by checking each mod one by one during the installation of these side mods) .

I'm now stuck to the final Patches ( 2.N ) on the STEP guide because of the DSR Patch not running apparentely its not able to find its own .esp in the load order the executable has the following arguments: ( I've also attempted to run MO as administrator with no results )

Dual Sheath Redux.jar

Binary: C:\Program Files (x86)\Java\jre7\bin\javaw.exe

* Attempted to update JRE (32bit) therefore Binary changed to C:\Program Files (x86)\Java\jre1.8.0_45\bin\javaw.exe the error does not display anymore due to the arguments yet the program does not run at all, with no error message or anything.

Start In: C:\Skyrim Utilities\Mod Organizer\mods\Dual Sheath Redux\SkyProc Patchers\Dual Sheath Redux Patch

Arguments *modified from 32bit bat file: javaw.exe -Xmx1024 -jar "C:\Skyrim Utilities\Mod Organizer\mods\Dual Sheath Redux\SkyProc Patchers\Dual Sheath Redux Patch\Dual Sheath Redux Patch.jar"

 

Edit: It seems that MO is unable to run the jar file directly and the bat file starts the jar but it starts it outside of MO. I have yet to find any workarounds or fixes for this issue.

Edit 2: After realizing that I have not set the binary for the jar file to the javaw 1.8 ( updated one ). After doing so the patcher works perfectly. My apologies for the useless thread.

 

If any one could please close/delete this , I'd be really grateful.

Edited by AlexanderADM

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.