Jump to content
  • 0
Sign in to follow this  
Perdurabo

Help!! skyrim and other executables cannot read Virutal folder

Question

Hi

 

After a long hiatus from skyrim I`ve returned to the fold

However I have run into this problem With MO.

 

1. Installed mods does not show up in game when launched from MO (they are ticked off in both panels)

 

2. Executables launched through MO (i.e BOSS, LOOT, Edit etc) does not read the Virtual folder, but the default data folder.

 

3. Ini edits made in MO does not appear in game when launched from MO.

 

MO was installed via the installer to "my documents" outside of program files, and always run on admin.

 

I suspect MO is somehow redircted, in a similar manner which is described in this post: https://forum.step-project.com/topic/6413-mo-installed-mods-not-being-found/?hl=%2Bvirtual+%2Bfolder&do=findComment&comment=104114

 

but I do not understand how he/she solved it.  

 

Any help in how to solve this is greatly appreciated!!

 

 

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Nevermind

 

I had an epifani. I went into the data folder and removed a mod (vampire lord larger wings) that was automatically added (steam workshop) when I first startet skyrim through its launcher.

 

The BSA of that mod gave some errors that MO complained about but then went away, I just remembered. 

 

Removing only the BSA of said mod have MO functioning perfectly again. It reads the VFS just fine now.

Re-adding the BSA reproduces the problem so I am certain it is to blame. 

I am however unable to reproduce the error message I got earlier.

 

Nevertheless thank you very much for you efforts to help me!!

Share this post


Link to post
Share on other sites
  • 0

Did you run Skyrim at least once outside of MO before using it to manage your mods?

This sets the ini files and registry properly.

Share this post


Link to post
Share on other sites
  • 0

Post you ModOrganizer.ini in spoiler tabs:

[spoiler] text [/spoiler]

Also provide the actual installation paths for Skyrim and MO and at least one of the 'problematic tools', e.g. LOOT.

 

Lastly have you moved your Skyrim installation after its initial install? I'm assuming not, but just eliminating all possibles.

Share this post


Link to post
Share on other sites
  • 0

 

 

[General]
gamePath=C:\\Users\\Thomas\\Spill\\Steam\\steamapps\\common\\Skyrim
motd_hash=107447838
first_start=false
selected_profile=Default
mod_list_state=@ByteArray(\0\0\0\xff\0\0\0\0\0\0\0\x1\0\0\0\0\0\0\0\x6\x1\0\0\0\0\0\0\0\0\0\0\0\a(\0\0\0\x2\0\0\0\x5\0\0\0\x14\0\0\0\x3\0\0\0\x14\0\0\x2\x13\0\0\0\a\x1\x1\0\0\0\0\0\0\x1\0\0\0\x1\0\0\0\x14\xff\xff\xff\xff\0\0\0\x81\0\0\0\0\0\0\0\a\0\0\x1\x16\0\0\0\x1\0\0\0\0\0\0\0P\0\0\0\x1\0\0\0\0\0\0\0\x41\0\0\0\x1\0\0\0\0\0\0\0\0\0\0\0\x1\0\0\0\0\0\0\0\x36\0\0\0\x1\0\0\0\0\0\0\0\0\0\0\0\x1\0\0\0\0\0\0\0\x36\0\0\0\x1\0\0\0\x1)
plugin_list_state="@ByteArray(\0\0\0\xff\0\0\0\0\0\0\0\x1\0\0\0\0\0\0\0\x2\x1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\x1Z\0\0\0\x4\x1\x1\0\0\0\0\0\0\x1\0\0\0\x1\0\0\0\x64\xff\xff\xff\xff\0\0\0\x81\0\0\0\0\0\0\0\x4\0\0\0\xa1\0\0\0\x1\0\0\0\0\0\0\0\x32\0\0\0\x1\0\0\0\0\0\0\0;\0\0\0\x1\0\0\0\0\0\0\0L\0\0\0\x1\0\0\0\x1)"
group_state=0
ask_for_nexuspw=true
window_geometry=@ByteArray(\x1\xd9\xd0\xcb\0\x1\0\0\0\0\x1\xe9\0\0\0\xa6\0\0\x5\x96\0\0\x3\x91\0\0\x1\xf1\0\0\0\xc4\0\0\x5\x8e\0\0\x3\x89\0\0\0\0\0\0)
window_split=@ByteArray(\0\0\0\xff\0\0\0\0\0\0\0\x2\0\0\x3\xde\0\0\x2\xa8\x1\0\0\0\x5\x1\0\0\0\x1)
log_split=@ByteArray(\0\0\0\xff\0\0\0\0\0\0\0\x2\0\0\x2\x62\0\0\0\x64\x1\0\0\0\x5\x1\0\0\0\x2)
browser_geometry=@ByteArray(\x1\xd9\xd0\xcb\0\x1\0\0\0\0\0\0\0\0\0\0\0\0\x3\xef\0\0\x2\xed\0\0\0\0\0\0\0\0\0\0\x3\xef\0\0\x2\xed\0\0\0\0\0\0)
filters_visible=false
manage_bsas=true
selected_executable=3

[PluginPersistance]
Python%20Proxy\tryInit=false

[settings]
hide_unchecked_plugins=false
force_enable_core_files=true
compact_downloads=false
meta_downloads=false
load_mechanism=0
download_directory=D:\\Thomas\\mods\\Skyrim mods\\downloads
cache_directory=C:\\Users\\Thomas\\Documents\\mod organizer\\webcache
mod_directory=C:\\Users\\Thomas\\Documents\\mod organizer\\mods
log_level=0
nexus_login=true
nexus_username=schtan
nexus_password=6d0EJkuzAcY0
offline_mode=false
use_proxy=false
display_foreign=true
nmm_version=0.52.2

[Plugins]
BSA%20Extractor\enabled=false
Basic%20diagnosis%20plugin\check_conflict=true
Basic%20diagnosis%20plugin\check_errorlog=true
Basic%20diagnosis%20plugin\check_font=true
Basic%20diagnosis%20plugin\check_missingmasters=true
Basic%20diagnosis%20plugin\check_modorder=true
Basic%20diagnosis%20plugin\check_overwrite=true
FNIS%20Checker\enabled=false
FNIS%20Checker\sensitive=false
Fomod%20Installer\enabled=true
Fomod%20Installer\prefer=true
INI%20Editor\associated=true
INI%20Editor\external=false
Python%20Proxy\enabled=true
Python%20Proxy\python_dir=
Simple%20Installer\enabled=true
Simple%20Installer\silent=false

[pluginBlacklist]
size=0

[customExecutables]
size=1
1\binary=C:/Users/Thomas/Spill/Steam/steamapps/common/skyrim/TES5Edit.exe
1\title=Tes5Edit
1\arguments=
1\workingDirectory=
1\closeOnStart=false
1\steamAppID=
1\custom=true
1\toolbar=false

[recentDirectories]
size=1
1\name=editExecutableBinary
1\directory=C:/Users/Thomas/Spill/Steam/steamapps/common/skyrim

[servers]
CDN=@Variant(\0\0\0\b\0\0\0\x5\0\0\0\xe\0p\0r\0\x65\0m\0i\0u\0m\0\0\0\x1\0\0\0\0\x12\0p\0r\0\x65\0\x66\0\x65\0r\0r\0\x65\0\x64\0\0\0\x2\0\0\0\0\0\0\0\x10\0l\0\x61\0s\0t\0S\0\x65\0\x65\0n\0\0\0\xe\0%}\xc3\0\0\0\x1a\0\x64\0o\0w\0n\0l\0o\0\x61\0\x64\0S\0p\0\x65\0\x65\0\x64\0\0\0\x6\0\0\0\0\0\0\0\0\0\0\0\x1a\0\x64\0o\0w\0n\0l\0o\0\x61\0\x64\0\x43\0o\0u\0n\0t\0\0\0\x2\0\0\0\0)

[CompletedWindowTutorials]
InstallDialog=true

 

 

 

Skyrim path:::

C:\Brukere\Thomas\Spill\Steam\steamapps\common\skyrim

 

MO path:::

C:\Brukere\Thomas\Mine dokumenter\mod organizer

 

Tes5Edit path:::

C:\Brukere\Thomas\Spill\Steam\steamapps\common\skyrim

 

Note:

"Brukere" and "Mine dokumenter" are often autotranslated to "Users" and "My documents" by English software.

 

No, I have not moved the Skyrim Installation. 

Share this post


Link to post
Share on other sites
  • 0

hmm...

My first thought would be MO might be falling over the path names, but surely not.

 

Just to check, could you install SKSE and then start MO? If MO has no issues with the German path names it will be automatically shown as the top option in the dropdown list for the 'Run' command.

 

For the sake of this test just grab the archive version and copy into the Skyrim folder only the *.dll *.exe files from with the archive. Later we can install the scripts properly into MO. That is of course unless you are feeling confident and you can just follow the instructions as outline by Gopher.

Share this post


Link to post
Share on other sites
  • 0

For future reference MO needs to have the Skyrim data folder clean of any mods. Mods installed manually or by Steam will cause you more grief if you also try to manage your mods with MO.

 

Keep the Skyrim folder clean and install only with MO.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.