Jump to content
  • 0
Sign in to follow this  
whismerhill

mod organizer issue : ASIS & Free Commander

Question

hi there,

 

I have an issue which is preventing me from creating the ASIS patch

 

it gives the famous : "java.lang.NullPointerException"

I deactivated all esp besides skyrim, its DLC & unofficial patches + ASIS-dependency.esp

I checked : "hide inactive ESP/ESM"

 

The reproccer skyproc patcher works fine

 

A side issue which I don't pretty much care about but which might help pinpoint the problem for the more knowlegeable perhaps :

-Free Commander XE sees my virtual data folder fine

however if I double click on any virtual folder (such as "skyproc patcher") it goes back to "real" data folder (so no more skyproc patcher folder ...)

 

 

I would just like to make ASIS work with MO. I just tried Free Commander because someone said it worked for him to use ASIS through Free Commander through MO

 

It's probably something wrong on my end but I have no idea what

thanks for any help.

 

 

EDIT: corrected the XS ~ XE typo

Edited by wolverine2710

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

ok I dunno what I did wrong

but I cleared the overwrite folder of asis work remnants (log files and a lot more)

and it's working. so I guess it was an asis issue from the start

or maybe it's because of MO that some files were left over (because previously when I used NMM and ASIS ever failed, it didn't leave that much files behind it as far as I remember)

and a single failure will hence cause subsequent failures

 

now I'll just have to find the problematic mod and to not forget to delete the overwrite folder contents xD

 

thanks for all the help, without you I wouldn't have been able to find this that quick.

Share this post


Link to post
Share on other sites
  • 0

Dienne who is the current maintainer of Skyproc and ASIS (which uses Skyproc internally) also uses MO. Hence he can probably help you best. As in interpret the debug logs and perhaps add a more specific error message.

 

My first reaction was that is a ASIS problem because reproccer (also uses Skyproc internally) runs correctly. Note: reproccer uses Leviathans older skyproc version and ASIS uses Dienne's Skyproc version. But the lot is clouded a bit with what you said about Free Commander XE. Couldn't find an XS version, perhaps a typo? I'm using Free Commander 2009 0.2b (NOT XE). To test your findings I installed Free Commander XE portable 'download 2014 build' (zip version) because I didn't want to mess up my existing FC. Kickstarted it from MO and moved to the /data directory. I saw the contents of the VFS and moved to the Skyproc Patchers directory, all seemed fine. Moved to and moved then back to /data. NOW I did NOT see the VFS content but only the regular /data directory. Stopped FC XE, did the same and could reproduce it. Also one time FC XE stopped with an error and two times after quitting FC XE MO's 'unlock' message did not disappear. Reason: FC XE was still running. Had to use task manager to quit it. Summary: FC XE portable and MO do NOT play nice together (on my system). I've been able to find my version back on the internet, here.

 

Check: Can you please check if peforms ASIS is not also installed in the regular /data directory? If so please remove it.

 

Lets now try to concentrate on MO and try the following:

 

1) Disable USKP in the left pane and run ASIS again. Does the error persist?

2) Should the error persist please install ASIS in the regular /data directory and run it from there - NOT from MO.  As the DLC's etc are in the regular /data directory you now have the same situation as in MO. Does it run now?  You could also install USKP in the regular /data directory but I don't want to clutter it.

3) Should it now run correctly, now add ASIS as an executable to MO and run it from MO? Does it still work?.

 

Note: The moment you use more then one skyproc patcher you should be using SUM otherwise things get complicated. If you already use SUM currently, please try to start ASIS from MO and not from SUM, does it work then?. You can run into problems when starting Skyrim but at least you can narrow down things...

 

Another thing you can to make sure MO is not somehow borked. Install MO again in a new directory and install ASIS and USKP there and run it again. Does the error still persist? Note: should it now work I can help your with instructions how to get your mods/downloads installed in the old MO back into the new MO.

 

Basically you have to do some work, invest time  and do a lot of tests, can't iterate them all here (already a wall of text). Please report back your findings.

 

As mentioned before Dienne is in the ideal situation to help you further should it NOT be a MO problem and even if its a MO related problem. This is all I can do for you at the moment.

Share this post


Link to post
Share on other sites
  • 0

ok First Success here

Free Commander 0.9b works !!!

I was able to browse the virtual folders without any problem

Thanks for that !

 

I already use SUM, SUM works until it stumbles on ASIS and then gives the same error message at the same exact position

Reason I'm using ASIS without SUM at the moment is to fix this problem (so that I don't have to wait for reproccer patching just to get an error message dozens of times)

 

**Disable USKP in the left pane and run ASIS again. Does the error persist?

yes the error persist

 

**Should the error persist please install ASIS in the regular <skyrim>/data directory and run it from there.

it works

 

**Should it now run correctly, now add ASIS as an executable to MO and run it from MO.

doesn't work

 

Since Free Commander 0.9b works I tried launching ASIS from it.

got the same error

 

I went a step further and tried  unchecking all mods from the left pane instead of just deactivating ESPs (just left ASIS)

same result

 

**Install MO again in a new directory and install ASIS

WTF it works

 

I don't get it :huh:

 

more testing later on

Share this post


Link to post
Share on other sites
  • 0

Can you please create a ticket in the bug genie issue tracker for the issue with Free Commander XE, so that Tannin can have a look at it.

 

Glad to see that MO works now. I don't have an answer why it now works but it has been reported in the past that reinstalling MO solved the problem for some users.

 

If you installed MO 1.1.2 please do NOT forget the NMM downgrade. To quote Tannin from the OP "It seems the external installer bundled with 1.1.2 is kaput so please downgrade to the NCC version from 1.1.1, there is an optional file for that in the files section. Simply unpack to your mod organizer directory (you should be prompted to overwrite files, choose yes)." 

 

There a few things/tests you can do to get your original mod setup back.

1) Test: make a backup of modorganizer.ini and nxmhandler.ini somewhere and then start MO again. Does ASIS work now?
The files are auto generated. You basically miss your username/password and some settings like your download directory should you have changed that.

2) Change: Should 1 not work install MO again in the existing MO directory. You can use the manual installer or the normal installer (in that case also install the NMM downgrade).

3) Change: Should 1 and 2 not work. Copy (or move if you no space left)  the Profiles, mods and overwrite (best practice is to have it empty) to the new MO directory. Also the downloads directory if its still in the default place. If you have changed the categories there will be I believe a categories.dat file, copy that also.

4) Change: Should everything work now and you feel 'adventurous' you can also copy the backupped two ini files to the new MO directory (make backup first of current new MO ini's.) Note: I noticed in the past (older version I believe) that on my system the MO/webcache directory wasn't relative to MO but had an absolute path.

 

Unless I've made a mistake and forgot something the above should work.

 

PS. I have edited (added colours) your post so its a bit clearer.

Share this post


Link to post
Share on other sites
  • 0

just a follow up :

I used "skyre ASIS inis"

it's outdated

the ini files format got updated in ASIS  and I missed this bit of information (silly me didn't read because he thought he had seen all)

 

sorry for the trouble.

 

Though it still remains that if ASIS crashes once my overwrite folder has to be cleared or else it will just crash repeatedly whatever changes I make (which doesn't ease the process of finding an issue when you don't know xD)

 

 

bug with free commander reported : https://issue.tannin.eu/tbg/modorganizer/issues/609

hope I did it ok

Edited by whismerhill

Share this post


Link to post
Share on other sites
  • 0

Your welcome.

I have to admit that 'left overs' (of ASIS) in overwrite is the first I see this mentioned. In the past I've used Automatic Variants all the time and I've experimented with ASIS, I never cleaned the overwrite directory (NOT best practice and now I know better)  and never got an error.

 

Is it reproducible, as in run ASIS once, it works, left overs in overwrite, rerun  ASIS and an error occurs? Its the more strange because ASIS in principle only generates text files in overwrite and the ASIS.esp.

 

Note: I nice trick which worked for and also for my skse plugins which updates logfiles. Once a reproccer.esp or logfile for skse is generated I move it to the mod it belongs to (reproccer, memory blocks log) and then rerun reproccer it ends up in the 'reproccer' mod or in case of MBL the logfile is updated in the MBL mod.

 

Edit: it would be appreciated if you can create a ticket for FreeCommander XE.

Share this post


Link to post
Share on other sites
  • 0

hehe your post and my last edit did "cross" :;):  (didn't want to make too much posts as only a few minutes separated my last edit and no new posts were made)

for reproducing my "cleaning overwrite necessary" issue :

 

-get any profile (empty is fine)

-install ASIS 1.40 or later

-install "skyre ASIS inis" 1.60 https://www.nexusmods.com/skyrim/mods/38238/

-check both

-move "skyre ASIS inis" to a higher priority if necessary (so that it overwrites ASIS default inis)

-run ASIS

-get the error

-uncheck "skyre ASIS inis"

-rerun ASIS

-get the error

-clean overwrite folder

-rerun ASIS

-works fine

 

note: I didn't check if this also fails with nmm or not, maybe it's the case !

back when I used nmm ASIS was 1.37 or earlier

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.