Jump to content
  • 0

Another CTD question - general reminder asked for


tillicollpase

Question

Hi, this is yet another CTD post.

I am getting random CTDs and ILSs. I also frequently get a situation where textures fail to load and I get purple or black meshes. These also happen randomly (so I know that it's not that the texture files are missing. It's just that they sometimes fail to load). CTDs and missing texture happens most often at the Hearthfire home Heljarchen Hall. I need to run the game a few times just to get into the house because, for example, I get ILS at the door, and then when I try again, I get in, but then immediately get CTD, and then on third try (loading the autosave made just before I got CTF) I am finally inside. Missing texture issue happens very frequently at that location too (both indoor cell and the immediately surrounding outdoor cell). But as I said, it's not limited to player home.

 

I think I've done everything, and not sure what else to do now. Just a reminder about what I should do next would be appreciated. Any ini tweaks I should try, for example? I'd really appreciate help.

 

I have cleaned all plugins (including update.esm and the DLC plugins), BOSS'd my load order, have bashed patch and merged patch. I am using ENBoost, and my ini files are not that heavily modified. I do have iMaxAllocatedMemoryBytes=2147483647 and the ini lines for multi-core CPU. I'm running at ultra setting, and didn't touch ugrids or LODs or whatever (after all this time playing and modding Skyrim, I still don't quite understand what they are so I leave them be).

Plugins are a bit on the heavy side, but I consciously tried to avoid overly script intense mods, save those that I had to have.

 

My specs are

CPU: i7-2600 3.40GHZ

RAM: 8GB

VGA: AMD 7950 with 3GB VRAM

 

No heat problem with the hardware, the game generally runs smooth otherwise than the CTD issue.

 

I followed all the instructions found at https://skyrim.nexusmods.com/mods/32363/?

My graphic driver is updated to the latest version. Skyrim is 1.9.32.0.8 (the latest). THe unofficial patches are all up to date.

I am using Mod Organizer.

 

I have run a much more heavily modded setup before (~240 plugins) albeit some instability, and I don't know why I am struggling at a much lighter setup here.

 

I am attaching my load order (I am using Texture Pack Combiner too).

 

 

 

 

# This file was automatically generated by Mod Organizer.

Skyrim.esmpdate.esm

Dawnguard.esm

HearthFires.esm

Dragonborn.esm

Falskaar.esm

RaceCompatibility.esm

Skyrim Project Optimization - Full Version.esm

ClimatesOfTamriel.esm

hdtHighHeel.esm

Ket_ARMONIZER_v2.esm

Lanterns Of Skyrim - All In One - Main.esm

moonpath.esm

SPIKE.esm

HighResTexturePackCombined.esp

Brawl Bugs CE.esp

Unofficial Skyrim Patch.esp

USKP Patcher for RaceCompatibility.esp

Unofficial Dawnguard Patch.esp

Unofficial Hearthfire Patch.esp

Unofficial Dragonborn Patch.esp

Unofficial High Resolution Patch.esp

Weapons & Armor Fixes_Remade.esp

Chesko_Frostfall.esp

Better Dynamic Snow.esp

Morning Fogs.esp

RevampedExteriorFog.esp

SplashofRain.esp

IceBreaker's Improved Reverb-v0.02-Cleaned.esp

Improved Combat Sounds v2.2.esp

StaticMeshImprovementMod.esp

StaticMeshImprovementMod-DragonbornTernFix.esp

TradeBarter.esp

Chesko_WearableLantern.esp

Dead Body Collision.esp

PilgrimsDelight.esp

Radiant and Unique Potions Poisons and Booze.esp

ShootingStars.esp

Skyrim Flora Overhaul.esp

Convenient Horses.esp

Auto Unequip Ammo.esp

RaceMenu.esp

RaceMenuPlugin.esp

SkyUI.esp

iHUD.esp

Cloaks.esp

Cloaks - Dawnguard.esp

1nivWICCloaks.esp

1nivWICSkyCloaksPatch.esp

hothtrooper44_ArmorCompilation.esp

DeadlyDragons.esp

DeadlyDragonsArmory.esp

DeadlyMonsters.esp

moonpath_questdata.esp

When Vampires Attack.esp

Wyrmstooth.esp

Civil War Overhaul.esp

Ket_ARMONIZER_LListsNPC.esp

dD-No Twitching Dragon Death Animation.esp

SFO - Expanded Diversity.esp

UnreadBooksGlow.esp

Helgen Reborn.esp

EnhancedLightsandFX.esp

ELFX - Exteriors.esp

ELFX - Moonpath.esp

ELFX - Dawnguard.esp

ClimatesOfTamriel-Dawnguard-Patch.esp

ClimatesOfTamriel-Dragonborn-Patch.esp

ELFXEnhancer.esp

HitStop.esp

LockpickingOverhaul4.esp

DeadlyCombat.esp

DeadlyCombat_GiantsAIFix.esp

DragonCombatOverhaulDragonborn.esp

Locational Damage.esp

The Dance of Death - Ultimate Edition.esp

dD-No Spinning Death Animation.esp

TheEyesOfBeauty.esp

AmazingFollowerTweaks.esp

Height Adjusted Races with True Giants - Smaller Giant Edition.esp

CharacterMakingExtender.esp

EnhancedCharacterEdit.esp

getSnowy.esp

WATER.esp

WATER Plants.esp

WATER DB Waves.esp

SKSE Hotkeys.esp

WetandCold.esp

WetandCold - Ashes.esp

Bashed Patch, 0.esp

ASIS-Dependency.esp

ASIS.esp

TouringCarriages.esp

Auto Unequip Shield.esp

Travel By Boat.esp

Windfull Skyrim.esp

DeadlyCombat_ASIS_Patch.esp

SBF All In One + DLC.esp

Merged Patch.esp

 

 

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Where to start...

First I added the spoiler tags! Thats a place to start!

 

Next up... ini´s

Revert to vanilla ini´s you do not need those multi core ones... the memory ones are pointless since you say you use ENBoost and it will handle all memory related stuff via its ini files.

 

Black and purple meshes mean that you have run out of memory, which is a bit odd with ENBoost, but most likely means you have not set it up properly. Please do post you enblocal.ini inside spoiler tags. (Search for BBcode spoiler if you need help.)

 

Just cleaning left and right is not always a bonus, but should not make the game more unstable. But it may break a few mods out there since they are constructed in a way the Tes5edit´s automated cleaning cannot handle.

 

As for the mod list, then ask yourself if you really do need ASIS... it makes any list much more unstable.

All those small combat mods you have each add a script to you which will make combat rather intensive script wise.

Ask yourself if you cannot manage to equip arrows and a shield yourself for example.

 

But overall it sounds like you have memory issues, which is again related to the fact that ENBoost and your inis are most likely messed up.

And not saying anything bad about project stability... but if you followed all of that then that would also mean you installed cleanmem.. which is even more pointless to do even if you where not using ENBoost! Also most of the ini tweaks he suggests are not really required or improve anything.

Link to comment
Share on other sites

  • 0

Thanks, Aiyen, getting someone's opinion about what might be problem helps a lot.

 

My enblocal.ini is

 

 

[PROXY]

EnableProxyLibrary=true

InitProxyFunctions=true

ProxyLibrary=sweet_d3d9.dll

 

[GLOBAL]

UsePatchSpeedhackWithoutGraphics=false

UseDefferedRendering=false

ForceFakeVideocard=false

 

[PERFORMANCE]

SpeedHack=true

 

[MULTIHEAD]

ForceVideoAdapterIndex=false

VideoAdapterIndex=0

 

[MEMORY]

ExpandSystemMemoryX64=true

ReduceSystemMemoryUsage=true

DisableDriverMemoryManager=true

ReservedMemorySizeMb=512

 

[WINDOW]

ForceBorderless=false

ForceBorderlessFullscreen=false

 

[ENGINE]

ForceAnisotropicFiltering=true

MaxAnisotropy=8

EnableVSync=false

 

[LIMITER]

WaitBusyRenderer=false

EnableFPSLimit=false

FPSLimit=100.0

 

[iNPUT]

//back

KeyReadConfig=8

//shift

KeyCombination=16

//f12

KeyUseEffect=123

//home

KeyFPSLimit=36

//num /       106

KeyShowFPS=106

//insert

KeyScreenshot=45

//enter

KeyEditor=13

 

 

 

I must confess, you're right, I am not sure if this is set up properly. I am using Ultimate Lighting Overhaul + with ENBoost, and I know the description page on Nexus for ENBoost talks about minor tweaking the settings a bit, which I tried and didn't seem to work so I reverted to the original enblocal.ini file.

I am not sure how my setting this up with Ultimate Lighting Overhaul + affected ENBoost. At least I picked the right enblocal.ini file from the ENBoost archive file (the one from 64bitOS/AMD_Videocard/2-4GB_VRAM_or_greater). I didn't do anything to this file.

 

I do prefer having ASIS but of course I'd be willing to experiment.

 

Your comment about auto-unequip scripts, yes, I suppose I can do without them.

 

Going back to my point about player home, any guess about why player home is causing problem? Battles actually rarely give me problem. It's the player home and when I am in the open that there is problem.

 

Finally, I can't get on to playing or fixing Skyrim at least until next weekend. I'd appreciate it if you would give me more assistance then (I will probably need to bump this thread, if that's ok).

Link to comment
Share on other sites

  • 0

Seems like you have an older version of ENBoost... that might also contribute to the issue. 

Also since you are just using ULO then there is no need to activate the graphics parts of ENB.. since those will conflict. 

so first UsePatchSpeedhackWithoutGraphics=false -> true to disable all color correction other then SweetFX. 

 

The memory tab should look like this (At least it does in all the never versions of ENB... dunno what happens at the nexus site, I always get it from ENB´s webpage and adjust myself.)

[MEMORY]

ExpandSystemMemoryX64=true

ReduceSystemMemoryUsage=true

DisableDriverMemoryManager=false

DisablePreloadToVRAM=false

EnableUnsafeMemoryHacks=false

ReservedMemorySizeMb=512

VideoMemorySizeMb=8192 -> 3072

 

You should alter the bottom most to your VRAM size first and then see if that is stable. Since you use AMD then you might also have to enable some of the above. You should only enable MemoryHacks if you absolutely must. In case of ingame stuttering etc. then alter the two numbers. Always going in powers of 2. Also the VideoMemorySize can only max be around 10Gb... built in limit. You can put in higher but it has not effect. 

ReservedMemory goes down instead of up... should not go below 128Mb, and not above 1024Mb. If I recall correctly. 

 

 

As for the player homes.... then my guess would be that you have some mods that conflict with Hearthfire. Which I cannot tell from just looking at the list since I have not spendt that much time messing with the homes other then making sure my own mods are compatible in tes5edit. 

 

Feel free to bump the thread if you think it is too far down. Just do not overdo it! We are moving threads around atm, so it might get pushed down a bit. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.