Jump to content
  • 0

DSR Patcher error.



Hi all,


So I had gone through STEP Extended and even patched it. All went fine.


I started adding a few extra mods I wanted and started going through the patch process again, bashed patch, DSR, etc. However, when I get to the DSR patch I now get the infamous skyproc.exceptions.MissingMaster error. It says I am missing Skyrim.esm and Update.esm.


The unusual thing is this wasn't a problem when I went through the guide in the first place.


I did at one point move my mods directory over to my SSD drive "after" I had completed STEP the first time. Obviously I was seeing some crazy load times and this is why I moved the mods folder. All ran fine.


So then I started adding those new mods and started the patch process.


I have tried moving the skyrim and update esm's into the overwrite folder and that didn't work.


Can anyone help me resolve this?



Just in case anyone runs into the same problem this solved it for me. Specifically I just used the make link option. Happy modding.



Okay I've been trying to get Skyproc patchers to work with Mod Organizer. I tried both 32 and 64 bit Java. And I tried right clicking on it in the Data tab and using the Open/Execute as well as the Add as Executable options. I even tried running it from the folder itself. The only way I could get it to work was when I manually copied the files to the actual Skyrim data folder. This is the error I would recieve. ================================ skyproc.exceptions.MissingMaster: DualSheath Redux.esp has some missing masters: -Skyrim.esm -Update.esm Please activate and try again. ================================= While it would work if I just did a manual install I wanted to keep all my mods in the virtual directory that Mod Organizer uses. That way it keeps my Skyrim folder structure clean. So here is the fix/work around for those interested in getting skyproc patches to work. Use a Symlink I also recommend using SUM Skyproc manager to merge all your skyproc mod installs into. Even if you're only using one skyproc mod, that way if you decide to add another or remove one it makes for easier management. https://skyrim.nexusmods.com/mods/29865 Open a command prompt and type the following assuming you use default installation paths. Otherwise adjust for your locations. ================================== mklink "C:\Program Files (x86)\ModOrganizer\mods\SUM - SkyProc Unified Manager\Skyrim.esm" "C:\Program Files (x86)\Steam\steamapps\common\Skyrim\Data\Skyrim.esm" mklink "C:\Program Files (x86)\ModOrganizer\mods\SUM - SkyProc Unified Manager\Update.esm" "C:\Program Files (x86)\Steam\steamapps\common\Skyrim\Data\Update.esm" ================================== You can then add the SUM.jar file to your Mod Organizer applications list like normal and it should work. And don't forget anytime you add,remove,update, shuffle mod order you have to rerun your skyproc patches. I hope this helps some of you.

Edited by wolfen420
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

I guess I should note that I found other topics on this and they did NOT resolve the problem. Some one had linked in one post from a while back to something that solved some ones problem with the exact same problem with skyrim and update esm but that link was dead and no comments or clue as to what it was that solved it.


So it would be great if some one could help me out here.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.