Jump to content
  • 0
GrantSP

[ Q & A ] Using FNIS with Mod Organizer

Question

This topic is specifically for FNIS related issues when using Mod Organizer.

 

--

EDIT: 17th April 2016.

Due to @fore's "issues" with MO he has pulled all support and directed it here.

 

Let it be stated that the "issues" he notes are due to user error and there is no inherent issue with FNIS running in MO.

 

Further his claim that FNIS WILL NOT run through MO on Windows 10 machines is just wrong! DO NOT follow the advice he offers regarding using FNIS and MO.

--

 

Setting up FNIS to run through MO

 

Install it like any other mod through MO and make sure it is active (checkmarked) in the left pane mod list.

 

Since you must launch FNIS through Mod Organizer in order for it to recognize your mods, add FNIS to the list of executables by doing the following:

  1. Click the gears icon Gear_MO.png.
  2. In the Title field, type FNIS.
  3. For the Binary field, browse to your FNIS installation (should be located in <ModOrganizer>/mods/Fores New Idles in Skyrim - FNIS/tools/GenerateFNIS_for_Users) and select the GenerateFNISforUsers.exe application.
  4. Click the Add button. This will add FNIS to your executables list.
  5. Click OK.

Now each time you want to run FNIS, simply select it from the drop-down menu at top right and click Run.

 

Running through MO

  1. Launch FNIS through MO
  2. In the Available Patches at the bottom of the window, check the boxes for all necessary patches in your setup.
  3. Click the [update FNIS Behavior] button and wait for a message to appear in the window stating "X animations for Y mods successfully included.".
  4. Click [Exit].

After closing FNIS, there will be files in Overwrite (essentially a fake mod located at the bottom of the left pane if sorted by priority ascending) created by FNIS. Right-click Overwrite and select Create Mod, name it FNIS Output and click OK. This will create a new mod listing in the left pane for the FNIS generated files. You will then need to check it to enable it. Each subsequent time you update FNIS behavior, you must open Overwrite and drag the new files back to this mod.

 

Common Errors

Error 53 or 2012

"Could not find file <path to file>\1hm_behavior.hkx

 

Ensure the animation sets you have installed are correctly placed in priority in the left-hand pane and FNIS is using the one you want. Open the Data tab in the right-hand pane and examine the filetree to see which animation is being used in the VFS.

Navigate the filetree by expanding: data>meshes>actors>character>behaviors> and see which mod is providing the file.

If the file name is displayed in red, the mouse tooltip will show which other mods are also providing this file. Move the correct mod to the correct location.

 

Additional cause for Error 2012

 

A user(@patchling) had Spybot - Search & Destroy+AV 2.5 installed and was constantly getting JIT and 2012 errors, specifically the 0_master.xml was not found. The file was placed in the FNIS temporary_log folder ready for processing but before that could happen it was removed by said program. Opening the start menu > settings > live protection > mode > uncheck "Scan programs before they start" apparently stops that behaviour.

 

*****

Error dialogue

GenerateFNISForUsers.exe - This application could not be started.

This application could not be started.

Do you want to view information about this issue?

 

Simply close the dialogue by pressing "No" and enable FNIS in the Left-hand pane. Correct FNIS installation and use explains this in the wiki.

 

Why does the 6.2 Add-on not look correct in MO?

What you need to remember here is MO is designed to handle 'mods' and what we are installing with FNIS, and its add-ons, are 'tools'.

This means MO is looking for the correct folder structure for a 'mod' as seen by the game. The archive for the 6.2 add-on has as its top folder: "tools" and this is correct for FNIS, not the game.

Simply 'set the data folder' so that the "tools" folder is now at the top of the tree and ignore the next dialogue that asks if you are sure.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

I installed both FNIS and this werewolf mod into the Skyrim structure and ran FNIS from there, exactly the same result as from when I ran it from within MO.

I'm not sure what you are expecting to see but for me at least I can get it to work with MO.

Share this post


Link to post
Share on other sites
  • 0

About 6 months ago I'd been happily running FNIS through Mod Organizer as needed to try various mods for Skyrim.  Then I stopped playing for a few months, upgraded to Windows 10, and tried again a few days ago after downloading some new mods and the latest FNIS files.

 

Although FNIS runs if I execute it through Windows, when I try to call it using Mod Organizer, I get the error "This application could not be started", which according to https://support.micr...n-us/kb/2715633means "The app is not configured in a way that makes it possible to determine the appropriate version of the .NET Framework runtime. The corresponding shim code is SHIM_NOVERSION_FOUND."

 

Do you have any suggestions for me in order to be able to run FNIS through MO and generate the FNIS patch?

Share this post


Link to post
Share on other sites
  • 0

Have you recently updated to Version 4.5.x of Microsoft's .NET Framework?

Apparently Windows 10 won't let you install any .NET Frameworks because that is all supposed to be integrated into Windows.  So the answer is no, but supposedly Windows 10 has got me covered in terms of providing that functionality.

 

EDIT: And to be clear, FNIS seems to run OK through windows, just not when called by Mod Organizer.

Edited by wr1

Share this post


Link to post
Share on other sites
  • 0

That will almost certainly be your issue. When you install 4.5.x, whether via Windows 10 or just installing to any other version of Windows, it'll turn 3.5 off. And you still need 3.5.

 

Found this out the hard way myself.

Share this post


Link to post
Share on other sites
  • 0

.NET should not have to be installed as it is a part of every Windows installation. It may however need to be activated via the 'Turn Windows features on and off' tool in Settings.

 

Upgraded to Win 10 last night and all my current .NET framework settings are still the same and FNIS runs without error from MO for me.

Share this post


Link to post
Share on other sites
  • 0

Supposed to be, but there's things out there still needing older versions of NET. I myself had to get back in and reactivate 3.5 for some things to work after updating to 4.5.x.

Share this post


Link to post
Share on other sites
  • 0

Supposed to be, but there's things out there still needing older versions of NET. I myself had to get back in and reactivate 3.5 for some things to work after updating to 4.5.x.

I was trying to activate some .NET framework stuff.  Do you see anything on the list under .NET framework that maybe I should activate?

 

2ut42a0.png

 

Thanks for any thoughts!

 

(Please let me know if you have any trouble with the image.)

Edited by wr1

Share this post


Link to post
Share on other sites
  • 0

Actually only the main header needs to be checked, neither of those two sub-menus need to be explicitly selected.

On my system neither of them are and I have never had any .NET issues with MO.

Share this post


Link to post
Share on other sites
  • 0

I don't think this is an issue with .NET. I haven't changed my OS, my .NET 3.5 never went inactive, but ever since I've been updating my mods the last couple days, none of my executables have been reading from MO's virtual data folder. So far I've only been testing LOOT and Bodyslide.

 

LOOT reads only the main files and steam DLC

Bodyslide only detects the files in its own folder. If I copy files directly into the bodyslide folder, it reads them, but will not read files in the virtual data folder.

 

I have reinstalled the executables, then reinstalled MO completely, but still have the same issue. Is this a bug in v1.3.8?

Or does anyone have another suggestion?

 

p.s. Yes, yes, yes, I am running the executables through MO, just like I always have, and they always used to work just fine. (since I know the next post would be suggesting that)

 

 

UPDATE--SOLVED my issue:

Turned out, the issue was the Official DLC High Res Textures. MO couldn't open the .bsa's, and I guess stopped setting any other mods up. When I took those files out, everything worked fine again.

 

Guess it turned out to be unrelated, but I honestly thought it wasn't.

Edited by pistachioman25

Share this post


Link to post
Share on other sites
  • 0

@pistachioman25

This topic is specifically for issues relating to FNIS & MO, please post your query in the correct place.

Share this post


Link to post
Share on other sites
  • 0

Both the options under the first subheading in your screenie.

 

 

Actually only the main header needs to be checked, neither of those two sub-menus need to be explicitly selected.

On my system neither of them are and I have never had any .NET issues with MO.

Well, I went and checked both of those sub headings, but no change; FNIS still can't be called by MO.

 

EDIT: I saw Pistachoman's post.  Could it be a problem with the latest version of MO? Given that fully enabling .NET 3.5 didn't do the trick and may not have been the problem...

Edited by wr1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.