Jump to content
  • 0

Script Extender option not appearing under Load Mechanism



I have OBSE installed in the Oblivion directory. In Mod Organizer, when I look under Load Mechanisms Script Extender does not appear. It seems to be working however when I load from MO no esp.s handled by MO are recognized. I've tried reinstalling etc. to no avail. Any thoughts?


- Thanks


Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 0

So I thought that was the problem but I was wrong. I have removed both installs of Oblivion and mod organizer. Reinstalled Oblivion to the steam directory and the mod organizer to my desk top. I installed OBSE according to the instructions in the read me and still MO does not notice that it is installed and as such still does not provide the Script Extender option.


Edit : I now get the script extender option but when I run Oblivion OBSE does not kick in and I get a CTD as the main menu loads. (FYI, I have used LOOT, and loaded everything in TES4Edit with out incident.)

Edited by PrimeNavigator
Link to comment
Share on other sites

  • 0

The script extender functions differently in Oblivion. You can't run Oblivion from MO as the script extender will not load. The game need to be run from Steam and then the OBSE will be started. This is why there is a script extender function in the workaround tab.


I have been playing with the script extender over the last few days and can say it is spotty the way it works. It was working fine as I was adding mods in Hishys guide. I ended for the day and started the next day and had problems.


Make sure that the load mechanism is set to script extender in the workarounds tab and then mod in MO and run the game from Steam. Note that is you change the load mechanism from one setting to another MO will need to be restarted so it can copy or delete some files in the data directory. The Steam in game community needs to be enabled or BOSE will fail to load.


I have been testing a Steam launch from MO and it so far has been working for the OBSE plugins, limited testing though. I created a new executable and pointed the binary to Steam.exe. I added steam://rungameid/22330 to the arguments line. You can run the game from MO when setup this way.


When run you will get the game launcher. If you look at the data only the files in the vanilla directory will show up, MO has not been started yet. If you change options the current profile ini does not get changed, the one in my games will ge modified.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.