Jump to content
  • 0
Sign in to follow this  

CK .bak.x.bak file recovery


I'm sure this is a quick and easy one but I can't find it.   I somehow lost an old CK .esp, but i found a folder that still has the 10 "mod name".bak.x.back files saved (x being a number 0-9).  Can I use this to recover the .esp?  thx!

Share this post

Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

You're not giving a lot of info here so I will be as generic as possible.


If the backup files are just renamed versions of files that have been edited somehow, then yes, renaming the extension to *.esp should work.

However, I have no idea what CK.esp is, how it has been edited or with what, and whether those files are in fact previous versions of that file or just snapshots created during the process of them being modified.


If what you mean by CK .esp is any plugin created with the Creation Kit then the same answers apply. If they are just renamed backups, rename them correctly. If they aren't then you will need to find the originals.


Hope that helps somewhat.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Jordo24
      I'd like to know how to use xedit or the creation kit to make files a .esl, I followed this guide
      and I cant really understand it, if anyone has step by step instructions please let me know!
    • By Bluegunk
      I've happily been using Creation Kit through MO2 the last few days with no issues. This afternoon it refuses to load in MO2 - crashes with the dreaded "Creation Kit has stopped working".
      However, it works outside MO2.
      I'm running Win 10, everything on an SSD away from Program Files.
      I tried reinstalling Creation Kit, reinstalling MO2, running a file verification on the system, checking Registry with CCLeaner, usual restarts etc.  No luck.
      The Windows Error Log gives me this:
      Faulting application name: CreationKit.exe, version:, time stamp: 0x58486f09
      Faulting module name: ucrtbase.dll, version: 10.0.14393.0, time stamp: 0x578997b5
      Exception code: 0xc0000409
      Fault offset: 0x000000000006d5b8
      Faulting process ID: 0x2f60
      Faulting application start time: 0x01d26f5bb7cb358e
      Faulting application path: G:\GAMES\Steam\steamapps\common\Skyrim Special Edition\CreationKit.exe
      Faulting module path: C:\WINDOWS\System32\ucrtbase.dll
      Report ID: d6761478-a6c5-4e10-9da8-db660f12aaf0
      Faulting package full name:
      Faulting package-relative application ID:
      Any help much appreciated! Thank you!
    • By GSDFan
      The following pertains to the developer builds of MO2. This has been tested with the latest build 2017-11-24 with the Update A2. The A3 update will cause the Creation Kit (CK) to report that it is not working and close and the latest version of Fallout 4. This may well work for SkyrimSE and other programs run from MO2. As always this worked for me and your mileage may vary.
      As MO2 is still in Beta and there are numerous problems still being worked on. The two problems I have encountered, one is that the CK will not load at all, this is not a MO2 problem at all, and once it is run, saving will result in a hung not responding CK and the user must terminate the CK manually and lose all work done. I would highly suggest that if you are doing a complex mod to do it in the vanilla environment.
      Problem one, as I stated earlier is not a MO2 problem and is included here to help others, as it can manifest in the vanilla environment also under certain conditions. Especially if the user has installed optional DLLs in the games root folder. In my case I found out that I had a DLL called dxgi.dll. If this DLL is present, the CK will not load when it is launched even from outside of MO. Renaming this DLL will allow the CK to launch. So, for every session you want to run the CK you just must rename dxgi.dll to something else and you are good to go.
      Problem two, not saving from the CK. This will be for the CK run from MO2, but may work for other programs run from MO2. As I understand it, MO2 has a problem when writing files that aren’t already in the VFS system, often resulting in odd behaviors, i.e. not saving newly created files, and hung programs.
      With that in mind I do the following:
      For editing an ESP:
      Open the mod to be worked on in a Windows Explorer window. Open the MO2 Overwrite folder in a Windows Explorer window. Copy, not move, MOD-Name.esp from the mods window to the MO2 Overwrite window. Start the CK and make changes until you are ready to save. When you are finished save your modified mod. It will now be saved to the Overwrite folder. If you are not going to modify anymore, right click the Overwrite folder and select “Sync to Mods…†option. Your mod will be copied to the back to the original mod. The Overwrite folder should now be empty. For converting “MOD-Name.esp†to an esl:
      Copy, not move, MOD-Name.esp from the mods window to the MO2 Overwrite window. Make a copy of “MOD-Name.esp†to “MOD-Name copy.esp†and rename it to “MOD-Name.eslâ€. You can also use a blank ESP to do this. I use a saved blank Bashed Patch, “Bashed Patch, 0.esp†from Wrye Bash, to do this renaming as needed. You should now have “MOD-Name.esp†and “MOD-Name.esl†in the overwrite folder. Copy, not move, the newly created “MOD-Name.esl’ into the mod being worked on folder window. This will make the actions in the last step work for us. Start MO2 and the CK and open the mod to converted, as described above, making it the active mod. From the file menu select the “Compact Active File Form IDs†click through the dialogs until no more show up. From the file menu, select “Convert Active File to Light Masterâ€. Click the dialogs until no more show up. The new ESL will be written to the “MOD-Name.esl†in the Overwrite folder at this time. No need to do anything else in the CK so close it now. Back in MO right click the Overwrite folder and select “Sync to Mods…†option. Your mod will be copied back to the original mod leaving the Overwrite folder empty.  
      For the MCM and MCM mods you need to have the empty data structure in the vanilla “Data†folder. They are MCM\Config and MCM\Settings. With this folder structure present in the Data folder MCM mods will now show up in game.
      I also had some problems with Transfer Settlements mod not saving Blueprints. To correct this, I had to create the following folder structures, “F4SE\plugins\TransferSettlements\Backup†and “F4SE\plugins\TransferSettlements\blueprintsâ€. When present in the vanilla game settlement blueprints will now save in game. When testing this without the folder structure present the Transfer Settlements would complete without any mod added ESPs being listed. With it there I got the list of ESPs I was expecting to see.
      I hope this helps users of the Developer builds have a better experience.
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.