Jump to content
  • 0
Sign in to follow this  
GrantSP

Does the order of 'Packages' ie. PKID matter?

Question

I'm just doing a bit of checking of mods that may or may not be included in certain 'Unofficial' patch mods that are around, specifically I was looking at REPCONNYukichigai Unofficial Patch, and when I loaded them up I noticed 3 Packages are shown as conflicting because REPCONN lists them in reverse order to both FalloutNV & YUP. (yes I know the guide says that isn't included, but things change and maybe...) (for the record, it still isn't included)

 

So my question is: does this truly matter? On the surface it looks like it shouldn't because those are still being handled by the game engine, I can't see why the order things get listed would matter if those records in the same plugin are loaded one way or another.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

xEdit has 2 types of arrays: sorted and unsorted. In sorted arrays the order of elements doesn't matter and you can't move them up/down using right click menu since xEdit itself determines their order for better conflicts resolution. The most common example is leveled lists.

In unsorted arrays you can move elements around manually, their order does matter. Example is conditions.

 

So the rule of thumb - if you can move elements in a list up/down then array is unsorted and order does matter, if you can not move elements then array is sorted and order doesn't matter.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By KillingMachine1914
      Greetings, 
       
      As it was stated in the title, it seems DynDOLOD is not applying modded statue of Azura (Sexy Statues Skyrim v2 NSFW Warning) when generating LODs. When I launch the game, vanilla Azura appears instead of the modded variant. The modded statue of Azura will only appear once I get close enough to it. Also, I installed a mod which resize the statue 2x its normal to make it visible all across Skyrim (Elizabeths Tower - Azura Shrine SSE).
       
      I have checked SSEEdit to see what defines the conflict and it turns out DynDOLOD.esp set the statue as persistent only and removed "is full lod" definition which was there in Elizabeth's Tower. I have very little idea of what those terms mean but my gut tells me that it has something to do with the trouble I am facing currently. Hence, is there a method to overcome this matter? 
       
      Thank you very much in advance.
    • By Newtant
      Hello!

      I've stumbled upon a weird issue that I haven't encountered or read about before. I'm running Windows 8.1 and a fresh install of Fallout New Vegas with no mods so far. I'm trying to get Mod Organizer and the 4GB exe to work together, but despite following all of the advice, tips and workarounds it's still not happening. Right now I can launch the 4GB exe through Mod Organizer. The game starts, I can load a save and 'play'. The problem is that all of the text has disappeared or is invisible. I can only navigate the main menu by memory, the ingame popups regarding the DLC is missing the text as well.

      This issue does not happen if I start the game on its own with the normal exe.
      This issue does not happen if I start the 4GB exe on its own.

      It only happens if I start the either the normal or the 4GB exe through Mod Organizer.

      NVSE is being loaded, it doesn't matter if I'm using NVSE stable or beta.
      I'm using NVAC, without it the game crashes before arriving at the main menu. NVAC seems to be working, the log is showing several handled errors. (Pastebin)
      Yes, I've added '-laaexe .\FalloutMO.exe' to the launch arguments, that helped me get around the access is denied error but produced this text error.
      I did try compatability modes, I've tried starting MO, the 4GB or both as administrator. No dice.

      I've arrived at a point where I really don't know what it could be or what I could try next. One thing I do know, however, is that I can't go back to the pre-MO modding, so I'm turning to you helpful people and hope that someone here has an idea.

      Thanks in advance!
       
      Pictures:
      New Vegas installation folder
      Mod Organizer executable settings
      Disappeared text main menu #1
      Disappeared text main menu #2
      Disappeared text ingame
       
      Edit:
       
      I deleted all of the fallout .inis as well in case some of my text/font settings were messed up, but that didn't work either.
    • By Kelmych
      I'm using MO 1.2.6. All of the Fallout New Vegas BSAs show up in the Archives tab except Update.bsa. Is MO ignoring it or just not showing it in the tab?
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.