Jump to content
  • 0
garybenoak

Profile automatic archive invalidation is unchecked and grayed out

Question

I downloaded MO the other day to learn my way around the program for Skyrim (I first downloaded v1.2.15, but just a few hours ago I downloaded v1.2.16 and the issue is still there). I've already modded with NMM many times in the past so while I may not know much, I'm not completely unfamiliar with modding. I've followed all of Gopher's tutorials and the tutorials that come with MO and everything has went well so far. I even installed a few different mods to see if they were working and they were!

 

But then I got to Profiles. I had heard that go to the Profiles section where you manage them, you need to have the box called "Automatic Archive Invalidation" enabled. I see both that box and the "Local Saves" box, but I can't tick archive invalidation since it's always grayed out (I can however tick Local Saves for what it's worth). Creating a new profile lets me tick that box ONLY if I select "Default Game Settings" when creating it. Nothing else will let me.

 

Let me add that I've tried this with mods enabled, no mods enabled, on a fresh install of Skyrim, with existing saves, with no existing saves, etc. I even uninstalled MO, deleted all traces of it, and reinstalled and still have the same problem.

 

I figured maybe this was intentional in some way? In the Workarounds section, the Backdate BSAs button says that it can be used instead of AI but does that mean I need to press it before I've installed mods, after I've installed them, after I've created a new profile, only one time, or what?

 

I apologize if this is a stupid question, but I can't find anywhere that says anything about this.

 

 

Here are my system specs even though I don't think they're necessary in this context: https://wiki.step-project.com/User:Garybenoak/SystemSpecs

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Welcome to the STEP forum.

Firstly the wiki says in the 'Initial Setup' section:

  1. Turn on the Archive Invalidation method appropriate for your game:
    • If running any game that is not Skyrimclick the profile Profiles_MO.png button in the toolbar and check Automatic Archive InvalidationRepeat this for all new profiles you create.
    • If running Skyrimclick the wrench Wrench_MO.png button, go to the Workarounds tab, and click Back-date BSAs.

Therfore you don't need to check that if you are using Skyrim, as you state you are.

 

Secondly I cannot replicate this with any of my installations. All profiles, whether new or existing, allow me to check that option.

Could you check the installation to ensure nothing is out of place? Perhaps if you could provide the paths to MO, Steam and Skyrim in addition to you Windows environment.

 

Unless we can get this information it will be very hard to pinpoint what is happening and even if a bug report is made all this information will still be needed.

Share this post


Link to post
Share on other sites
  • 0

its grayed out until you run the game for the first time but as grant says, Archive Invalidation is NOT needed in Skyrim.

Share this post


Link to post
Share on other sites
  • 0

Is it really? I didn't know that. How do you remember stuff like that? Perhaps that should be placed in the wiki also. Seems like an essential piece of information.

Share this post


Link to post
Share on other sites
  • 0

The only reason I remember is because in Oblivion I was stumped on why I couldnt enable it and I was stumpt on  why I was getting crashes

Share this post


Link to post
Share on other sites
  • 0

Welcome to the STEP forum.

Firstly the wiki says in the 'Initial Setup' section:

  1. Turn on the Archive Invalidation method appropriate for your game:
    • If running any game that is not Skyrimclick the profile Profiles_MO.png button in the toolbar and check Automatic Archive InvalidationRepeat this for all new profiles you create.
    • If running Skyrimclick the wrench Wrench_MO.png button, go to the Workarounds tab, and click Back-date BSAs.

Therfore you don't need to check that if you are using Skyrim, as you state you are.

 

Secondly I cannot replicate this with any of my installations. All profiles, whether new or existing, allow me to check that option.

Could you check the installation to ensure nothing is out of place? Perhaps if you could provide the paths to MO, Steam and Skyrim in addition to you Windows environment.

 

Unless we can get this information it will be very hard to pinpoint what is happening and even if a bug report is made all this information will still be needed.

MO: C:\Users\Mercury\Documents\Skyrim Mod Organizer

Steam: C:\Program Files (x86)\Steam

Skyrim: C:\Program Files (x86)\Steam\steamapps\common\Skyrim

 

I'm running Windows 7 Ultimate 64 bit. I've also tried running MO as admin but that didn't fix anything.

 

I've ran the game multiple times and it still doesn't allow me to check that box.

 

Like I mentioned in my OP, the automatic archive invalidation option remains grayed out on all profiles UNLESS I select "Default Game Settings" when making a new profile. But again, it did the same thing on my previous modded install, and my fresh install. I haven't changed any of the config/ini files so I don't understand.

 

But if "Back-date BSAs" eliminates the need for that option, is it safe to continue with just that even though the AI option is still grayed out?

Share this post


Link to post
Share on other sites
  • 0

Did you see @hishutup's comment?

At any rate AI isn't a problem with Skyrim. Just continue.

Share this post


Link to post
Share on other sites
  • 0

Did you see @hishutup's comment?

At any rate AI isn't a problem with Skyrim. Just continue.

I did but you implied that the AI option shouldn't be grayed out anyways so I wanted to make sure it wouldn't affect anything else

Share this post


Link to post
Share on other sites
  • 0

My apologies then. As it was some time ago since I installed a game that uses it, I must confess that I simply didn't realize it worked that way. @hishutup works in Oblivion a lot so I trust his memory.

Share this post


Link to post
Share on other sites
  • 0

My apologies then. As it was some time ago since I installed a game that uses it, I must confess that I simply didn't realize it worked that way. @hishutup works in Oblivion a lot so I trust his memory.

Well both of you know much more than me so I appreciate the help

Share this post


Link to post
Share on other sites
  • 0

The only reason I remember is because in Oblivion I was stumped on why I couldnt enable it and I was stumpt on  why I was getting crashes

 

 

My apologies then. As it was some time ago since I installed a game that uses it, I must confess that I simply didn't realize it worked that way. @hishutup works in Oblivion a lot so I trust his memory.

Oh, I have one more question. I reinstalled MO just to get a fresh start since I didn't have anything major set up ATM, and after I clicked "Back-date BSAs", a BSA file called "Skyrim - Invalidation" showed up in my archives section but it's unselected by default. Do I need to check the box myself, or is it supposed to be that way?

Edited by garybenoak

Share this post


Link to post
Share on other sites
  • 0

Check it.

My memory fails me but I think it was checked by default when I installed MO the first time, maybe the behaviour has changed?

At any rate nothing drastic will happen like your game crashing, if you have troubles uncheck it and see. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Sayoregg
      I am using MO2. I installed DynDOLOD in a separate directory than my game and not in program files or anything. In MO2 I added -sse to the arguments for both programs (I'm using the x64 versions of them if that's relevant). Without the arguments the programs give a totally different error so I'm guessing that it isn't the issue. When I do try to run the programs (Both DynDOLOD and texgen), I'm getting this error log. Gonna use TexGen's as an example.
                     [00:00:00.063]    TexGen based on xEdit x64 (DAB7081D) starting session 2021-04-15 10:01:59
                     [00:00:00.073]    Game Mode: SSE
                     [00:00:00.078]    Game Name: Skyrim Special Edition
                     [00:00:00.084]    Using Skyrim Special Edition Data Path: C:\Program Files(x86)\Steam\steamapps\common\Skyrim Special Edition\Data\
                     [00:00:00.089]    Using Backup Path: C:\Program Files(x86)\Steam\steamapps\common\Skyrim Special Edition\Data\SSEEdit Backups\
                     [00:00:00.095]    Using Scripts Path: D:\Programs (D)\DyndoLOD\Edit Scripts\
                     [00:00:00.101]    Using Cache Path: D:\Programs (D)\DyndoLOD\Edit Scripts\DynDOLOD\cache\
                     [00:00:00.107]    Using Temp Path: C:\Users\Sayor\AppData\Local\Temp\SSEEdit\
                     [00:00:00.114]    Using ini: C:\Users\Sayor\Documents\My Games\Skyrim Special Edition\Skyrim.ini
                     [00:00:00.124]    Using save path: C:\Users\Sayor\Documents\My Games\Skyrim Special Edition\Saves\
                     [00:00:00.132]    Using plugin list: C:\Users\Sayor\AppData\Local\Skyrim Special Edition\Plugins.txt
                     [00:00:00.140]    Using settings file: C:\Users\Sayor\AppData\Local\Skyrim Special Edition\DynDOLOD_settings.ini
                     [00:00:00.157]    Using language: English
                     [00:00:00.167]    Using general string encoding: 1252  (ANSI - Latin I)
                     [00:00:00.176]    Using translatable string encoding: 1252  (ANSI - Latin I)
                     [00:00:00.192]    Using VMAD string encoding: 65001 (UTF-8)
                     [00:00:00.202]    Loading active plugin list: C:\Users\Sayor\AppData\Local\Skyrim Special Edition\Plugins.txt
                     [00:00:00.218]    Fatal: Error loading plugin list: <EDirectoryNotFoundException: The specified path was not found>
      I have checked the path it is trying to load "Plugins.txt" from and there wasn't any file called like that there, only a "DynDOLOD_settings.ini". I asked one guy in a discord server for help because I knew he used DynDOLOD. His Plugins.txt file is completely empty, and DynDOLOD worked for him, so I created an empty Plugins.txt file there, yet the programs still give the same error.
    • By Dragoonman
      Firstly, I'll go ahead and explain that I have just over 200 mods in my Skyrim build. I use mod organizer and have followed S.T.E.P as well as several online videos from the likes of Gopher explaining how to install some of the more difficult mods such as perkus maximus. I know how to create merge patches, bash patches, and have cleaned all of my mods (with the exception of Hunterborn and Guard Dialogue Overhaul as their mod pages said not to) with TES5edit.

      However, though my build is stable when exploring interior spaces in Skyrim, I have crashes randomly when exploring the outdoors.

      Sometimes Skyrim will CTD open entering combat while outside. Other times it will CTD when just walking or running around. And sometimes I will talk to an NPC outside and Skyrim will CTD. The only thing I know that the CTDs have in common is that I'm outside when they happen.

      I've run Skyrim Performance Monitor and stay under the 3.1 gb crash limit, so I'm thinking it had to be some sort of script error or perhaps conflicting mods.

      Here is my mod load order.
       
      Here are my PC specs.
       
      I've already edited my SKSE.ini to look like this:
       
       
      I have speedhack enabled on my ENB.
      If someone could take a look at it and tell me if they see some conflicting mods or perhaps a faulty load order, that would be incredible.
       
      My modlist is for me to enjoy a difficult and yet rewarding skyrim which hopefully can look beautiful at the same time. I've seen a few people show off their mod builds which contain even more mods than my own, so hopefully I'm not simply overlooking something silly like a limit.

      I figure it would either be a mod dealing with spawning or combat outdoors, but I haven't really been able to find evidence to back my theory up. Perhaps I installed the patches for my mods in an incorrect order?
       
      The way I have my mods organized is the order in which I install them, so the patches for things like Perkus Maximus, EBD, ASIS, and Dual Sheath Redux are installed in the order that you see them.
       
      I've been trying to make this build stable for over a month now and have done everything short of going through the mods one at a time and disabling them which would take an eternity based on the fact that I would have to repatch everything everytime I disabled a mod. The game is perfectly stable without any of the patches installed and the mods requiring them disabled so far as I could tell, but after the patches are installed things seem to go downhill.
      Any of you experienced modders out there have any ideas? I would prefer to keep all of the mods I currently have, but if I have to chunk some of them in favor of actually being able to play I'll do it, though Perkus Maximus and ASIS are must haves for me.
       
      Thank you in advance! I hope I can get this working before Fallout 4 absorbs all of my interests and consumes me. Please let me know if I need to include any further information.
       
    • By LiquidAurum
      Hi,
      Below is my modlist. I crash to desktop everytime I load a saved game. However, there is one save that loads for a while, but after a while that crashes to desktop as well. Now I assumed at first it's because that was interior, but that doesn't seem to be the case either, as the interior's do load successfully but CTD after a while. I ran loot and did find some conflicting .esp's. and were disabled (ClimatesOfTamriel-Dungeons Hazardous/Hardcore and COT-Interiors-Cold/Warm). Now even after those are unchecked it still CTD. Could htis be a lack of VRAM issue? I don't see how it could be as I've ran this exact ENB befofre (granted almost a year ago). If you guys need the order of my plugins/mods please let me know. 
      Thank you all in advance. 
       
       
      https://drive.google.com/file/d/0B401Ci0KQvVrX29XeU9RdWVZY28/view
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.