Jump to content
  • 0
Sign in to follow this  
Riggsie15

How do I get my system RAM to work with VRAM?

Question

Hi, I thought I'd get back into Skyrim after a couple years.  I'm using STEP to guide my mod installation.  STEP is great for easing me back into the modding circle.

 

One thing I've noticed on forums and videos is people are getting their System RAM and the VRAM to work together to run the extensive mods.  I see the RAM helps out with like 40% of the work load.  My problem is my System RAM is not doing anything.  I'm only 2/3 of the way through STEP and I'm already getting bad stuttering in my Benchmark, mainly coming into Helgen.  I used Skyrim Performance Monitor and have found that my VRAM pretty well maxes out as soon a I start the game, while the RAM hardly moves.

 

10869700_10204350152366456_1659147896011

 

2015-01-04 22:48:00 - TESV
Frames: 10345 - Time: 205625ms - Avg: 50.310 - Min: 9 - Max: 63

 

My Rig:

CPU: Intel® Core i7-2600K CPU @ 3.40GHz

System RAM: 16GB

GPU: 2x GeForce GTX 570

VRAM: 1280MB

Resolution: 1920 x 1080, 60Hz

My rig runs BF4 and Dragon Age Inquisition on ultra!  So I would like to know what the go?

 

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Thanks for link.  This was my memory setup.

[MEMORY]
ExpandSystemMemoryX64=true
ReduceSystemMemoryUsage=true
DisableDriverMemoryManager=false
DisablePreloadToVRAM=false
EnableUnsafeMemoryHacks=false
ReservedMemorySizeMb=512
VideoMemorySizeMb=8126
EnableCompression=true
AutodetectVideoMemorySize=false

 

I've since changed it to:

[MEMORY]
ExpandSystemMemoryX64=true
ReduceSystemMemoryUsage=true
DisableDriverMemoryManager=false
DisablePreloadToVRAM=false
EnableUnsafeMemoryHacks=false
ReservedMemorySizeMb=128
VideoMemorySizeMb=15232
EnableCompression=true
AutodetectVideoMemorySize=false

 

I'll see if it dose any better.

Share this post


Link to post
Share on other sites
  • 0

This was my result.  Still haven't seen the CPU help out.

10914982_10204361840178644_3058261261268

Frames: 12254 - Time: 209883ms - Avg: 58.385 - Min: 5 - Max: 63

 

Have seen a increase in frames though but that is because I droped a lot of the graphics mods.

Share this post


Link to post
Share on other sites
  • 0

Make sure that you have all the ENB files in place (d2d9.dll & enbhost.exe are essential! and have to be in the root directory) and then make sure you haven't disabled the ENBoost feature: https://wiki.step-project.com/Guide:ENB#Global_.28enblocal.29

This is the settings I've been running with:

[GLOBAL]

UsePatchSpeedhackWithoutGraphics=true

UseDefferedRendering=false

IgnoreCreationKit=true

[PERFORMANCE]

SpeedHack=true

EnableOcclusionCulling=true

Share this post


Link to post
Share on other sites
  • 0

So you're running ENBoost only? Do you have enbhost.exe in your root Skyrim directory as well as the d3d9.dll? If you do, start up Skyrim, load a game, run around for a bit, and alt-tab out. Open up Task Manager, click on the Processes tab and see if you see "enbhost.exe" running.

Share this post


Link to post
Share on other sites
  • 0

So you're running ENBoost only? Do you have enbhost.exe in your root Skyrim directory as well as the d3d9.dll? If you do, start up Skyrim, load a game, run around for a bit, and alt-tab out. Open up Task Manager, click on the Processes tab and see if you see "enbhost.exe" running.

Yep they're right next to each other in the Skyrim main directory.  I did what you said and found ENBoots was not running in the Task Manager.  The ENB info comes up in the top left corner when I start the game though.

 

It does come up "Patch SpeedHack is enabled, graphic modification is disabled".

Edited by Riggsie15

Share this post


Link to post
Share on other sites
  • 0

Yep they're right next to each other in the Skyrim main directory.  I did what you said and found ENBoots was not running in the Task Manager.  The ENB info comes up in the top left corner when I start the game though.

 

It does come up "Patch SpeedHack is enabled, graphic modification is disabled".

It should say that whenever only ENBoost is being used. The fact that enbhost.exe is not in Task Manager means it is not running and, thus, ENBoost is not working. Could you post your entire enblocal.ini and a screenshot of your Skyrim directory? Also, when version of the ENBSeries did you download to use?

 

Enclose the INI inside spoiler tags like so:

[spoiler]
Text text text
[/spoiler]

Share this post


Link to post
Share on other sites
  • 0

Righto here's the ini file

 

 

 

[PROXY]
EnableProxyLibrary=false
InitProxyFunctions=true
ProxyLibrary=other_d3d9.dll

[GLOBAL]
UsePatchSpeedhackWithoutGraphics=true
UseDefferedRendering=false
IgnoreCreationKit=true

[PERFORMANCE]
SpeedHack=true
EnableOcclusionCulling=true

[MULTIHEAD]
ForceVideoAdapterIndex=false
VideoAdapterIndex=0

[MEMORY]
ExpandSystemMemoryX64=true
ReduceSystemMemoryUsage=true
DisableDriverMemoryManager=false
DisablePreloadToVRAM=false
EnableUnsafeMemoryHacks=false
ReservedMemorySizeMb=512
VideoMemorySizeMb=15232
EnableCompression=true
AutodetectVideoMemorySize=false

[WINDOW]
ForceBorderless=false
ForceBorderlessFullscreen=false

[ENGINE]
ForceAnisotropicFiltering=false
MaxAnisotropy=16
ForceLodBias=false
LodBias=0.0
AddDisplaySuperSamplingResolutions=false
EnableVSync=true
VSyncSkipNumFrames=0

[LIMITER]
WaitBusyRenderer=false
EnableFPSLimit=false
FPSLimit=60.0

[iNPUT]
//shift
KeyCombination=16
//f12
KeyUseEffect=123
//home
KeyFPSLimit=36
//num /       106
KeyShowFPS=106
//print screen
KeyScreenshot=44
//enter
KeyEditor=13
//f4
KeyFreeVRAM=115

[ADAPTIVEQUALITY]
Enable=false
Quality=0
DesiredFPS=20.0

[ANTIALIASING]
EnableEdgeAA=true
EnableTemporalAA=false
EnableSubPixelAA=true
EnableTransparencyAA=false

[FIX]
FixGameBugs=true
FixParallaxBugs=true
FixAliasedTextures=true
IgnoreInventory=true
FixTintGamma=true
RemoveBlur=false
FixSubSurfaceScattering=true
FixSkyReflection=true
FixCursorVisibility=true

 

 

 

And the directory

10906308_10204402264309222_3006536162092

 

ENBoost v0.265

Share this post


Link to post
Share on other sites
  • 0

Okay...so wow. You have a lot of stuff that shouldn't be in that directory. New Vegas in the Skyrim directory???  :O_o:  Beside that, if you're just using ENBoost, you only need d3d9.dll, enbhost.exe, and enblocal.ini. Delete all other ENB files.

 

Your enblocal.ini looks okay.

Share this post


Link to post
Share on other sites
  • 0

Cool I deleated the enb folder and the enbseries ini.

 

I don't know how the other Bethesda folders got in there.  I've only install the Legendary edition a week ago.  they have .git folders in them.

Edited by Riggsie15

Share this post


Link to post
Share on other sites
  • 0

Hey techangel85, sorry but I ï¸havnt been able to the computer for the last few days. Traveling at the moment. But last I tried it still wasn't working. I'll try changeling the servility settings next chance I get. Thanks.

Share this post


Link to post
Share on other sites
  • 0

10906308_10204402264309222_3006536162092

You have to be trolling! Fallout 3, Fallout New Vegas, Nehrim, and Oblivion in the Skyrim folder AND the "screenshot" was taken with a camera!  :lol:

Edited by fireundubh

Share this post


Link to post
Share on other sites
  • 0

The URL's of your screenshots is apparently associated to some sort of malware (Hijacking) according to this source (And many others, try google it). Maybe virus are to blame for your problems? Try to install and run malwarebytes or something similar and see what it reports.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.