Jump to content
  • 0
Sign in to follow this  
DecayingDesires18

Wrye Bash launched from MO results in corrupted header warning.

Question

Hi everyone,

 

I'm not entirely sure this is the correct thread to post this in. If it isn't, I apologize. However, according to the Wrye Bash page they don't offer support if Wrye Bash is being used with Mod Organizer which I respect, but because of that I'm not sure where else to go.

 

This is the only problem, for now, that I'm currently experiencing in an otherwise stable Skyrim setup. When I launch Wrye Bash from Mod Organizer's list of executables Wrye Bash loads up fine as does every mod except for Enhanced Character Edit. At Wrye Bash's start-up, I receive a pop-up warning labeled 'corrupted headers' and in the box is CharacterMakingExtender.esp. It tells me that this mods header is corrupted. And I have absolutely no idea what that means.

 

Tonight is the first time I've received this error on any Wrye Bash version and with any mod. I haven't changed my ini-tweaks between the time that Wrye Bash would load ECE fine and between it apparently being corrupted. Although my ini-tweaks are essentially vanilla with only a couple very minor tweaks. I began receiving the error with Wrye Bash version 304 and the error still continues when I updated to version 304.3 in an effort to fix this error. 

 

I have downloaded ECE multiple times tonight to make sure that it downloaded completely and wasn't corrupt. The download itself isn't corrupt. It's fine and Mod Organizer is able to install it without error. The esp shows up fine when launching BOSS and BOSS gives no error or warning with it. 

 

However, I'm unsure if this is how it's supposed to be, but the ECE folder in MO's virtual directory shows up with only the esp, not the textures, meshes, scripts, or interface folders. And they aren't showing up MO's overwrite folder either. However, the external installer that ECE uses worked flawlessly, let me choose all the options I wanted, and then I received a notification saying the mod was successfully installed. I have the SKSE plugins in the proper folder as well. 

 

With ECE being marked as corrupt by Wrye Bash the esp doesn't show up in Wrye Bash at all so I'm unable to see any further details about the error aside from it being a corrupted header. I have also goggled this problem and have found a couple threads with people experiencing the same or similar issue, but they either didn't receive any answers or solutions, didn't list the solution they eventually figured out themselves, or the solution was to upgrade to the latest version of Bash which I already did, but to no avail. 

 

My Skyrim is a legal copy that I bought at Best Buy a long time ago. I have the latest Skyrim patch as well as the latest Unofficial Patches. I have only just started a new game with few mods installed so there are no left behind scripts or bloat. I do use a mostly S.T.E.P build with a couple variations, mainly with armor and weapon mods. 

 

I'd really appreciate any help or advice that can be given with this as I'm currently unable to play since I can't edit my character. Thank you all in advance. 

 

 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

You're using the MO 1.2.0 beta version, which includes a broken version of ncc.

ece didn't install correctly and so wrye bash was correct in reporting an error.

Please apply the ncc downgrade from the MO page on nexus or wait for the update to 1.2.1.

Share this post


Link to post
Share on other sites
  • 0

I took the plugin files and installed them (NOT the entire mod) with MO to check the plugin headers with TES5Edit and Wrye Bash. I didn't see any problems, so the headers should be OK. Make sure you have the current Microsoft Visual C++ redistributable (including the 2012 update) as mentioned on the Nexus page for Wrye Bash.

 

First, of course, you need to solve the problem of why it didn't install properly. There are some STEP posts about problems with external installers and the recent versions of MO that might help you.

Share this post


Link to post
Share on other sites
  • 0

Thank you both for the replies. I really appreciate it. First, I'll download the NCC downgrade and report back if that fixes the problem. I'm 99% certain that I have the latest version of Microsoft Visual, but I will download that as well to be sure. 

 

However, with the broken version of ncc likely being the culprit then I have another question, if that's alright. Since the ncc is broken in the latest version then it stands to reason that every single mod I installed with the external installer in the latest version wouldn't have installed properly as well. And yet I only received an error with Extended Character Edit. Does that mean the other mods installed fine despite the ncc being broken or do you recommend reinstalling all the external installer mods with the downgraded ncc just to be on the safe side and avoid a potentially broken game down the line?

 

Update:

 

I installed the downgraded ncc and was able to install Enhanced Character Edit without an error from either Mod Organizer or Wrye Bash, but now other mods that use the external installer that I was going to reinstall to be sure they installed properly aren't installing at all. With those, I'm getting an error from MO saying the mod was not found. 

 

I can't say for sure, but it does seem like the only mod that didn't install properly with the broken ncc was Enhanced Character Edit and all the others installed fine such as Realistic Room Rental Enhanced which uses an external installer, appeared to install fine with the broken ncc, and the MCM menu for it shows up fine with all the options intact. There must just be something about ECE that doesn't play well with the broken ncc. 

Edited by DecayingDesires18

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By frihyland
      Discussion thread:
      Mod Organizer Guide by DoubleYou & Step Modifications
      Wiki Link --> DOCUMENTATION UPDATE TOPIC
       

      This thread is for discussion and improvement of the Mod Organizer Guide on the wiki.
       
       
       
      This thread is for discussion of the Mod Organizer Guide, and should NOT be used for support/troubleshooting. Please use the Official Support Forum for support/troubleshooting.
    • By Sayoregg
      I am using MO2. I installed DynDOLOD in a separate directory than my game and not in program files or anything. In MO2 I added -sse to the arguments for both programs (I'm using the x64 versions of them if that's relevant). Without the arguments the programs give a totally different error so I'm guessing that it isn't the issue. When I do try to run the programs (Both DynDOLOD and texgen), I'm getting this error log. Gonna use TexGen's as an example.
                     [00:00:00.063]    TexGen based on xEdit x64 (DAB7081D) starting session 2021-04-15 10:01:59
                     [00:00:00.073]    Game Mode: SSE
                     [00:00:00.078]    Game Name: Skyrim Special Edition
                     [00:00:00.084]    Using Skyrim Special Edition Data Path: C:\Program Files(x86)\Steam\steamapps\common\Skyrim Special Edition\Data\
                     [00:00:00.089]    Using Backup Path: C:\Program Files(x86)\Steam\steamapps\common\Skyrim Special Edition\Data\SSEEdit Backups\
                     [00:00:00.095]    Using Scripts Path: D:\Programs (D)\DyndoLOD\Edit Scripts\
                     [00:00:00.101]    Using Cache Path: D:\Programs (D)\DyndoLOD\Edit Scripts\DynDOLOD\cache\
                     [00:00:00.107]    Using Temp Path: C:\Users\Sayor\AppData\Local\Temp\SSEEdit\
                     [00:00:00.114]    Using ini: C:\Users\Sayor\Documents\My Games\Skyrim Special Edition\Skyrim.ini
                     [00:00:00.124]    Using save path: C:\Users\Sayor\Documents\My Games\Skyrim Special Edition\Saves\
                     [00:00:00.132]    Using plugin list: C:\Users\Sayor\AppData\Local\Skyrim Special Edition\Plugins.txt
                     [00:00:00.140]    Using settings file: C:\Users\Sayor\AppData\Local\Skyrim Special Edition\DynDOLOD_settings.ini
                     [00:00:00.157]    Using language: English
                     [00:00:00.167]    Using general string encoding: 1252  (ANSI - Latin I)
                     [00:00:00.176]    Using translatable string encoding: 1252  (ANSI - Latin I)
                     [00:00:00.192]    Using VMAD string encoding: 65001 (UTF-8)
                     [00:00:00.202]    Loading active plugin list: C:\Users\Sayor\AppData\Local\Skyrim Special Edition\Plugins.txt
                     [00:00:00.218]    Fatal: Error loading plugin list: <EDirectoryNotFoundException: The specified path was not found>
      I have checked the path it is trying to load "Plugins.txt" from and there wasn't any file called like that there, only a "DynDOLOD_settings.ini". I asked one guy in a discord server for help because I knew he used DynDOLOD. His Plugins.txt file is completely empty, and DynDOLOD worked for him, so I created an empty Plugins.txt file there, yet the programs still give the same error.
    • By Dragoonman
      Firstly, I'll go ahead and explain that I have just over 200 mods in my Skyrim build. I use mod organizer and have followed S.T.E.P as well as several online videos from the likes of Gopher explaining how to install some of the more difficult mods such as perkus maximus. I know how to create merge patches, bash patches, and have cleaned all of my mods (with the exception of Hunterborn and Guard Dialogue Overhaul as their mod pages said not to) with TES5edit.

      However, though my build is stable when exploring interior spaces in Skyrim, I have crashes randomly when exploring the outdoors.

      Sometimes Skyrim will CTD open entering combat while outside. Other times it will CTD when just walking or running around. And sometimes I will talk to an NPC outside and Skyrim will CTD. The only thing I know that the CTDs have in common is that I'm outside when they happen.

      I've run Skyrim Performance Monitor and stay under the 3.1 gb crash limit, so I'm thinking it had to be some sort of script error or perhaps conflicting mods.

      Here is my mod load order.
       
      Here are my PC specs.
       
      I've already edited my SKSE.ini to look like this:
       
       
      I have speedhack enabled on my ENB.
      If someone could take a look at it and tell me if they see some conflicting mods or perhaps a faulty load order, that would be incredible.
       
      My modlist is for me to enjoy a difficult and yet rewarding skyrim which hopefully can look beautiful at the same time. I've seen a few people show off their mod builds which contain even more mods than my own, so hopefully I'm not simply overlooking something silly like a limit.

      I figure it would either be a mod dealing with spawning or combat outdoors, but I haven't really been able to find evidence to back my theory up. Perhaps I installed the patches for my mods in an incorrect order?
       
      The way I have my mods organized is the order in which I install them, so the patches for things like Perkus Maximus, EBD, ASIS, and Dual Sheath Redux are installed in the order that you see them.
       
      I've been trying to make this build stable for over a month now and have done everything short of going through the mods one at a time and disabling them which would take an eternity based on the fact that I would have to repatch everything everytime I disabled a mod. The game is perfectly stable without any of the patches installed and the mods requiring them disabled so far as I could tell, but after the patches are installed things seem to go downhill.
      Any of you experienced modders out there have any ideas? I would prefer to keep all of the mods I currently have, but if I have to chunk some of them in favor of actually being able to play I'll do it, though Perkus Maximus and ASIS are must haves for me.
       
      Thank you in advance! I hope I can get this working before Fallout 4 absorbs all of my interests and consumes me. Please let me know if I need to include any further information.
       
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.