Jump to content
  • 0
Sign in to follow this  
Orangehood

Script Status not Saving

Question

I just finished the Skyrim Revisited Guide by Neo and for some reason, when I load a save that I created after following the guide, all of the scripts restart like when I first created the character. MCM settings aren't saved either.  I'm using MO 0.99.something and I followed the guide to the letter.  When I check my saves folder in my documents/my games, each save has a normal version and an skse one. The skse one is only like 5 kb so I'm pretty sure all of the script data is stored in it and that's all. This makes me think that for some reason, whenever I load, it isn't grabbing the skse save along with the rest of it.  Any help would be greatly appreciated because I load a lot so Skyrim is now basically unplayable due to the time it takes to set everything up again.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

This is probably pretty common if you use existing saves with a fresh install of a major mod guide. It is alwasy recommended to use a new game when using something like SR.

Share this post


Link to post
Share on other sites
  • 0

It is a fresh save. I've experimented with a few settings in MO and each time I make a new game but they all have the same results. The way it acts, its almost like since MO uses a virtual directory, it "reinstalls" those mods every time so it does that... I think I will try moving all of the scripts from the mods folder to the actual skyrim data folder or at least the overwrite folder to see if it works.

 

EDIT: Is there any way in MO, other than searching the mod directory for all of the folders called scripts, to easily move things that are only organized virtually before launch?

Share this post


Link to post
Share on other sites
  • 0

MO has local save games, so maybe that is what the issue is. The scripts that are in the data directory are the same no matter what, but what scripts are running in your save game is what matters. Somehow those got messed up and reset to the beginning.

Share this post


Link to post
Share on other sites
  • 0

I've tried both with local save games off and on. There are no scripts in the data directory, just in MO's virtual directory. My theory is that for whatever reason, when MO launches the game, since it uses the virtual directory, its almost like it opens the saves and THEN adds all the mods which causes them to rerun from the beginning. So I was thinking moving those scripts to a static location in either MO's overwrite or skyrim's data folder might fix the issue but I haven't gotten around to that yet. Also, how does the load mechanism workaround option work? I switched it to script extender but it didn't solve the problem, but should I leave it there or leave it on MO?

Share this post


Link to post
Share on other sites
  • 0

Always start the SKSE with MO, otherwise you are starting the game without the virtual directory.

 

Somehow you have a broken save, not sure how many saves you have tried. I would also go ask if this something that has happened to others on the MO nexus thread. Wolverine and Vuud (DoubleYou on STEP) are pretty good with support and know most issues.

Share this post


Link to post
Share on other sites
  • 0

I know that, I was talking about the option in the workaround section. And I know that, but I don't know how to get an unbroken one lol. And I'll try that.

Share this post


Link to post
Share on other sites
  • 0

First off, if you followed Skyrim Revisited it to the letter, remove Nitpick MO provides that function. Did you install the skse scripts as described in the guide and was there a green good to go message? I don’t think Nitpick will cause that issue, but the SKSE scripts would be a good candidate for that.

 

From your initial post this does not appear to be the case, but are you using Skyrim save helper?

 

From what I understand from my reading is that the save-game.skse file is used to hold information that cannot or should not be saved in the regular save by skse. They do it to avoid save game corruption. I do not know what the content is, but I have read that it is “registrations and other things that can't be saved directlyâ€. If you use Skyrim save helper it will write a new save in the game folder without the skse version. If you load that save you will most likely break your game. The recommendation from the SKSE forum is that if you delete the save-game.skse also delete the save-game.ess.

 

Also try looking at this post from Wolverine, it will show you if the virtual file system is working. https://forum.step-project.com/showthread.php?tid=3583

 

Other than that there is nothing in the SR guide that would cause that problem and i am out of ideas for now.

Share this post


Link to post
Share on other sites
  • 0

What is your script latency? Install Convenient Horses, go into MCM and enable the script latency test, and tell us the results. Also, what version of Skyrim Revisited did you install?

Share this post


Link to post
Share on other sites
  • 0

Script Latency is anywhere between 500 and 5000 with the average around 2000. And Skyrim Revisited is just Neovalen's step modding guide. I did add Requiem, Falskaar, and Wyrmstooth after following his guide if that makes a difference. Everything is checked for compatibility.

 

Also, I am using v.99 as it was the only version that worked with FNIS when I was doing this and I haven't upgraded. Don't know if that's important. And I have already uninstalled Nitpick and I am not using any external save monitor. I don't see how the virtual file system wouldn't be working as it is successfully giving me the content of the mods in the game, just not preserving the status of the scripts.

Share this post


Link to post
Share on other sites
  • 0

Script Latency should be between 50 and 100, so you have way to many scripts running. I'm surprised that your game even starts.

Share this post


Link to post
Share on other sites
  • 0

Script Latency is anywhere between 500 and 5000 with the average around 2000. And Skyrim Revisited is just Neovalen's step modding guide. I did add Requiem, Falskaar, and Wyrmstooth after following his guide if that makes a difference. Everything is checked for compatibility.

 

Also, I am using v.99 as it was the only version that worked with FNIS when I was doing this and I haven't upgraded. Don't know if that's important. And I have already uninstalled Nitpick and I am not using any external save monitor. I don't see how the virtual file system wouldn't be working as it is successfully giving me the content of the mods in the game, just not preserving the status of the scripts.

500 to 5000 (with 2k average)? Woah, I'm with ESRB on this one I'm quite surprised your game is running at all. Post your BOSS logg if you can't figure out which of the mods you installed have scripts.

Share this post


Link to post
Share on other sites
  • 0

I know which mods have scripts because MO shows that. And my game still plays fairly smooth so I don't really plan on deleting them unless I absolutely have to. My concern is just that they restart everytime I load a game, which shouldn't. If that is caused by having too many scripts, I can delete stuff, sure. But I only want to do that if that is the problem, which I kind of doubt. I can post my BOSS log if that would help to determine what is causing my problem though.

Share this post


Link to post
Share on other sites
  • 0

Scripts call functions Init and OnPlayerLoadGame and OnGameReload. The normal script latency should be 50 milliseconds. Yours is 2000 which is 40 times slower than normal. This is obviously a problem, and with so much lag your scripts are not able to call the function(s) they need.

Share this post


Link to post
Share on other sites
  • 0

I have a question. Are you using any character and or save game type managers/ utilities either external or internal to MO?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.