Jump to content
  • 0
Sign in to follow this  
Nearox

How did you solve Transparency Anti-Aliasing for shimmering textures?

Question

I've been running a stable SR install for nearly a week now. However, something really annoys me to the point where I don't want to play anymore(and it annoyed me too in vanilla): While moving around, the textures of trees/grass/windows/foilage/fences etc. - basically anything with transparency - are terribly aliasing. It's like half my screen is vibrating. 

 

I run an i5 2500k @4.3ghz and a HD950 2gb.  I play at 1680x1050 resolution.

 

Here's what I tried:

 

- FXAA Injector: Too blurry and doesn't solve the transparency issue

- SMAA Injector: Generally works great for regular edge detection but has no effect at all on foilage.

- MSAA (x2, x4, x8): Has zero effect on transparency aliasing.

- AMD's Adaptive AA: Enabling this in both Skyrim INI and in CCC. It works and I notice transparency is less, although it doesn't completely remove the issue and parts of the foilage that is further away still shimmers. However the game crashes regularly with this on (even in 2x mode). Also, some textures appear transaprent where they shouldn't be (e.g. some big trees, mosh on rocks in solitude keeps flickering)

- AMD's SuperSampling: Enabling this in CC and enabling Transparency AA in Skyrim INI has the same effect as Adaptive AA but without the artifacts. However, the CTD's are the same. 

 

The latter two options do not max out my VRAM, so it cannot be that the game crashes due to that. Also, my GPU load is at 85-90% which means temps are good. I'm using a FPS limiter at 45. 

 

Are there any other alternatives that can reduce shimmering? I'm running out of ideas...

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

Other then higher game resolutions and/or use an Nvidia card (which use different technology to do the same thing) then not really.

 

Last I checked then the author of ENB was considering doing his own AA code to combat this issue, but who knows when and if that will happen.

 

That some textures appear transparent, is a problem with the textures, not the render. I only have it for some of SFO´s trees, but it is extremely minimal with the right ENB settings.

 

The best bet would be to increase the resolution, and then downsample if your monitor cannot handle higher. However do keep in mind that this voids warranty on your monitor! :)

Share this post


Link to post
Share on other sites
  • 0

Thank you Aiyen. Would you be able to pinpoint me a link or a pastebin to the right ENB settings? I currently only use ENBoost.

 

Also I have been looking for flora texture packs that have higher resolution (like 2k). Thought if I could get my hands on that it would increase texture quality and hopefully reduce some transparency AA. Do you think this will make a difference?

Share this post


Link to post
Share on other sites
  • 0

Since I am currently working on a high res retexture of said flora then I can tell you ...

Helps a bit but does not remove the issue entirely. Also depends on how the texture is made. But ultimately screen resolution, and the lighting does wonders to hide the issue.

 

As for ENB´s... try something out. I do not know your tastes :)

Share this post


Link to post
Share on other sites
  • 0

Alright fair enough. Gonna try messing with the screen resolution, just found a guide on the internet


Bleh it seems that since CCC drivers 13.1 the downscaling 'hack' is no longer possible unless following a very complex procedure editing registry etc. which I don't dare to touch.

Share this post


Link to post
Share on other sites
  • 0

ENB also allows for downscaling. Might be simpler to use. Only limitation is that it only does it in powers of 2 of the current screen resolution.

Share this post


Link to post
Share on other sites
  • 0

Yeah but that is also a problem because increasing height and width x2 is, as I'm sure you know :P, much more than 2x AA because of the higher pixel count.

 

Anyways, I managed to do it and wanna thank you a LOT for suggesting this. There is a german tool to downsample AMD using 12.11 CCC drivers and then installing the new 13.x drivers over it. Did that, works wonders.

 

It decreased my shimmering a lot, though it's still there. With the tool I can adjust downscaling down to the pixel. For instance, my Skyrim seems to work well when I increase both height and width by 40% which, coming from 1680x1050, amounts to 2352x1470. This results in 35fps stable (except when near waterfalls or in the Rift area). However when I increase them to 50%, which amounts to 2520x1576, then my FPS dips below 30fps on average.

 

It's an amazing tool for tweaking the game. I cannot distinguish any difference between downsampling and using SuperSampingAA. However SSAA did use like 300mb more VRAM then when I downsample, even though I get similar quality. The downside is that downsampling reduces my FPS more than SSA does. The resulting image quality is the same but it's a tradeoff between lower FPS (which I can easily regulate to be stable with a FPS limiter) and high VRAM use. High VRAM use, or simply using AdaptiveAA or SSAA, causes my game to occasionally CTD.

 

Therefore, thanks once again for pointing me to this! Been looking for a shimmering solution for a long long time!

 

(if you have any mods of yourself let me know, I'll endorse them :))

Share this post


Link to post
Share on other sites
  • 0

I think I need to do something similar. I'd like to not use an ENB if possible but right now, using native GPU settings gives me the same issues as Nearox with fences, tree shadows, and grass shadows. I tried .ini hacking for a week before I gave up, reinstalled, and started following SR.

 

I think I'm in over my head with this downsampling stuff. I use a Radeon 6950 as well but have a 32inch Samsung TV as a monitor. I don't know what I can do as far as resolution, but native is 1280x720.

Share this post


Link to post
Share on other sites
  • 0

The issue basically boils down to DPI, or pixel density. You should increase your game resolution and then have the GPU scale it down. This is similar to AA, but is a powerful alternative that (as you can read in my previous post) consumes less VRAM if set-up correctly.

 

https://forums.guru3d.com/showthread.php?t=366244

 

Do not follow EDIT3 comments from the above link. Follow EDIT2 instead, which is:

 

https://forums.guru3d.com/showpost.php?p=4511322&postcount=150

 

You do not need to install the 13.x drivers if you don't want. They dont really bring a lot to the hd6000 series: they are msotly focused on the hd7000 series.

 

But I'd first get your SR install 100% up and running before going into this. Although it is a method which takes like 10min work and has little risk :)

 

Try using a value which is like 30 or 40% of your current resolution and see how much FPS it eats (it eats a lot).

 

EDIT: You should also check out RadeonPro if you aren't using that already, just a tip :)

Share this post


Link to post
Share on other sites
  • 0

Not using Radeonpro, will look. I never really had to think about my graphic card before. It always worked very nicely for Skyrim. What brought me to SR was all this weird stuff caused by the GPU drivers (I think) as they've updated.

 

Your solution here does seem like a double-edged sword. Right now, with Unreal Cinema, I get 60fps indoors and 40-50 exteriors and it works okay. I haven't seen too much clashing with CoT yet but am sort of concerned about it. If other ENBs are less demanding, it might be better to use one as they seem to pretty much take care of my AA shadow issues (except the fences, have no idea what's up with those).

Share this post


Link to post
Share on other sites
  • 0

Well if you are worried about speed (i.e., FPS) the only thing you should worry about is staying above 32FPS (this is the goal of the STEP guide and it is said to become unstable if you run long under 32fps).

 

I believe that the game by default has Double-Vsync on. At least that was the case on my install. I think this is the default behaviour. It means that the game runs at either 60fps or, if you go below that, at 30fps (the console versions all run at 30fps). Therefore when your FPS dips from 60-45, the game will technically run at 30FPS, even if it shows a higher fps on the counter (this was the case on my install). This resulted in a sense of microstuttering for me.

 

 

There are two things you can do about this:

 

1. In RadeonPro, make a profile for Skyrim (use TESV.exe and fill in a launcher with skse_loader). Under Tweaks > Vsync Control enable Vsync (do select Double Vsync). Now you'll have 'regular' vsync.

2. Check Dynamic Framerate Control and put it to a value just under your 'average minimum value'. Mine is at 38FPS. The RadeonPro FPS limiter is very good and works much better than the ENB limiter.

3. Make sure that iPresentInterval=0 in Skyrimprefs.ini and that vsync is said to off in enblocal.ini

 

4. Profit: Your game now runs smooth, without stuttering etc. I cannot observe noticeable difference between playing at around 40fps and at 60fps. The big concern is that it is stable and that my GPU load or VRAM is not at 100% all the time but more at like 80-90%, this improves stability and reduces CTDs. Iff your GPU is max loaded most of the time, try to lower the FPS limit a bit. It will reduce the load of the GPU as well.

Share this post


Link to post
Share on other sites
  • 0

That all sounds more doable. For whatever reason, my iPresentInterval is already 0 (cuz of ENB) though I never manually changed it.

 

My game does run smooth and I don't have the transparency AA "shimmer" issues. Will those come back if I follow the above advice?

Share this post


Link to post
Share on other sites
  • 0

The transparency issue depends entirely on resolution or equivalent AA level.

Vsync will do weird screen tearing, and also it is a safeguard against weird physics etc. If you do disable it and your helgen into gets really messed up then that would be why.

The game is designed around the 30FPS mark for reasons already stated.

In general there should not be any issues by having Vsync on. I personally think its one of the most vital featuers to have on, since I really do hate the screen tearing, and I would rather have that not there, then some other fancy shadow effect etc.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.