Jump to content

DynDOLOD 3.00 Alpha 173


sheson

Recommended Posts

On 6/10/2024 at 4:37 PM, sheson said:

It is known that ENB settings affects grass LOD color/brightness. ENB typically does not change the visibility of LOD or transparency of textures. Use tfc to get close to LOD. No logs and no useful screenshots like a close up of LOD with tfc were provided.

What I mean is that enabling ENB fixes the impression of grass LOD only looking green.

Without ENB the LOD grass is matching the full grass types, but the darkness makes the brown grass look the same as the green grass at a distance.

ENB Off:

TheElderScrollsVSkyrimSpecialEditionScreenshot2024_06.12-01_48_33_54.thumb.jpg.eb728a6a4bd0a1887fae361d98ad5c0a.jpg

But with ENB enabled, the green and brown grass can be seen from a distance. I just need to reduce the brightness of the grass LOD slightly to match the shadows on the full grass.

Enb On:

TheElderScrollsVSkyrimSpecialEditionScreenshot2024_06.12-01_48_05_10.thumb.jpg.51a492176ad2c88f652c3d0053dbcd0e.jpg

Link to comment
Share on other sites

3 minutes ago, drift123 said:

What I mean is that enabling ENB fixes the impression of grass LOD only looking green.

Without ENB the LOD grass is matching the full grass types, but the darkness makes the brown grass look the same as the green grass at a distance.

ENB Off:

TheElderScrollsVSkyrimSpecialEditionScreenshot2024_06.12-01_48_33_54.thumb.jpg.eb728a6a4bd0a1887fae361d98ad5c0a.jpg

But with ENB enabled, the green and brown grass can be seen from a distance. I just need to reduce the brightness of the grass LOD slightly to match the shadows on the full grass.

Enb On:

TheElderScrollsVSkyrimSpecialEditionScreenshot2024_06.12-01_48_05_10.thumb.jpg.51a492176ad2c88f652c3d0053dbcd0e.jpg

ENB can light distinctive types of full models (shaders) differently, while typically object LOD is treated the same regardless of what it depicts. The direction light is coming and its color affected how things look.

https://dyndolod.info/Help/Grass-LOD#Settings
In case the grass LOD brightness or color seems off (it might depend on weathers or ENB settings), try different Direct/Ambient settings for grass LOD billboards in TexGen. In addition or alternatively change the GrassBrightnessTop*/ComplexGrassBrightnessTop* and GrassBrightnessBottom*/ComplexGrassBrightnessBottom* settings in ..\DynDOLOD\Edit Scripts\DynDOLOD\DynDOLOD_SSE.ini - those settings help if the color tone is off. Especially the image based lighting effect from ENB has a big impact on the brightness and color tone of the grass LOD. Additional complex grass lighting and time of day settings will obviously not apply to object LOD, as they are separate meshes and shaders. Do not use them so full grass and grass LOD match better for all weathers/times.

https://dyndolod.info/How-LOD-Works
LOD does not cast or receive shadows. This can be mitigated by the ENB distant shadow effect or Screen-Space Shadows.

https://dyndolod.info/Help/Grass-LOD#Internal-Billboards-and-External-Billboards

Link to comment
Share on other sites

Keep getting this error message when running Dyndolod. The page that pops up has no additional information or help explaining the error.

https://imgur.com/kYopadb

Things I have tried:

-restarting my pc

-reinstalling Dyndolod

-rerunning xLodgen and Texgen

-adding Dyndolod, Lodgen, and Texgen as exclusions in Windows Defender

I was running Dyndolod a few days ago and it worked fine. No changes have been made to my mod list, other than textures. Dyndolod will initially run fine, after ~13 minutes it will say waiting for Lodgen64 to run, then for ~15 minutes more nothing else will appear in the log. Then this message appears. Additionally, no log is generated.

Link to comment
Share on other sites

2 hours ago, sasquatch678 said:

Keep getting this error message when running Dyndolod. The page that pops up has no additional information or help explaining the error.

https://imgur.com/kYopadb

Things I have tried:

-restarting my pc

-reinstalling Dyndolod

-rerunning xLodgen and Texgen

-adding Dyndolod, Lodgen, and Texgen as exclusions in Windows Defender

I was running Dyndolod a few days ago and it worked fine. No changes have been made to my mod list, other than textures. Dyndolod will initially run fine, after ~13 minutes it will say waiting for Lodgen64 to run, then for ~15 minutes more nothing else will appear in the log. Then this message appears. Additionally, no log is generated.

Read the first post and/or https://dyndolod.info/Official-DynDOLOD-Support-Forum#Post-Logs which DynDOLOD log, debug log and bugrport.txt (if it exists) to upload when making posts. Read https://dyndolod.info/Official-DynDOLOD-Support-Forum#Post-Logs what to do in case there are no logs in the log folder to upload because the tool is being terminated prematurely.

Do not post screenshots of messages, use the "Copy message to clipboard" link instead and paste the message, as explained in the first post and/or https://dyndolod.info/Official-DynDOLOD-Support-Forum#Post-Logs

Click onto the "Click on this link for additional explanations and help for this message" to open https://dyndolod.info/Messages/Exceptions for further help as explained in the first post and/or https://dyndolod.info/Official-DynDOLOD-Support-Forum#Read-Log-and-Error-Messages. See everything under "Access violation"

Link to comment
Share on other sites

Edit: Nevermind, I see the problem plugin with ignored cells now. Please disregard.

 

Okay, here is a copy/paste of the error message.

[Window Title]
DynDOLOD

[Main Instruction]
Access violation at address 0000000001279942 in module 'DynDOLODx64.exe'.

[Content]
Read of address 0000000000000000.

Click on this link for additional explanations and help for this message

For qualified help and advice or to report a problem make a post on the official DynDOLOD support forum.

[OK] [Exit DynDOLOD]

[Footer]
Online Help | Support Forum | Copy message to clipboard

And here are the logs. https://ufile.io/f/97fo5

Each time I run Dyndolod it gets to "Waiting for LODGenx64Win.exe generating object LOD for Tamriel." then around 15 minutes later terminates with the above error message.  I am using the x64 version. I am not using an antivirus other than Windows Defender, and Texgen, Lodgen and Dyndolod are all set as exceptions. I have 32gb of RAM and the usage is not particularly high while this occurs, averaging around 70%

 

Edited by sasquatch678
Link to comment
Share on other sites

I'm trying to use TexGen64 for my FO4 modlist. I am getting this error when I try to utilize the program.

Spoiler

Using Fallout4 Data Path: E:\Steam\steamapps\common\Fallout 4\Data\
Using Scripts Path: E:\DynDOLOD\Edit Scripts\
Using Temp Path: C:\Users\xxxxx\AppData\Local\Temp\TexGen_FO4\
Using Output Path: E:\DynDOLOD\TexGen_Output\
Using ini: C:\Users\xxxxx\Documents\My Games\Fallout4\Fallout4.ini
Using custom ini: C:\Users\xxxxx\Documents\My Games\Fallout4\Fallout4Custom.ini
Using save path: C:\Users\xxxxx\Documents\My Games\Fallout4\Saves\
Using Creation Club Content list: E:\Steam\steamapps\common\Fallout 4\Fallout4.ccc
Using plugin list: C:\Users\xxxxx\AppData\Local\Fallout4\Plugins.txt
Using settings file: E:\DynDOLOD\Edit Scripts\DynDOLOD\TexGen.ini
Using language: En
Using general string encoding: 1252  (ANSI - Latin I)
Using translatable string encoding: 1252  (ANSI - Latin I)
Using VMAD string encoding: 65001 (UTF-8)
Loading active plugin list: C:\Users\xxxxx\AppData\Local\Fallout4\Plugins.txt
[00:00] Background Loader: starting...
[00:00] Background Loader: [Fallout4 - Textures1.ba2] Loading Resources.
[00:00] Background Loader: Fatal: <Exception: Unknown archive version 0x00000007>
[00:00] Background Loader: finished

I am using the rolled back version 1.10.163 for my playthrough. Game runs fine so I'm not sure why it is saying unknown archive version. Any help is appreciated. I've used your tools many times for Skyrim but this is my first time trying them in Fallout 4. Thanks for the great tools!

Link to comment
Share on other sites

36 minutes ago, someguyidk said:

I'm trying to use TexGen64 for my FO4 modlist. I am getting this error when I try to utilize the program.

  Hide contents

Using Fallout4 Data Path: E:\Steam\steamapps\common\Fallout 4\Data\
Using Scripts Path: E:\DynDOLOD\Edit Scripts\
Using Temp Path: C:\Users\xxxxx\AppData\Local\Temp\TexGen_FO4\
Using Output Path: E:\DynDOLOD\TexGen_Output\
Using ini: C:\Users\xxxxx\Documents\My Games\Fallout4\Fallout4.ini
Using custom ini: C:\Users\xxxxx\Documents\My Games\Fallout4\Fallout4Custom.ini
Using save path: C:\Users\xxxxx\Documents\My Games\Fallout4\Saves\
Using Creation Club Content list: E:\Steam\steamapps\common\Fallout 4\Fallout4.ccc
Using plugin list: C:\Users\xxxxx\AppData\Local\Fallout4\Plugins.txt
Using settings file: E:\DynDOLOD\Edit Scripts\DynDOLOD\TexGen.ini
Using language: En
Using general string encoding: 1252  (ANSI - Latin I)
Using translatable string encoding: 1252  (ANSI - Latin I)
Using VMAD string encoding: 65001 (UTF-8)
Loading active plugin list: C:\Users\xxxxx\AppData\Local\Fallout4\Plugins.txt
[00:00] Background Loader: starting...
[00:00] Background Loader: [Fallout4 - Textures1.ba2] Loading Resources.
[00:00] Background Loader: Fatal: <Exception: Unknown archive version 0x00000007>
[00:00] Background Loader: finished

I am using the rolled back version 1.10.163 for my playthrough. Game runs fine so I'm not sure why it is saying unknown archive version. Any help is appreciated. I've used your tools many times for Skyrim but this is my first time trying them in Fallout 4. Thanks for the great tools!

Please update to the latest version of xLODGen.

Link to comment
Share on other sites

45 minutes ago, DoubleYou said:

Please update to the latest version of xLODGen.

The latest is the beta v.112 right? I'm still getting the error somehow. I don't imagine that my textures are too far from vanilla so I'm just use yours for now.

Link to comment
Share on other sites

14 minutes ago, someguyidk said:

The latest is the beta v.112 right? I'm still getting the error somehow. I don't imagine that my textures are too far from vanilla so I'm just use yours for now.

I reread your question. I see now you said TexGen. This is the xLODGen topic, so I thought you were using xLODGen. Latest TexGen is alpha 171 currently. 

Link to comment
Share on other sites

2 hours ago, DoubleYou said:

Please update to the latest version of xLODGen.

My mistake, I thought this was a catch-all for all of Sheson's mods. I am using the latest versions of all of his mods but I'm still getting that same error. Oh well. In any case I generated the LODs with your mod and everything looks great except tree LODs overwrote the ones from A Forest. I should have paid closer attention. With this and PRP everything looks and runs fantastically. Modding FO4 in 2024 is in a pretty sweet spot, even with the NG debacle.

Edited by someguyidk
Link to comment
Share on other sites

Having major issues getting TexGen to run.  I have used DynDOLOD 3.0 for multiple playthroughs in the past with no issue, and I currently cannot get TexGen to run without crashing and leaving no log behind after about 1 minute of trying to create lods.

I have all the requirements, and have recently just switched from the scripts and dll to the NG version of the plugin in an attempt to get things working.  I am on Skyrim AE 1.6.40.  I have tried using both 32 and 64 bit versions of TexGen.

I have the resources for DynDOLOD being overwritten by everything that is conflicting with it, and have tried reversing these dependencies to no avail. I have been frequently restarting my PC, as well as clearing the TexGenOutput folder every time the program fails and boots to desktop.  Currently on the newest release of DynDOLOD (Alpha 171).

The only new mod I have added to my modlist is Skurkbro's Part 4 which in includes LODs and clutter,  TexGen still does not run upon removing this.

I am really banging my head against the desk with this one if anyone could point me in the right direction.  I would include logs from the folder but like I mentioned, TexGen is not generating them upon what I think is a crash.

Link to comment
Share on other sites

1 hour ago, ExquisiteLemon said:

Having major issues getting TexGen to run.  I have used DynDOLOD 3.0 for multiple playthroughs in the past with no issue, and I currently cannot get TexGen to run without crashing and leaving no log behind after about 1 minute of trying to create lods.

I have all the requirements, and have recently just switched from the scripts and dll to the NG version of the plugin in an attempt to get things working.  I am on Skyrim AE 1.6.40.  I have tried using both 32 and 64 bit versions of TexGen.

I have the resources for DynDOLOD being overwritten by everything that is conflicting with it, and have tried reversing these dependencies to no avail. I have been frequently restarting my PC, as well as clearing the TexGenOutput folder every time the program fails and boots to desktop.  Currently on the newest release of DynDOLOD (Alpha 171).

The only new mod I have added to my modlist is Skurkbro's Part 4 which in includes LODs and clutter,  TexGen still does not run upon removing this.

I am really banging my head against the desk with this one if anyone could point me in the right direction.  I would include logs from the folder but like I mentioned, TexGen is not generating them upon what I think is a crash.

See https://dyndolod.info/Official-DynDOLOD-Support-Forum#Post-Logs
..\DynDOLOD\bugreport.txt - if it exists
If there are no logs or debug logs because the tool is being terminated prematurely, check the Windows Event log for related messages. Add RealTimeLog=1 under [TexGen] or [DynDOLOD] in ..\DynDOLOD\Edit Scripts\DynDOLOD\[TexGen|DynDOLOD]_[GAME MODE].INI respectively. Then execute the tool again to generate the real-time debug log in the Logs folder in real time and upload that.

While the DynDOLOD Resources are irrelevant for TexGen, see https://dyndolod.info/Help/DynDOLOD-Resources
Typically DynDOLOD Resources LOD assets should overwrite everything else unless another mod specifically instructs to overwrite DynDOLOD Resources. Refer to Load/Overwrite Orders for detailed explanations.
Also see https://dyndolod.info/Help/Load-Overwrite-Orders

DynDOLOD DLL NG (or its former alternatives) are irrelevant for TexGen.

https://en.wikipedia.org/wiki/Booting

Link to comment
Share on other sites

11 hours ago, sheson said:

See https://dyndolod.info/Official-DynDOLOD-Support-Forum#Post-Logs
..\DynDOLOD\bugreport.txt - if it exists
If there are no logs or debug logs because the tool is being terminated prematurely, check the Windows Event log for related messages. Add RealTimeLog=1 under [TexGen] or [DynDOLOD] in ..\DynDOLOD\Edit Scripts\DynDOLOD\[TexGen|DynDOLOD]_[GAME MODE].INI respectively. Then execute the tool again to generate the real-time debug log in the Logs folder in real time and upload that.

While the DynDOLOD Resources are irrelevant for TexGen, see https://dyndolod.info/Help/DynDOLOD-Resources
Typically DynDOLOD Resources LOD assets should overwrite everything else unless another mod specifically instructs to overwrite DynDOLOD Resources. Refer to Load/Overwrite Orders for detailed explanations.
Also see https://dyndolod.info/Help/Load-Overwrite-Orders

DynDOLOD DLL NG (or its former alternatives) are irrelevant for TexGen.

https://en.wikipedia.org/wiki/Booting

For whatever reason, adding the RealTimeLog=1  on TexGen ini made it run almost twice as long as it usually does, it still crashed at about the 3 minute mark though, leaving no logs.  I have also re ran SSELodGen to see if that was the issue, but I am still having the same crash.

Here are my real time logs;  https://drive.google.com/file/d/1wuwFXqWPvgZIKAUPmQdSOONnC2vN8Uhn/view?usp=sharing

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.