Jump to content
Sign in to follow this  
z929669

Aspens Ablaze (by mindflux)

Recommended Posts

Discussion topic:
Aspens Ablaze by mindflux
Wiki Link


See mod page for screen compares for all versions. Those screens were created under Step WIP 2.0.0.

I think "Autumnal" is the most vanilla-friendly option, and I think it is also the most realistic.

Share this post


Link to post
Share on other sites
On 8/9/2021 at 4:03 PM, DoubleYou said:

@z929669 Do we need the last option of the fomod installed if using your Aspens Ablaze Addon?

image.png

No, not needed but will not hurt as I describe in the Description of the Add-On. We should keep it unticked in the mod page though.

  • Upvote 1

Share this post


Link to post
Share on other sites

I love the look, but I'm not in love with the animation of the trees. The wobble seems strange. 

Nevermind the performance issue, as that is an LOD issue I need to correct.

Share this post


Link to post
Share on other sites
1 hour ago, DoubleYou said:

I love the look, but I'm not in love with the animation of the trees. The wobble seems strange. 

Nevermind the performance issue, as that is an LOD issue I need to correct.

Yeah, anims are basically vanilla and part of the base mod meshes, which are totally custom and look great but lack the NiNode magic that allows better anims. It doesn't bother me personally. See EVT aspen models to see the structural diff, which is one way to get better anims. Complicated, IMO.

The LOD performance is also an issue with the base crowns, which are high poly to correct for lighting issues that impact deciduous trees in particular. Normal faces must always face a light source to look right, so higher poly count helps to correct. Pines don't have the issue, because their branches basically always are radial at 45 degrees-ish. I spoke with Vurt at length about this issue with my aspen mod, which has lower poly count and suffers quite a bit from this limitation.

IMO, the AA mod itself should further optimize polys and reduce by half again to fix both full and LOD performance. Just correcting the LOD crowns alone would mean more noticeable transition. Could be done though, but I am still learning how to use 3DsMax.

Anims and polys issues are both special problems of deciduous trees I think.

Share this post


Link to post
Share on other sites

I just made a mesh rule to remove the treeaspen from LOD and it mostly fixed the LOD performance issue. If I tll, the performance is fine, so that was how I knew it was LOD. If we use this, it would be good to improve this, as that is quite the fps hit.

Share this post


Link to post
Share on other sites
9 minutes ago, DoubleYou said:

I just made a mesh rule to remove the treeaspen from LOD and it mostly fixed the LOD performance issue. If I tll, the performance is fine, so that was how I knew it was LOD. If we use this, it would be good to improve this, as that is quite the fps hit.

For me, LOD is the whole point though, so removing it from LOD is just a bad idea, IMO. Better to just set billboard for Aspen LOD

Share this post


Link to post
Share on other sites

Agreed. It was just a test to see if that was the issue. Need to regen again with modified rule for it.

Share this post


Link to post
Share on other sites

One of the users for the add-on mentioned that he may optimize the LOD meshes ... makes much more sense to optimize the fill ones though, since they are the same exact thing. I may give it a try at some point if he doesn't.

Share this post


Link to post
Share on other sites
1 hour ago, TechAngel85 said:

I vote we accept this one with the new optimization, it's not worse than the Marsh.

Agree

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Black_Armory
      Hey guys,
      Decided to redo my LODS yesterday, basically wanted them in a higher res. So i opened Texgen and i got this error. I was using it last week and there was no problem with it.
      Does anyone know how i can fix this error?  
      Thanks in advance for any help/advice!
       
      Error: Error copying textures\architecture\windhelm\whruinstone_n.dds to  D:\Games\Modding\DynDOLOD\TexGen_Output\DynDOLOD-temp\textures\architecture\windhelm\whruinstonedark_n.dds   The system cannot find the path specified.
       
      Kind Regards, 
      Tris 
       
       

    • By Ruedii
      I noticed we don't have a mod brainstroming mega thread for people to dump and discuss any cool ideas they have but have no interest in producing and/or ability to do so. 

      Sort of a no bad ideas thing.

      I thought I'd get started.

      In researching other stuff, I noticed that Skyrim dumps (quite literally) the dead bodies.

      It might be a cool mod to create a set of realms of the dead (headed by the various gods and daedra) where you could be sent on some unique missions.  NPCs would be sent to a realm when they die selected based on their alignment and race.  They would be revived as a specter there.  (Warewolves go to the hunting grounds, Nords (both genetic and cultural) go to Sovengard, etc).
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.