Jump to content
dstansberry

Font Size in SSEEdit

Recommended Posts

I have a wee problem. When I start SSEEdit (4.0.3)  the fonts for Records, Messages and Viewer all default to 3pt. As you might imagine, on a 4k screen, 3pt is... challenging, to say the least. I can go to options to change the font size to 7 or 8, but I can find no way to save those settings, so each and every time I run the program, I have to reapply the font increase so as to actually see what I'm doing. 

What am I missing here? 

Share this post


Link to post
Share on other sites
1 hour ago, dstansberry said:

I have a wee problem. When I start SSEEdit (4.0.3)  the fonts for Records, Messages and Viewer all default to 3pt. As you might imagine, on a 4k screen, 3pt is... challenging, to say the least. I can go to options to change the font size to 7 or 8, but I can find no way to save those settings, so each and every time I run the program, I have to reapply the font increase so as to actually see what I'm doing. 

What am I missing here? 

I am able to save theme and fonts without issue. Settings persist. I run xEdit via MO, but I assume it would be the same either way. Try running as admin?

From SSEEdit_log.txt in xEdit root folder:

%LOCALAPPDATA%\Skyrim Special Edition\Plugins.sseviewsettings

This has the xEdit settings, I think. You may need to run as admin for the program to save to this file, or edit manually once you find the settings to modify.

Share this post


Link to post
Share on other sites

I'm running it through MO as well (MO2, if it matters). Do you DO anything to save the fonts? Or does it just remember?  The theme I'm using is... Onyx Blue (which is does remember without issue), but those fonts are driving me batty. I've an administrator account, and the whole setup is on a non-system drive, but I'll give running it as admin a shot and see what happens, and check out  the sseviewsettings. Thanks for the tip!

Share this post


Link to post
Share on other sites

No joy, I'm afraid. As a test, ran the SSEEdit, as an administrator, outside of MO. Sure enough, the fonts were small, so I changed them all to 7pt. Then I exited, and opened plugins.sseviewsettings, and there in the UI section I saw the FontRecordSize (along with FontMessagesSize and FontViewerSize) all listed as 7, just as I had selected. 

Then I opened up SSEdit again, the same way, and the fonts were small. Looking at them in the options menu, they were all listed as 3. Without making any changes, I exited again, and the Plugins.sseviewsettings still shows 7 as the font size. 

I wonder if there's an issue with the Theme overriding the options? I'll test again with no theme at all and see what happens. 

Share this post


Link to post
Share on other sites
25 minutes ago, dstansberry said:

No joy, I'm afraid. As a test, ran the SSEEdit, as an administrator, outside of MO. Sure enough, the fonts were small, so I changed them all to 7pt. Then I exited, and opened plugins.sseviewsettings, and there in the UI section I saw the FontRecordSize (along with FontMessagesSize and FontViewerSize) all listed as 7, just as I had selected. 

Then I opened up SSEdit again, the same way, and the fonts were small. Looking at them in the options menu, they were all listed as 3. Without making any changes, I exited again, and the Plugins.sseviewsettings still shows 7 as the font size. 

I wonder if there's an issue with the Theme overriding the options? I'll test again with no theme at all and see what happens. 

I am using the dark 'carbon' theme without issue. Check the log file and the path to see if there is another settings file in there. Also make changes in the UI, note the time, and check the timestamp of the setting file(s) to verify that the UI settings are updating in the file (sounds like you did that basically though). Also try editing the file directly and checking that the settings are translated in the UI. I would always run xEdit as admin. You should be able to set that behavior in Windows by right clicking the file and editing the config for running the program.

Share this post


Link to post
Share on other sites

The more I look at this, the more I think this may be a font scaling bug in Windows as related to multiple monitors with drastically different resolutions. 

I have two monitors, one at 4k and one at 1K. The 4K monitor is set for 150% scaling, as recommended by Windows. The 1K is set at 100%, so no scaling at all there. But what I've noticed in all of my testing is that when I set SSE to 7pts, it displays in 3 pt. When I set it to 8 pt, it displayed in 4pt. But the sseviewsettings never changes. If I overstate my desired font size (Say, 12pt, it displays in 6pt (which is infinitely more legible than 3pt).

If I open SSEEdit on the 4K monitor, it retains and displays the fonts in the full 12pts. But if I open it on the 1k, it scales that down to 6 points. 

 

Share this post


Link to post
Share on other sites
4 minutes ago, z929669 said:

I am using the dark 'carbon' theme without issue. Check the log file and the path to see if there is another settings file in there. Also make changes in the UI, note the time, and check the timestamp of the setting file(s) to verify that the UI settings are updating in the file (sounds like you did that basically though). Also try editing the file directly and checking that the settings are translated in the UI. I would always run xEdit as admin. You should be able to set that behavior in Windows by right clicking the file and editing the config for running the program.

When I change the font sizes in the program, the data is directly reflected in the sseviewsettings, and they are retained there, and I don't see any other "spot" for settings (I didn't even know about THAT spot until you were kind enough to tell me. At any rate, the immediate solution for me appears to be to (about) double the size I want it to display, if I'm going to continue using it on the 1k monitor. It's holding that, and, as an added bonus, is still suitable for display when I move it over to the 4k (which hardly ever happens anyway). Thanks for your ear and your advice! Finding out about the sseviewsettings file really helped me narrow it down to something I can work with! 

Share this post


Link to post
Share on other sites

Glad you figured something out ;)

12 minutes ago, dstansberry said:

The more I look at this, the more I think this may be a font scaling bug in Windows as related to multiple monitors with drastically different resolutions. 

I have two monitors, one at 4k and one at 1K. The 4K monitor is set for 150% scaling, as recommended by Windows. The 1K is set at 100%, so no scaling at all there. But what I've noticed in all of my testing is that when I set SSE to 7pts, it displays in 3 pt. When I set it to 8 pt, it displayed in 4pt. But the sseviewsettings never changes. If I overstate my desired font size (Say, 12pt, it displays in 6pt (which is infinitely more legible than 3pt).

If I open SSEEdit on the 4K monitor, it retains and displays the fonts in the full 12pts. But if I open it on the 1k, it scales that down to 6 points.

Windows scaling is notorious for causing issues. I would disable it completely if you can deal with the small fonts (which should not be an issue unless your monitor is < 32" or 32*2.54 cm).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.