Jump to content

Recommended Posts

9 minutes ago, gmahadhika91 said:

Help, I'm experiencing distant mountain disappearing when I got farther away than said mountains formation. Notice the red circled distant mountain. How do I fix this? Thank you.

https://imgur.com/a/NZn1q1u

Check my previous post, and examine your LOD distance settings as described.

Share this post


Link to post
Share on other sites
1 minute ago, RogueRim said:

I believe it does include grasses: 

6hVVsFG.jpg

Yes, that looks like grass. pretty thin though.

Check the 2nd post again, troubleshooting, first entry about the object bounds. There might be grass meshes that have no billboards generated because of 0 object bounds.

Share this post


Link to post
Share on other sites
44 minutes ago, z929669 said:

Check my previous post, and examine your LOD distance settings as described.

I'm already using BethIni Ultra setting. Should I crank those numbers up even more?

Also, if it is configurable in skyrimprefs.ini then I don't have to regenerate DynDOLOD for those mountains to be consistently shown, do I?

Share this post


Link to post
Share on other sites
24 minutes ago, gmahadhika91 said:

I'm already using BethIni Ultra setting. Should I crank those numbers up even more?

Also, if it is configurable in skyrimprefs.ini then I don't have to regenerate DynDOLOD for those mountains to be consistently shown, do I?

Read the section "How LOD works in Skyrim" and "Mod Configuration Menu (SkyUI MCM)" in ..\DynDOLOD\docs\DynDOLOD_Manual.html

The static LOD distance settings can be changed at any time, even directly in the game with the DynDOLOD SkyUI MCM Settings as already explained.

Share this post


Link to post
Share on other sites
8 hours ago, z929669 said:

ENB can cause this. If you use an ENB, try switching off in game using Shift + F12 to test.

Otherwise, you can adjust grass color via DynDOLOD_SSE.ini and grass billboard direct/ambient brightness in TexGen to compensate.

It's probably also exacerbated by certain weathers.

 

3 hours ago, sheson said:

Are you reporting a problem with the DynDOLOD 3 alpha that doesn't happen with DynDOLOD 2.x or vanilla LOD for that matter?

Otherwise just increase the LOD distances in the INI or the DynDOLOD SkyUI MCM Settings as explained in the manual.

TYVM! It helped! I started having 15 fps loss and huge stutters with dyndolod thou... It is on medium preset.

Share this post


Link to post
Share on other sites
16 minutes ago, jared_maxwell said:

TYVM! It helped! I started having 15 fps loss and huge stutters with dyndolod thou... It is on medium preset.

DynDOLOD is a set of tools that generates a LOD mod based on the load order and options/settings made by the user. The visual results and the performance impact are what the user chooses it to be. The resource requirements can be less, same or more than the vanilla game while the visual result is always vastly superior.

A single bad INI setting can require more resources than all LOD together. If you use grass LOD with a large LOD level 4 distance , it almost does not matter if medium or high preset was selected. Grass LOD has hundred of thousands of billboards.

Share this post


Link to post
Share on other sites
Just now, sheson said:

DynDOLOD is a set of tools that generates a LOD mod based on the load order and options/settings made by the user. The visual results and the performance impact are what the user chooses it to be. The resource requirements can be less, same or more than the vanilla game while the visual result is always vastly superior.

A single bad INI setting can require more resources than all LOD together. If you use grass LOD with a large LOD level 4 distance , it almost does not matter if medium or high preset was selected. Grass LOD has hundred of thousands of billboards.

It is set to 20k.

Share this post


Link to post
Share on other sites
3 hours ago, sheson said:

There might be grass meshes that have no billboards generated because of 0 object bounds.

I switched from Tamrielic Grass to Folkvangr and it worked on the very first try. Thank you @sheson and @z929669 so much for your continued and unwavering support! I was under the impression that dyndo would work with any grass, but looking back with hindsight, trying a different grass seems like an obvious option. I'm so happy that it works now, it looks awesome. Now I just have to get the colour of the distant grass to more closely match the near grass. 

https://imgur.com/a/HzIvqay I see that there has already been some discussion here about it, so I will begin happily tinkering. I'm so psyched! Skyrim never looked top tier until now :)THANK YOU. 

 

Share this post


Link to post
Share on other sites
1 minute ago, RogueRim said:

I switched from Tamrielic Grass to Folkvangr and it worked on the very first try. Thank you @sheson and @z929669 so much for your continued and unwavering support! I was under the impression that dyndo would work with any grass, but looking back with hindsight, trying a different grass seems like an obvious option. I'm so happy that it works now, it looks awesome. Now I just have to get the colour of the distant grass to more closely match the near grass. 

https://imgur.com/a/HzIvqay I see that there has already been some discussion here about it, so I will begin happily tinkering. I'm so psyched! Skyrim never looked top tier until now :)THANK YOU. 

 

Grass billboards and grass LOD can be generated with any grass mod in the load order. It is all explained in second post and its source ..\DynDOLOD\docs\help\GrassLOD.html and the rest of manual. A couple posts back, the user gigan2 uploaded his TexGen config file for Tamrielic. Either that or updating the objects bounds with CK to make sure all grass billboards are created.

Share this post


Link to post
Share on other sites
14 minutes ago, jared_maxwell said:

Actually - FPS is fine, but it stutters a lot.

LOD does not typically cause stutter since LOD is always loaded. Unless maybe available memory is really low. It is typically the loading of the cell and its full models.

Make sure that No Grass in Objects has OnlyLoadFromCache = True

Share this post


Link to post
Share on other sites
10 minutes ago, sheson said:

LOD does not typically cause stutter since LOD is always loaded. Unless maybe available memory is really low. It is typically the loading of the cell and its full models.

Make sure that No Grass in Objects has OnlyLoadFromCache = True

Yes, it has. It is maybe on cell change, but i can say for sure that disabling dyndolod output increases perfomance and almost eliminates stutters, except some micro ones in riverwood area.

Share this post


Link to post
Share on other sites
7 hours ago, jared_maxwell said:

Yes, it has. It is maybe on cell change, but i can say for sure that disabling dyndolod output increases perfomance and almost eliminates stutters, except some micro ones in riverwood area.

Don''t overload the system with a too busy load order, large textures, large models, high settings etc.. That applies to everything, full or LOD models and textures, grass etc. The LOD mod is created based on the load order on your choices helps. It typically contains 3 LOD types that work independently of each other. All have their own creation options, models and textures and settings in game.

Share this post


Link to post
Share on other sites
2 minutes ago, sheson said:

Don''t overload the system with a too busy load order, large textures, large models, high settings etc.. That applies to everything, full or LOD models and textures, grass etc. The LOD mod is created based on the load order on your choices helps. It typically contains 3 LOD types that work independently of each other. All have their own creation options, models and textures and settings in game.

Just if i had an idea what could possibly cause this...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Jordles
      Hi all, new to the forum and to STEP modding in general, hopefully this isn't too difficult of a problem to solve. I've just about finished with the STEP guide and I'm on the Level of Detail step, but I can't run LodGen. When I try, I get the error message "Fatal: Could not open registry key: \SOFTWARE\BethesdaSoftworks\Fallout4 This can happen after Steam updates, run the game's launcher to restore registry settings"
      I'm very new to modding and not very confident with anything, but I've followed the STEP guide to the letter. FO4 isn't even installed and I'm not sure why it's looking for FO4, in a folder that doesn't exist, for a Skyrim install. 
      The only thing I can think that might have affected it is the fact that I moved the initial MO2 installation to a different drive - however, I've updated all the filepaths to refer to the correct directories. I've added the argument -sse to the command line in MO2 but this hasn't helped - I feel like I'm missing something obvious here, but it's beyond my meagre abilities to figure it out. Any ideas?
       
    • By Whitestar127
      Hi, I have two questions:
      1. Is it possible to save MCM settings somehow? I'm doing a lot of testing now before committing to a save, and it's a chore to have to manually set those settings every time I start a new game. Some mods, like A matter of time, allows saving. But that doesn't appear to be the case for the majority of MCM mods.
      2. Is it possible to have Dof only for under water? I don't like the effect of it on land, but I also don't like being able to see for miles underwater. Would Dynavision help with this? (I'm using ENB).
       
      Thanks
       
      EDIT: Is the answer for 1 simply the .skse file in the saves folder?
    • By Omniguous
      the arguments '-iknowwhatimdoing' and '-allowmasterfilesedit' should NOT be entrenched into the STEP guide.
      for starters: nothing you do with xEdit actually requires the latter one.
      and the first is NOT meant 'simply for disabling a single pop-up': it does much more and the user is /meant/ to -ahem- KNOW WHAT IT IS and WHAT THEY DO. hence, the name.
      This applies to SSE, as well.
      thanks.
  • Recently Browsing   2 members

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.