Jump to content
  • 0
Sign in to follow this  
Alexanderman95

Ultra Trees DynDOLOD not showing past some point

Question

Hello there. 

 

Recently I have encountered a wierd thing, wich might not be a bug, but still I'd like to know how to fix it.

I'm using 3d trees mode with generated ultra trees LODs, but at some point the game does not spawn LODs way in the distance. It's not a big problem when not looking far away, but the moment I look in the distance from some mountain, I can clearly see that there are no LODs for trees.

In the screenshots below you can see how I look at Morthal marsh region and there are no trees at all(1st shot), but if I 'tcl' myself closer, LODs appear(2nd shot), but even past that point you can see how the groung further away is empty.

https://imgur.com/a/MaTpSvb

So I've been trying to regenerate LODs several times, but the problem still stays. 

What exactly might be the cause for this? Are those some .ini file settings, or am I missing something in the DynDOLOD settings that I should change?

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

I think this is likely due to certain INI settings at least in part, but someone chime in if there is more to it:

[TerrainManager]
fBlockLevel0Distance=50000.0000
fBlockLevel1Distance=72500.0000
fBlockMaximumDistance=94000.0000
fSplitDistanceMult=4.0000
fTreeLoadDistance=72500.0000
I'm not sure if tree LOD display is locked to LOD levels 4/8/16 (fBlockLevel*Distance & fBlockMaximumDistance) or strictly governed by fTreeLoadDistance, but you could try increasing some of those values to check. At least you don't need to regenerate DynDOLOD to do this ;)

Share this post


Link to post
Share on other sites
  • 0

These settings are the exact same as you wrote. Probably some other thing.

OK, but those are default for ultra. Try increasing them, load game, compare screens to verify your assumption.

 

Try something like this:

[TerrainManager]
fBlockLevel0Distance=70000.0000
fBlockLevel1Distance=300000.0000
fBlockMaximumDistance=350000.0000
fSplitDistanceMult=4.0000
fTreeLoadDistance=150000.0000
If it works, then isolate which may be affecting tree LOD in your case by throttling all but the value in question.

Share this post


Link to post
Share on other sites
  • 0

Check the log for report that shows if all LOD levels have LOD assets as explained in Docs/trees.ultra/DynDOLOD-Trees.html. Something like:

 

TreeAspen01 [TREE:0006A9E6] meshes\landscape\trees\treeaspen01.nif
	Billboard found, 3D LOD found
	LOD4: meshes\dyndolod\lod\trees\treeaspen01passthru_lod.nif
	LOD8: textures\terrain\lodgen\skyrim.esm\treeaspen01_0006a9e6.dds using Internal
	LOD16: textures\terrain\lodgen\skyrim.esm\treeaspen01_0006a9e6.dds using Internal
Read the chapter How LOD works in the DynDOLOD/Docs/DynDOLOD_Manual.html

 

The LOD distances can also be adjusted in the SkyUI MCM Settings page as explained in the chapter Mod COnfiguration Menu (SkyUI MCM) in the DynDOLOD_Manual.html

Edited by sheson

Share this post


Link to post
Share on other sites
  • 0

I found the problem and fixed it. Completely forgot about FPS Stabilizer mod. Thank you for help, and I apologize for wasting time. 

OK, so to button up what the issue was for you: INI TerrainManager settings were being dynamically altered by "SSE FPS Stabilizer" mod? Meaning that it was the skyrimprefs.ini [TerrainManager] settings?

Share this post


Link to post
Share on other sites
  • 0

Yep. Since my ini file wasn't 'read only' at the moment, I launched the game with the mod. To fix it I had to disable mod and crank those setting waaaay higher than they saved.

Share this post


Link to post
Share on other sites
  • 0

Just for reference, you can set fTreeLoadDistance to 0 if you are using 3d trees, since you are no longer using tree lods, as the trees are input into the object lod.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By sheson
      DynDOLOD DLL for Skyrim, Skyrim Special Edition, Skyrim Anniversary Edition and Skyrim VR
      So far all versions of DynDOLOD use the SKSE plugin PapyrusUtil for the optional dynamic LOD in the game. Starting with version 2.45 there is now the alternative DynDOLOD DLL available.
      The current DLL version is 2.45. It works with dynamic LOD generated by DynDOLOD Standalone 2.45 and newer.
      Read the ..DynDOLOD\Docs\DynDOLOD_DLL.html included in DynDOLOD Standalone for an explanation about DynDOLOD DLL, installation instructions (overwrite papyrus scripts of DynDOLOD Resources) and how it works.
      If there are problems with it, check DynDOLOD_DLL.html and the DynDOLOD FAQ first before posting.
      If a DynDOLOD.DLL version is required for a game version that is not listed below, request it in this thread. First, search this thread if it has been requested already, though. The future will tell how long it takes to release updates.
      Typically a new DynDOLOD.DLL is required for each new game version, but not each new SKSE version. For example a DynDOLOD.DLL compiled with SKSE64 2.0.9 also works with SKSE64 2.0.10 for the same game version.
      Nexus Downloads for DynDOLOD 2.45 and higher
      DynDOLOD DLL for Skyrim
      DynDOLOD DLL SE for Skyrim Special Edition
      DynDOLOD DLL VR for Skyrim VR
      Mega Mirrors:
      DynDOLOD.DLL + Scripts for Skyrim 1.9.32 (overwrite the papyrus scripts included in DynDOLOD Resources)
      DynDOLOD Scripts for Skyrim Special Edition and Skyrim VR (overwrite the papyrus scripts included in DynDOLOD Resources SE)
      DynDOLOD.DLL for Skyrim Special Edition 1.5.39
      DynDOLOD.DLL for Skyrim Special Edition 1.5.50
      DynDOLOD.DLL for Skyrim Special Edition 1.5.53
      DynDOLOD.DLL for Skyrim Special Edition 1.5.62
      DynDOLOD.DLL for Skyrim Special Edition 1.5.73
      DynDOLOD.DLL for Skyrim Special Edition 1.5.80
      DynDOLOD.DLL for Skyrim Special Edition 1.5.97
      DynDOLOD.DLL for Skyrim Special Edition 1.6.318
      DynDOLOD.DLL for Skyrim Special Edition 1.6.323
      DynDOLOD.DLL for Skyrim Special Edition 1.6.342
      DynDOLOD.DLL for Skyrim Special Edition 1.6.353
      DynDOLOD.DLL for Skyrim Special Edition 1.6.629
      DynDOLOD.DLL for Skyrim Special Edition 1.6.640
      DynDOLOD.DLL for Skyrim Special Edition GOG 1.6.659 (untested)
      DynDOLOD.DLL for Skyrim VR 1.4.15
    • By Hypobolic
      Hi,
      So after changing the tree mod I'm using as well as grass and some terrain textures, I'm going through the STEP LOD generation guide, in the DynDOLOD section there are some recommended rules for LOD generation when using A Clear Map of Skyrim. Specifically is says to set the Tree LOD4 rules to use Billboard4, and also notes that the Aspen trees can drop FPS by 30 if this is not done.

      It actually says that Aspen trees are ALWAYS set to tree LOD4, so as not to render branches.
      I am choosing not to use A Clear Map of Skyrim. My question is if the above statement is true for all tree LOD generation, even when not using A Clear Map of Skyrim?
      Even through these recommendations are inset under the heading specifically for A Clear Map of Skyrim, is this true when not using it? 30fps is an alarming number.
      Thanks!
    • By Ease
      I have a problem with two excessively glowing window textures that I've been troubleshooting for several hours now and I cannot seem to figure it out. The problem is only resolved if I disable DynDOLOD and I had to go through my entire load order to figure that out. The almighty Google hasn't found me a whole lot of information on it either. I've read through the Glow LOD section of the dyndolod.info webpage and have messed around with just about every setting I can, but still, I cannot solve this problem. I'm completely open to the idea that it's one of my mods conflicting with DynDOLOD, but I cannot for the life of me figure out what. It may be right under my nose too. I wouldn't be surprised.
      The two windows in question seem to be (according to more informative console) WRTempleOfK01 and WRHouseWind02. 
      Things I have tried:
      Making a fresh save file Disabling any texture mods I am using that change any architecture in Whiterun Disabling my lighting mods Generating LODs without any form of FX, candles, windows glow or any form of LOD glow available Rebuilding ENB shader cache Tweaking window lighting in my ENB settings I've included my mod list as well in case anyone here has a bigger brain than me and can spot the problem just by looking at what I have.
      In the screenshot attached you can see the problem I'm having. Any help on this would be greatly appreciated because I'm not the best at this stuff. Thanks!

      EDIT: Well, after several hours of trying to figure it out, I finally isolated the problem minutes after making this thread. I thought about deleting the thread but instead maybe this might help out someone else in the future. The file causing the issue specifically was in TexGen_Output under textures/architecture/whiterun/wrwindows01_g.dds. I hid the file and now my windows are glowing properly, ending my hours of suffering over a minute detail. 
      Below is a screenshot of the corrected glow on the windows. 

      modlist.txt
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.