Jump to content
  • 0
Sign in to follow this  
JackintheHinter

Random textures don't seem to be processed and I'm not quite sure where the issue is happening.

Question

Hi all, I posted about this issue on reddit and was directed to try here. I am going to be detailed about my issue because I don't want to waste anyone's time, so I apologize if this is a long post. I've tried installing DynDOLOD before and had issues so I've never really bothered with the full thing. I've decided to absolutely get it working since the benefits are great and there's so much helpful documentation. I've followed Seshon's and GamerPoets install guides, and read the the quick start manual, the Skyrim manual, and the SSE manual, and I'm still running into this issue. I'm using MO2 and am running DynDOLOD through it. I do have the -SSE argument for both TexGen64 and Dyndolod64. I'm also running MO2 in administrator mode if that matters. I have checked to make sure my antivirus in not quarantining anything and has all the appropriate exceptions. 

 

I'm getting purple textures on some buildings and scattered LODs, which from what I've read I understand is a texture missing. TexGen and DynDOLOD run fine and complete succesfully. In the log for DynDOLOD. I do get the line:

"Error: Can not find DynDOLOD Resources SE core files required to create improved LOD.

RTFM DynDOLOD_Manual_SSE.html requirements section.  Verify the core files from DynDOLOD Resources SE archive has been installed completly.

Verify the game is starting in the desired game mode. Current mode: SSE"

I do have the -sse argument in. I have also confirmed that the all the DynDOLOD Resource SE core files are installed completely, all the files are there.

 

Below are the images of the LOD issues I'm having. I went into freecam to show it a little closer.

 

https://i.imgur.com/6rTY7fg.jpg

https://i.imgur.com/f3IAx8M.jpg

https://i.imgur.com/mft1L5y.jpg

https://i.imgur.com/de4Rw6s.jpg

 

My mod list is short and simple, just the following:

-Unofficial Skyrim Special Edition Patch
-SkyUI
-PapyarustUtil
-DynDOLOD Resources SE
-Indistinguishable Billboards for Skyrim SE
-TexGen Output
-DynDOLOD Output

 

And my load order: https://i.imgur.com/zPSD4ou.png

post-14729-0-66888600-1566674688_thumb.png

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Can you please explain how DynDOLOD supposedly runs fine and completes successfully but at the same notifies you about the fact that DynDOLOD Resources SE core files are not installed correctly?

 

Are you saying you can generate LOD despite that installation error?

 

DynDOLOD checks if a few a key files exist in the load order. If the OS function returns a file not found message, then the error is triggered.

 

 

 

FAQ: Game: Incomplete static object LOD / LODGen.exe crash

 
A: Make sure DynDOLOD Resources Core Files have been installed completely. Sometimes mod managers fail to download or unpack archives correctly. Use a better mod manager. 
 
 
Add the missing files or otherwise assure the OS returns true for the file checks. UAC,  Antivir, anything installed into special OS folders or DynDOLOD installed into MO or game folder etc.
Edited by sheson
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Sure, I can expand on it. Both Texgen and DynDOLOD would run and complete, displaying the text that they were done and giving me the prompt to save and exit at the end. Despite running all the way through, two instances of the previously mentioned error would appear in the log for Dyndolod, within the first 100 lines. I never got an error message that interrupted the installation or made it quit. I'm attaching the log because I know that must sound very weird (it's got a huge chunk in the middle that worked cut out because of file size upload constraints). But I went through a complete reinstall of Skyrim and DynDOLOD, again, and the error is no longer appearing, so I suppose it doesn't matter that much. I still have the missing textures issue. I've already double and triple checked that all the files are there, readable, and able to pass and execute through antivirus. Everything is installed outside of the Skyrim directory and out of Program Files.

 

I'll keep playing around with solutions and repeat them until I figure it out and report back for posterity. I know it must be user error at this point, but whatever I'm doing wrong repeatedly I don't know.

DynDOLOD_SSE_log.txt

Share this post


Link to post
Share on other sites
  • 0

Use pastebin for large text files or zip them and upload them to a file service.

 

Do not install DynDOLOD into any MO folders.

 

Make sure all files from DynDOLOD Resource SE core files are installed. Compare number of files with right click on folders for example. Compare contents of textures\lod\*.dds specifically.

 

TexGen will generate many of those files as well.

Edited by sheson

Share this post


Link to post
Share on other sites
  • 0

DynDOLOD is definitely installed outside of MO folders, it's in a separate directory not inside MOs hierarchy. Sorry about the text file, I hadn't thought of that. I've got links to the current Dyn and TexGen logs in case you do want to look at them. But I don't think it's an issue with DynDOLOD and this seems to be an isolated case, so I may just try DynDOLOD another time.

 

I rechecked that Resources has all the core files. Thanks for the right click idea, I hadn't thought of that. The Resources mod installed in MO2 and the original Resources do indeed have the same content down to each .dds file. Thanks for your help and patients in this.

 

I hope you don't mind G Drive, most other things are blocked where I am and pastebin has a size limit.

Dyn: https://drive.google.com/open?id=1SYdmbKr1TwpLj160mFV1u4_5aYZi7xPx

TexGen: https://drive.google.com/open?id=1_sP2kHNR2GvwwRqLFLUbnVm_CEonOPrn

Share this post


Link to post
Share on other sites
  • 0

DynDOLOD can not find the textures to add them onto the object LOD texture atlas.

If the texture would exist, but instead is corrupted/wrong format there would be a message.

 

If a texture is not on the object LOD texture atlas, the LODGen process - which generates the object LOD meshes - leaves the texture paths as is, so the game might load them directly.

 

The game also can not find the textures at their default location.

If the texture file would exist, but somehow be corrupted the game typically crashes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By CorneliusC
      Starting a list for all the mods in the current STEP guide, which are in need to be updated (or already are) to work with the current game version 1.6.640. I'm listing only relevant mods in each category (please correct me if i missed anything).
      For a more comprehensive view on SKSE dependencies please see https://modding.wiki/en/skyrim/users/skse-plugins
       
       
    • By mooit
      Hi,
      I'm using DynDOLOD Alpha99...
      In the past I was able to get my distance grass colors more balanced, looking similar, now the farthest distance out is a greener color, then the rest of the grass.
      Here's a screen shot of the grass I am referring to with red boxes around it, that appears greener than the rest...
      Green Grass — Freeimage.host
      I'm using Complex Grass... 
      To balance the colors, is this just playing around the TexGen Direct/Ambient?
      In DynDOLOD I've tried default settings and these settings for the complex grass.
      ComplexGrassBrightnessTopR=0.500 ComplexGrassBrightnessTopR=0.500 ComplexGrassBrightnessTopR=0.500 ; make bottom darker to fake shadowing ComplexGrassBrightnessTopR=0.500 ComplexGrassBrightnessTopR=0.500 ComplexGrassBrightnessTopR=0.500 THANKS
    • By TechAngel85
      Discussion topic:
      Particle Patch for ENB by mindflux
      Wiki Link
       
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.