Jump to content
  • 0
Sign in to follow this  
Infeksion

Fallout 4: Fallout4.ini and Fallout4Prefs.ini questions

Question

After noticing a slow but sure decline in my gaming experience I decided to do a clean install of Fallout 4. On the the first run of the game to create the .ini files I received a notice that Fallout 4 does not recognize my graphics card and all settings are reverted to low quality. I accepted that and proceed with setting the parameters to "Ultra" and exit the game launcher.

 

When I opened the newly created .ini files, I found the Fallout4.ini literally void of data except for this one entry:

 

[Display]

sD3DDevice="NVIDIA GeForce RTX 2080 Ti"

 

In the same directory (Documents\My Games\Fallout 4) The Fallout4Prefs.ini contained the settings I selected during the initial set up procedure.

 

However, in the game directory (G:\Games\Steam...\Fallout4\Fallout4 I found another Fallout4Prefs.ini file created a few minutes after the .ini file in the "My Games" directory with the "low quality" settings:

 

for example:

Fallout4Prefs. ini in "My Games" Directory:

[Display]

...

iShadowMapResolution=4096

iDirShadowSplits=2

uiShadowFilter=3

uiOrthoShadowFilter=3

iAdapter=0

iSize W=2560

iSize H=1440

bFull Screen=1

bBorderless=1

 

Fallout4Prefs.ini in Fallout4\Fallout4 Directory:

[Display]

...

iShadowMapResolution=2048

iDirShadowSplits=3

uiOrthoShadowFilter=2

uiShadowFilter=2

bBorderless=1

bFull Screen=0

iSize H=720

iSize W=1280

 

and many others...

 

My questions are:

1. How to populate the Fallout4. ini file with the correct parameters?

2. Why two different Fallout4Prefs.ini files? I am not sure which one the game is using. Should I even be concerned about this?

 

Any assistance on this matter will be much appreciated.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

The Fallout4Prefs.ini you found in the game folder is not used by the game. It serves as a baseline INI file for the Fallout 4 Launcher when it creates your INI files.

 

You should also have a Fallout4_Default.ini (I might have the filename slightly wrong) in your game folder that is used by the Launcher as a baseline for the Fallout4.ini file you are having trouble with. Please ensure that file exists and is not blank. If it doesn't, let me know. That would cause your Fallout4.ini to not populate correctly.

Share this post


Link to post
Share on other sites
  • 0

Thank you for the response.

 

The Fallout4_Default.ini does exist in the Game Directory and it is populated. I used BethInI to set up and manage my .ini files through the ini path setting (via the MO2 profile route as recommended). All three .ini files are populated correctly in the MO2 INI Editor, and that is sufficient for me. For now the game with the fixes and a few core mods (Unoffical Patch, MCM etc), seem to run stable. I will do the textures etc tonight, and see where we get.

Edited by Infeksion

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By DoubleYou
      Fallout 4 VR Default Values for All Valid INI Settings
      If it's not here, the tweak is most likely bogus, if it follows the same pattern as in previous games. To verify a setting exists, use the getini console command. If it returns "NOT FOUND," it is bogus. (Side note: settings with a u-prefix always returns an "UNKNOWN TYPE" value. This is normal and the setting is still valid.) Plugin INIs have not been tested. I have settled for the same definition of "Default" as I used for the original Skyrim, i.e., the value used when the setting is not explicitly stated in the INI files.
      Do NOT use these as your INI files. This is for reference only at this point.
      Fallout4Custom.ini
      (This is the result of normal use of the game that the custom INI is generated. It may be possible that a base INI file such as Fallout4.ini or Fallout4VR.ini works as well)
      Fallout4Prefs.ini
       
    • By Quade
      So I've been using mod organizer one for a long while but now that I've tried the second version, it doesn't wanna work for me only when using F4SE. Even without mods I run it and up pops an error telling me that a component of the script extender has stopped working. A command line is also run for some reason and spits the attached image below out. I'm at a loss now, is there any way to fix this?

    • By Tomack13
      I have had no issues with fomods running Mod Organizer 2, until now.  I am trying to install "AAF Basic Animations Theme".  I had it installed earlier but had to uninstall it.  When I re-downloaded it, it came up with this error "Installation as fomod failed: No conditions were successful in an 'OR' clause!".  I have tried several times to re-download the mod but keep getting the same error.  As I said, I have had no issues until now.
       
      Could someone assist please.  Thanks in advance.
       
       
       
      I figured it out.  I had installed AAF.esm but had not checked in eather the left side nor the right side.  Once I checked them off MO allowed me to install the "AAF Basic Theme) mod.  
       
      Sorry for cluttering up the forum.  
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.