Jump to content
  • 0
TheFerries

Mod Organizer Can't Run any FOMOD installer

Question

So yeah this is quite a problem, so im following the STEP guide for fallout new vegas (Fear and Loathing) and everything was going fine until the point where I have to install Project Nevada

Everytime I tried to run the FOMOD installer, I just could not run it, it always gives the same error after it tries to load the fomod installer

I've attached a pic.
Incase you can't see the pic, the error says "The Type initializer for "SevenZip.SevenZipLibraryManager" Threw an Exception", then it says "installation Failed (errorcode 5)"

And it happens with every FOMOD installer, like the Flashlight mod and User Interface Organizer

At first i tought it was Winrar (cus it said Sevenzip) so i uninstalled and decided to install 7z, but nope, it fixed nothing
Later I decided to install them manually.. and everything was going well, until I reached Fallout Character Overhaul, and that is a whole different beast to treat manually!

So yeah, I Need help here

Any way to fix this?

post-11990-0-11123100-1509260556_thumb.png

Edited by TheFerries

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

In essence the discussion is about doing a repair on the effect .net installs. You may be able to open up program manager and select the effected .net installs and choose repair and see if that helps your issue or you could follow the directions from Microsoft, From an elevated command prompt run the following:

 

In the meantime, you should be able repair your install by running:
"%windir%\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\ServiceModelReg.exe" /r /x
%windir%\Microsoft.NET\Framework\v3.5\WFServicesReg.exe /c

 

Each line is it's own command, Hope that helps
 

Share this post


Link to post
Share on other sites
  • 0

Thanks for the help, sadly its giving me another problem with the 2 commands

On the first command its giving me an error and telling me that: Web.Config. does not exists
and on the second command its telling me that: Machine.Config. does not exist

Since .Net framework 3.0 and 3.5 uses the configs from 2.0
when I see the config folder for 2.0 i have the following files (in the image attached):

As you can see I Have:

Web.config.default
Machine.config.default

But not the ones that the Commands are asking for.
Is there like, Any way to create the Web.Config and Machine.config file?

post-11990-0-60428000-1509476281_thumb.png

Edited by TheFerries

Share this post


Link to post
Share on other sites
  • 0

You should have both machine.config and web.config in %windir%\Microsoft.NET\Framework\v2.0.50727\CONFIG. If this is the folder you took the screenshot from, you might try running a repair of the Microsoft .NET Framework 2.0 and 3.5 to see if this fixes the issue.

Share this post


Link to post
Share on other sites
  • 0

The screenshot shows that folder indeed

I tried of course running the Framework 2.0, 3.0 or 3.5 installer, but since this is Windows 7, it doesnt work cus all those frameworks already comes with windows 7

Also ran the sfc /scannow command, and while it did fix some stuff the machine.config and web.config files are still missing

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Vidistis
      Hello there, I've been trying to find a way to color the text for separators. The text color is either black and white, but sometimes it's black on a separator that shares the same color of others that have white text. I would really like to be able to control the color of both the separator bar and it's text.
    • By vabatta
      Hi everyone,

      I have a portable installation of MO2 on a different drive than the OS, same drive where Skyrim is installed, and since I updated to Windows 11 I can't start Skyrim through MO2 either with or without all mods, SKSE. If I start it from outside of MO2 in any way, it works fine (with SKSE too). What could be the issue?



    • By DangerousDeraz
      Hey everybody, i ran into an issue that i was hoping someone would help me with.
      last night when i was installing my mods from STEP 2.0.0 Guide, my PC accidentally turned off and on again, after it turned back on and i went to open MO2 i found all my mods rearranged alphabetically into the last separator, and all of them were unticked. as seen in the screenshots.
      Is there a way to revert this and not go through the menace of rearranging all of the 310 mods into their separators? 
      Thanks.  


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.