Jump to content
  • 0
Sign in to follow this  
Ineluki

MO - Access is denied

Question

Hello everyone,

 

I have been using MO on my old computer for a long time and never had issues with it. Few days ago I bought new rig. I installed windows/drivers/updates. I installed steam and games and MO.

When I try to start MO with any .exe file TESV, Launcher, SKSE I get "failed to spawn anyexefile.exe:failed to start process (Access is denied(5)). I checked and I got same thing on Oblivion exe files. I try find solution all over the place but so far nothing helps. What I can tell you is:

 

- Steam client is installed in C:/program files but steamapps with common and games is not. It's in separate folder on D:

 

- I currently have no antivirus or any such program installed

 

- I try run MO as administrator, I set all .exe files in compitability mods to always run as administrator.

 

I installed MO from Skyrim Nexus page. I tried both portable and install version. I changed noting in ini files. Everything is fresh copy. Please help me. I've been banging my head with this for hours and I have no idea what else to do.

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Just to add, I'm using Windows 7. Same windows, same copy I used on old PC where everything worked with no issues. I tried other buttons but nothing works. Loot, TES5Edit, no button when run from MO won't work. When I run manually (aka SKSE_loader.exe from Skyrim folder it works normally).

Share this post


Link to post
Share on other sites
  • 0

I manage to resolve it. After hours of reading similar topics and trying all sort of common solutions like run as admin, check user privileges, check paths of MO keys and such I run on topic where some guy claimed he resolved same issue by removing some windows update. That was on Windows 10 mind you. Now, what I did I DON'T recommend to anyone. Do it only if you're desperate/frustrated like I was and on your own responsibility. I begin to remove windows updates. Not random one, I begin with security updates. I removed by the order they were installed from newest to oldest. Mind you this is windows 7 I'm working on so I didn't remove that update that guy was talking about. I was just pissed enough to give it a shot. I removed about 5 of them before windows asked me to restart. I did. I try run MO again and it worked. Since I removed 5 of them I don't know which one was causing issues. I can't even be sure it caused issues. Honestly f..k me if I know why it didn't want to work and why is working now.

 

I'm sharing this only so you know what desperate measures you can take if you run out of all common sense solutions. And maybe someone can take a look into this and try locate which (if any) updates is causing this problem. Cheers.

Edited by Ineluki

Share this post


Link to post
Share on other sites
  • 0

Just so you know, MO should never be run with Admin privledges. You most likely end up with problems down the line.

 

MO should also be installed in a folder away from the systen UAC protected files. It can go into its own folder on the your main drive or another drive. You do not have to install it in the game folder to work. You will have to had run the game at least once from the launcher to set up registry values before running from MO.

Share this post


Link to post
Share on other sites
  • 0

During the process, I tried to run it with and without admin privileges. First time without because on old PC it worked normally. I begin to apply admin privileges when issue was already present. MO was never installed with UAC files. Both Skyrim and MO were on :D drive during entire process. I installed and de-installed it multiple times. I put it in Skyrim folder once, outside second time but nothing helped. I also run Skyrim each time I reinstalled MO so everything can be properly set. Still nothing helped.

 

I watched multiple videos and read S.T.E.P guide concerning MO when I learned to use it. And as I said I've been using it long time now for both Oblivion and Skyrim so I'm familiar with most things that cause issues. This problem was something different.

 

I will later install back those updates I removed. One by one. I'm actually curious to see will problem reappear.

Edited by Ineluki

Share this post


Link to post
Share on other sites
  • 0

Never run anything as admin. Any files that are written are given admin ownership, meaning you will not be able to make any changes to them while using your normal account.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By irisquexo
      Hi guys I'm new here so hopefully this is the right place to post this.
       
      When I try launching Skyrim SE through Mod Organizer 2 I get the error "REL/Relocation.h(567): failed to open file"
       
      Before this error I was getting the error "REL/Relocation.h(548): failed to open file" but I uninstalled and reinstalled the engine fixes and SKSE libraries. After doing that and relaunching I get the error I mentioned above. Do you guys know what I could have done wrong? I'm really new to messing with mods so it's probably something I did wrong... I've made sure all plugins are enabled and all mods are installed with their masters except for the ones below because I can't find the appropriate mod that goes with it so maybe that could also be the issue. I'm pretty sure I have "Blues Skyrim" but the creator renamed it so that's why MO2 is detecting it as missing. Idk if that's the case with the other ones though.
       
      Missing masters:

      Master                                                                               Required By
       
      Blues Skyrim.esp                                                              Eli_Breezehome [PATCH - DOS (Director's Cut) SE VER1.4] (STD).esp
       
      Skyrim Better Roads - All In One - Merged.esp                Settlements Expanded SE - Skyrim Better Roads Patch.esp, Skyrim Better Roads - All In - One - Merged - PATCHED.esp
       
      Soljund's Sinkhole.esp                                                      Settlements Expanded SE - Soljunds Sinkhole Patch.esp
       
      Tes Arena - Skyrim Frontier Fortress.esp                         Settlements Expanded SE - Legendary Cities Patch - AIO.esp
       
      Whistling Mine.esp                                                           Settlements Expanded SE - Whistling Mine Patch.esp
       
       
       
      also another problem is when I run LOOT it gives me the error 
       
      Loot failed to run
      Errors:
      Cyclic interaction detected: ELE_SSE.esp --[Master]-> SoS_ELE_Patch.esp --[Group]-> Luminosity Lighting Overhaul.esp --[Master]-> SoS_Luminocity_Patch.esp --[Group]-> ELE_SSE.esp
       
       
       
      If anyone knows what I could do to fix this, that would be amazing. Thank you


    • By JackGee
      Hi there peoples,

      First time posting, so if this isn't allowed please just let me know. Looking for a bit of support, as been scratching my head for ages now and getting nowhere.

      I have used MO2 + xEdit in the past and never had any issues with it. However, decided to mod Fallout NV again. When trying to run FNVEdit through MO2, it doesn't seem to complete the action as LOOT tells me after cleaning that it still needs cleaned. I have made sure the installation directory for MO2 isn't in the Fallout folder. It's all on my C drive (SSD). Tried running as admin ect. Clearing read only. Just can't seem to get it working.

      Any advice or help is appreciated.

      Thanks 
    • By Kattmandu
      Since the release of Anniversary Edition, I renamed my Skyrim SE installation folder from 'Skyrim Special Edition' to 'Skyrim Special Edition Classic' before updating the game on Steam.  So now I have both folders in Steam\steamapps\common.
      I have setup MO2 to have two different instances of Skyrim SE (one being Anniversary Edition and the other being just before Anniversary Edition).  I'm using the same Base Folder (F:/Tools/MO2Base/Skyrim) for both instances so I don't have duplicate mods using up disk space.  However, I did create unique subfolders for 'Profiles' and 'Overwrite' (e.g. %BASE_DIR%/AE/profiles and %BASE_DIR%/SE/profiles).
      So, now I have FNIS installed and when I run it through the 'Skyrim Special Edition' instance, it runs as expected.  When I switch to the 'Skyrim Special Edition Classic' instance, FNIS gives me the following warning...
      FNIS Behavior V7.6   11/14/2021 2:35:15 PM
      Generator: F:\Games\Steam\steamapps\common\Skyrim Special Edition Classic\data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe
      Skyrim SE 64bit: ??.??.?? - F:\Games\Steam\steamapps\common\Skyrim Special Edition\ (Steam)
      >>Warning: Expected generator path: F:\Games\Steam\steamapps\common\Skyrim Special Edition\data\tools\GenerateFNIS_for_Users not found<<
      I'm also getting similar pathing error when trying to run DynDOLOD through MO2...
      Error: Can not find DynDOLOD Resources SE core files to create improved LOD.
      Current Data path F:\Games\Steam\steamapps\common\Skyrim Special Edition\Data\
      Is there a way to run these utilities through MO2 with Skyrim SE being in a folder other than 'Skyrim Special Edition'?
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.