Jump to content
  • 0
LePresidente

[WIP] How to build ModOrganizer using Modorganizer-Umbrella

Question

Recommended Posts

  • 0

I'm currently build the MSVC2013 branch so i'll update known issues for that when I encounter an error. Using my work pc so I've never built it before.

Share this post


Link to post
Share on other sites
  • 0

I'm curious if anyone has tried this process under Linux or another *nix using MinGW (or similar)? Python, CMake, 7zip, ... are all readily available on all common (and pretty much all uncommon) distributions, so only the MSVC bit stands in the way of being cross-compiled.

Share this post


Link to post
Share on other sites
  • 0

I'm curious if anyone has tried this process under Linux or another *nix using MinGW (or similar)? Python, CMake, 7zip, ... are all readily available on all common (and pretty much all uncommon) distributions, so only the MSVC bit stands in the way of being cross-compiled.

 

been discussed before I took over. https://github.com/TanninOne/modorganizer-umbrella/issues/16

Share this post


Link to post
Share on other sites
  • 0

Will hopefully be pushing a commit shortly to allow the use of the precompiled Qt install. Should avoid very long build times using umbrella.

Share this post


Link to post
Share on other sites
  • 0

Ok this is a PITA (pain in the ass) can't seem to get past the fact that QT5 in the build doesn't build Qt5WebEngineWidgets so it fails when it gets called in the cmake for mo in the initial build under the umbrella. Might make some changes there, already forked it to my GitHub from Tanninone's  umbrella which is where LePresidente is pointing to. Keep in mind last time I coded it was CoBol and Fortran and that was over 25 years ago and my schooling was over 40 years ago :p Seems to be a good project for my "golden" years. Think I'll do a manual install of qt5.8 and a few edits and see where that takes me. I know the folks over at Chromium made a few changes lately with win 10 and all which is perhaps why this is called out in this program, see ( https://chromium.googlesource.com/chromium/src/+/master/docs/windows_build_instructions.md#Visual-Studio) for details if your interested, so it may take so updates for this. :)

Share this post


Link to post
Share on other sites
  • 0

If it's any consolation I too had those sort of issues with Qt dependencies last time I tried. Could be we're both "old farts"?

Share this post


Link to post
Share on other sites
  • 0

I believe so GrantSP :P but what the hell MO2 is like an old ex that keeps yapping in my ear and I just want to do something..... I just about fell over when I seen all the dependencies of MO2 talk about the mother of builds, I started looking for my punch cards :) https://youtu.be/KG2M4ttzBnY

Edited by Helidoc

Share this post


Link to post
Share on other sites
  • 0

Ok so i stopped pushing commits to tannins Repo, My bad.

 

Currently my Master branch uses the QT Binary install so that should help you out alot. 

Edited by LePresidente

Share this post


Link to post
Share on other sites
  • 0

Ok so i stopped pushing commits to tannins Repo, My bad.

 

Currently my Master branch uses the QT Binary install so that should help you out alot. 

How are you handling Networkx 1.11 vs 2.0 my system wants to use 2.0 by default?

Share this post


Link to post
Share on other sites
  • 0

How are you handling Networkx 1.11 vs 2.0 my system wants to use 2.0 by default?

 

my Master branch only uses Networkx 2.0 now, Though its for the drawing of the graphs which is not really required for the build process so I might just remove it.

Share this post


Link to post
Share on other sites
  • 0

Ahh ok when I attempted Tannin's branch I had to force install 1.11 or it would error out on the build. The build I'm wanting to work on is to add esl functionality to it so that MO2 can see the New CC addon's etc, something to do in my "golden years"

Edited by Helidoc

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Vidistis
      Hello there, I've been trying to find a way to color the text for separators. The text color is either black and white, but sometimes it's black on a separator that shares the same color of others that have white text. I would really like to be able to control the color of both the separator bar and it's text.
    • By vabatta
      Hi everyone,

      I have a portable installation of MO2 on a different drive than the OS, same drive where Skyrim is installed, and since I updated to Windows 11 I can't start Skyrim through MO2 either with or without all mods, SKSE. If I start it from outside of MO2 in any way, it works fine (with SKSE too). What could be the issue?



    • By DangerousDeraz
      Hey everybody, i ran into an issue that i was hoping someone would help me with.
      last night when i was installing my mods from STEP 2.0.0 Guide, my PC accidentally turned off and on again, after it turned back on and i went to open MO2 i found all my mods rearranged alphabetically into the last separator, and all of them were unticked. as seen in the screenshots.
      Is there a way to revert this and not go through the menace of rearranging all of the 310 mods into their separators? 
      Thanks.  


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.