Jump to content
  • 0
Sign in to follow this  
TIGERSHARK27

Confused with ESP order from AMB-BoS - Content Addon

Question

I'm nearing completion of my mod list (still need ELFX and will look into an ENB preset), and I just successfully installed the STEP Compilation Installer - High Res - 2.10 into my mod list, choosing the Extended Patch.  I ran LOOT (had been doing throughout installations) and came up with no dirty edits (already cleaned necessary files) and no warnings, but one error - Even Better Quest Objectives requires the aMidianborn_Skyforge_Weapons.esp to be installed, but on the AMidianBorn Book of Silence STEP wiki page, it says at the very bottom (Final step):

 

Required: Depending on where you installed the mod, ie. the name of the mod that you used, right click the aMidianBorn Book of Silence or aMidianBorn Book of Silence WEAPONS mod and click [information...]. Click the Optional ESPs tab and move aMidianborn_Skyforge_Weapons.esp from the lower pane to the upper pane.
 
I believe that infers I'm deactivating it, according to the description upon hovering over the esp when at that screen (Information, upon right-clicking a mod).  I haven't tried running Skyrim, but I assume the error would cause a CTD.  I did also notice that Even Better Quest Objectives has an available ESP (by default active) called BetterQuestObjectives-AMBSkyforgePatch.esp which could be related.  Perhaps moving that plugin to the upper pane as well would fix the error/dependency?
 
I assumed the aMidianBorn - Book of Silence Content Add-on covered this somehow, and on the official AMB Content Add-On page https://forums.nexus...owtopic=2678959, it mentions to disable the aMidianborn_Skyforge_Weapons.esp (as well as two other esps I don't seem to have) and that "a separate patch for this mod is not needed, but you must load the Content Addon file AFTER Better Quest Objectives."
which I have done (set as a metadata rule in LOOT).
 
It should be noted I have not used Wrye Bash yet, in case that is applicable.  Thanks for any help!

Edited by GrantSP

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I was cleaning up this post from the ugly copy paste I did, but apparently I can no longer edit it since it's over 15 minutes old... sorry it looks that way.  Wish I could change it.

Share this post


Link to post
Share on other sites
  • 0

I had a hard time reading your post, but I'll give this a whirl, as I am installing the new version of STEP as well. Let me make sure I understand the problem - LOOT is telling you that EBQO is requiring the skyforge weapons ESP?

 

If that's the case, something's wrong, since the two don't even touch each other. Or shouldn't. I've never seen that callout, and it makes me wonder if you installed some odd variant of EBQO or a patch for it that you don't need?

 

A list of the relevent portions of the load order may be helpful here... IE, just mods that relate to EBQO and the BoS.

Share this post


Link to post
Share on other sites
  • 0

BetterQuestObjectives-AMBSkyforgePatch.esp is only installed if you check aMidianBorn Skyforge Weapons in EBQO's installer. It shouldn't be checked. The patch is not needed if you're using content addon from Book of Silence.

 

TIGERSHARK27, it would be best if you reinstalled EBQO and made sure that the only selected options are the ones required by STEPhttps://wiki.step-project.com/Even_Better_Quest_Objectives

 

If something isn't listed, it should be left unchecked.

Share this post


Link to post
Share on other sites
  • 0

I didn't select any patch options in the installer, because it said not to if you're going to use the Extended Patch.  I moved the EBQO esp to optional and it fixed the issue, but I reinstalled it anyway, which also fixed the issue.

 

Having way worse CTD problems now though... (unrelated to this).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By irisquexo
      Hi guys I'm new here so hopefully this is the right place to post this.
       
      When I try launching Skyrim SE through Mod Organizer 2 I get the error "REL/Relocation.h(567): failed to open file"
       
      Before this error I was getting the error "REL/Relocation.h(548): failed to open file" but I uninstalled and reinstalled the engine fixes and SKSE libraries. After doing that and relaunching I get the error I mentioned above. Do you guys know what I could have done wrong? I'm really new to messing with mods so it's probably something I did wrong... I've made sure all plugins are enabled and all mods are installed with their masters except for the ones below because I can't find the appropriate mod that goes with it so maybe that could also be the issue. I'm pretty sure I have "Blues Skyrim" but the creator renamed it so that's why MO2 is detecting it as missing. Idk if that's the case with the other ones though.
       
      Missing masters:

      Master                                                                               Required By
       
      Blues Skyrim.esp                                                              Eli_Breezehome [PATCH - DOS (Director's Cut) SE VER1.4] (STD).esp
       
      Skyrim Better Roads - All In One - Merged.esp                Settlements Expanded SE - Skyrim Better Roads Patch.esp, Skyrim Better Roads - All In - One - Merged - PATCHED.esp
       
      Soljund's Sinkhole.esp                                                      Settlements Expanded SE - Soljunds Sinkhole Patch.esp
       
      Tes Arena - Skyrim Frontier Fortress.esp                         Settlements Expanded SE - Legendary Cities Patch - AIO.esp
       
      Whistling Mine.esp                                                           Settlements Expanded SE - Whistling Mine Patch.esp
       
       
       
      also another problem is when I run LOOT it gives me the error 
       
      Loot failed to run
      Errors:
      Cyclic interaction detected: ELE_SSE.esp --[Master]-> SoS_ELE_Patch.esp --[Group]-> Luminosity Lighting Overhaul.esp --[Master]-> SoS_Luminocity_Patch.esp --[Group]-> ELE_SSE.esp
       
       
       
      If anyone knows what I could do to fix this, that would be amazing. Thank you


    • By JackGee
      Hi there peoples,

      First time posting, so if this isn't allowed please just let me know. Looking for a bit of support, as been scratching my head for ages now and getting nowhere.

      I have used MO2 + xEdit in the past and never had any issues with it. However, decided to mod Fallout NV again. When trying to run FNVEdit through MO2, it doesn't seem to complete the action as LOOT tells me after cleaning that it still needs cleaned. I have made sure the installation directory for MO2 isn't in the Fallout folder. It's all on my C drive (SSD). Tried running as admin ect. Clearing read only. Just can't seem to get it working.

      Any advice or help is appreciated.

      Thanks 
    • By Kattmandu
      Since the release of Anniversary Edition, I renamed my Skyrim SE installation folder from 'Skyrim Special Edition' to 'Skyrim Special Edition Classic' before updating the game on Steam.  So now I have both folders in Steam\steamapps\common.
      I have setup MO2 to have two different instances of Skyrim SE (one being Anniversary Edition and the other being just before Anniversary Edition).  I'm using the same Base Folder (F:/Tools/MO2Base/Skyrim) for both instances so I don't have duplicate mods using up disk space.  However, I did create unique subfolders for 'Profiles' and 'Overwrite' (e.g. %BASE_DIR%/AE/profiles and %BASE_DIR%/SE/profiles).
      So, now I have FNIS installed and when I run it through the 'Skyrim Special Edition' instance, it runs as expected.  When I switch to the 'Skyrim Special Edition Classic' instance, FNIS gives me the following warning...
      FNIS Behavior V7.6   11/14/2021 2:35:15 PM
      Generator: F:\Games\Steam\steamapps\common\Skyrim Special Edition Classic\data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe
      Skyrim SE 64bit: ??.??.?? - F:\Games\Steam\steamapps\common\Skyrim Special Edition\ (Steam)
      >>Warning: Expected generator path: F:\Games\Steam\steamapps\common\Skyrim Special Edition\data\tools\GenerateFNIS_for_Users not found<<
      I'm also getting similar pathing error when trying to run DynDOLOD through MO2...
      Error: Can not find DynDOLOD Resources SE core files to create improved LOD.
      Current Data path F:\Games\Steam\steamapps\common\Skyrim Special Edition\Data\
      Is there a way to run these utilities through MO2 with Skyrim SE being in a folder other than 'Skyrim Special Edition'?
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.