Jump to content
  • 0
Rayen42

Mod Organizer v2.0.8.3 and usvfs_x86.dll

Question

uhhhh, I don't know if anyone had this problem before because I was lurking around and no one seems to have this but every time I open loot or fnis THROUGH mod organizer, I get this:

 

https://gyazo.com/ef0bd9f53aced91f9c72a2affa870718 (this goes for both loot and fnis)

 

i tried searching for the usvfs_x86.dll online but i couldn't find any

 

It then would give me the "parameter is incorrect 87" error but when I open it again, it'll give me the usvfs_x86 error BUT this time loot will launch without any of my plugins on the list 

 

https://gyazo.com/9defe578a7151ba481c7416abb724097

 

FNIS.esp shows up here because I installed it directly to my Skyrim/Data folder as doing it through the "mods" folder of MO would not work, it would give me a skyrim bad installation instead, basically like this 

 

https://gyazo.com/d6765d4ecda1b4b90552ca9c5d7147b6

 

 (this is just a random photo i found but its similar to what I used to have till i moved FNIS to the data folder, it would also show an ERROR(2012)

 

The first thing I thought of as the culprit is my AV, so I made sure everything from LOOT to mod organizer was excluded:

 

https://gyazo.com/7d500b22a98c991d8e3e33070a0b5429 (I can't expand the entire thing but you get the gist of it)

 

This is my mod organizer.ini:

[General]
selected_profile=STEP 1
ask_for_nexuspw=true
gameName=Skyrim Special Edition
gamePath=E:\\Steam\\steamapps\\common\\Skyrim Special Edition
first_start=false
group_state=0
window_geometry=@ByteArray(\x1\xd9\xd0\xcb\0\x2\0\0\0\0\0\xb0\0\0\0\xca\0\0\x5\xf3\0\0\x3\xb3\0\0\0\xb8\0\0\0\xe8\0\0\x5\xeb\0\0\x3\xab\0\0\0\0\0\0\0\0\a\x80)
window_split=@ByteArray(\0\0\0\xff\0\0\0\x1\0\0\0\x2\0\0\x3\xde\0\0\x2\xa8\x1\xff\xff\xff\xff\x1\0\0\0\x1\0)
log_split=@ByteArray(\0\0\0\xff\0\0\0\x1\0\0\0\x2\0\0\x2\x62\0\0\0\x64\x1\xff\xff\xff\xff\x1\0\0\0\x2\0)
browser_geometry=@ByteArray(\x1\xd9\xd0\xcb\0\x2\0\0\0\0\0\0\0\0\0\0\0\0\x3\xef\0\0\x2\xed\0\0\0\0\0\0\0\0\0\0\x3\xef\0\0\x2\xed\0\0\0\0\0\0\0\0\a\x80)
filters_visible=false
selected_executable=3
mod_info_tabs=@ByteArray(\0\0\0\t\0\0\0\xe\0t\0\x61\0\x62\0T\0\x65\0x\0t\0\0\0\f\0t\0\x61\0\x62\0I\0n\0i\0\0\0\x12\0t\0\x61\0\x62\0I\0m\0\x61\0g\0\x65\0s\0\0\0\xe\0t\0\x61\0\x62\0\x45\0S\0P\0s\0\0\0\x18\0t\0\x61\0\x62\0\x43\0o\0n\0\x66\0l\0i\0\x63\0t\0s\0\0\0\x1a\0t\0\x61\0\x62\0\x43\0\x61\0t\0\x65\0g\0o\0r\0i\0\x65\0s\0\0\0\x10\0t\0\x61\0\x62\0N\0\x65\0x\0u\0s\0\0\0\x10\0t\0\x61\0\x62\0N\0o\0t\0\x65\0s\0\0\0\x10\0t\0\x61\0\x62\0\x46\0i\0l\0\x65\0s)
backup_install=false

[PluginPersistance]
Python%20Proxy\tryInit=false

[customExecutables]
1\title=Skyrim Special Edition
1\custom=false
1\toolbar=false
1\ownicon=false
2\title=Skyrim Special Edition Launcher
2\custom=false
2\toolbar=false
2\ownicon=false
3\title=LOOT
3\custom=true
3\toolbar=false
3\ownicon=false
size=6
4\title=BethINI
4\custom=true
4\toolbar=false
4\ownicon=false
4\binary=E:/Steam/steamapps/common/Skyrim Special Edition/BethINI/BethINI.exe
4\arguments=
4\workingDirectory=E:/Steam/steamapps/common/Skyrim Special Edition/BethINI
4\steamAppID=
5\title=FNIS
5\custom=true
5\toolbar=false
5\ownicon=false
5\binary=E:/Steam/steamapps/common/Skyrim Special Edition/Data/tools/GenerateFNIS_for_Users/GenerateFNISforUsers.exe
5\arguments=
5\workingDirectory=E:/Steam/steamapps/common/Skyrim Special Edition/Data/tools/GenerateFNIS_for_Users
5\steamAppID=
6\title=SSEDIT
6\custom=true
6\toolbar=false
6\ownicon=false
6\binary=E:/Steam/steamapps/common/Skyrim Special Edition/SSEDIT/SSEEdit.exe
6\arguments=
6\workingDirectory=E:/Steam/steamapps/common/Skyrim Special Edition/SSEDIT
6\steamAppID=
3\binary=E:/Program Files x86/LOOT/LOOT.exe
3\arguments=
3\workingDirectory=E:/Program Files x86/LOOT
3\steamAppID=

[recentDirectories]
size=3
1\name=editExecutableBinary
1\directory=E:/Steam/steamapps/common/Skyrim Special Edition/Data/tools/GenerateFNIS_for_Users
2\name=editExecutableDirectory
2\directory=E:/Steam/steamapps/common/Skyrim Special Edition/Data/tools
3\name=installMod
3\directory=

[Settings]
language=en_US
log_level=0
compact_downloads=false
meta_downloads=false
use_prereleases=false
nexus_login=true
offline_mode=false
use_proxy=false
load_mechanism=0
nmm_version=0.61.13
hide_unchecked_plugins=false
force_enable_core_files=true
display_foreign=true
nexus_username=oRyenero
nexus_password="imgonnablurthisjustobesure"

[Plugins]
Basic%20diagnosis%20plugin\check_conflict=true
Basic%20diagnosis%20plugin\check_errorlog=true
Basic%20diagnosis%20plugin\check_font=true
Basic%20diagnosis%20plugin\check_missingmasters=true
Basic%20diagnosis%20plugin\check_overwrite=true
Basic%20diagnosis%20plugin\ow_ignore_empty=false
Basic%20diagnosis%20plugin\ow_ignore_log=false
FNIS%20Checker\enabled=false
FNIS%20Checker\sensitive=false
Fomod%20Installer\enabled=true
Fomod%20Installer\prefer=true
Fomod%20Installer\see_disabled_mods=false
Fomod%20Installer\use_any_file=false
INI%20Editor\associated=true
INI%20Editor\external=false
Python%20Proxy\enabled=true
Python%20Proxy\python_dir=
Simple%20Installer\enabled=true
Simple%20Installer\silent=false

[pluginBlacklist]
size=0

[geometry]
modList=@ByteArray(\0\0\0\xff\0\0\0\0\0\0\0\x1\0\0\0\0\0\0\0\a\x1\0\0\0\0\0\0\0\0\0\0\0\bT\0\0\0\x3\0\0\0\x6\0\0\0\n\0\0\0\x4\0\0\0\n\0\0\0\x2\0\0\0\n\0\0\x2\xf3\0\0\0\b\x1\x1\0\x1\0\0\0\0\0\0\0\0\x1\0\0\0\x14\xff\xff\xff\xff\0\0\0\x81\0\0\0\0\0\0\0\b\0\0\x1\x15\0\0\0\x1\0\0\0\0\0\0\0P\0\0\0\x1\0\0\0\0\0\0\0\0\0\0\0\x1\0\0\0\0\0\0\0\x41\0\0\0\x1\0\0\0\0\0\0\0\0\0\0\0\x1\0\0\0\0\0\0\0\x37\0\0\0\x1\0\0\0\0\0\0\0\0\0\0\0\x1\0\0\0\0\0\0\x1\x16\0\0\0\x1\0\0\0\0\0\0\x3\xe8\x1)
espList="@ByteArray(\0\0\0\xff\0\0\0\0\0\0\0\x1\0\0\0\0\0\0\0\x2\x1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\x1\xee\0\0\0\x4\x1\x1\0\x1\0\0\0\0\0\0\0\0\x1\0\0\0\x64\xff\xff\xff\xff\0\0\0\x81\0\0\0\0\0\0\0\x4\0\0\x1\x1a\0\0\0\x1\0\0\0\0\0\0\0M\0\0\0\x1\0\0\0\0\0\0\0;\0\0\0\x1\0\0\0\0\0\0\0L\0\0\0\x1\0\0\0\0\0\0\x3\xe8\0)"
dataTree=@ByteArray(\0\0\0\xff\0\0\0\0\0\0\0\x1\0\0\0\x1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\x1\xee\0\0\0\x2\x1\0\0\x1\0\0\0\0\0\0\0\0\0\0\0\x1\x90\xff\xff\xff\xff\0\0\0\x81\0\0\0\0\0\0\0\x2\0\0\0\xdb\0\0\0\x1\0\0\0\0\0\0\x1\x13\0\0\0\x1\0\0\0\0\0\0\x3\xe8\x1)
downloadView=@ByteArray(\0\0\0\xff\0\0\0\0\0\0\0\x1\0\0\0\0\0\0\0\x1\x1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\x1-\0\0\0\x3\x1\x1\0\x1\0\0\0\0\0\0\0\0\0\0\0\0\x64\xff\xff\xff\xff\0\0\0\x81\0\0\0\0\0\0\0\x3\0\0\0\x64\0\0\0\x1\0\0\0\0\0\0\0\x64\0\0\0\x1\0\0\0\0\0\0\0\x65\0\0\0\x1\0\0\0\0\0\0\x3\xe8\x1)

[Servers]
CDN="@Variant(\0\0\0\b\0\0\0\x5\0\0\0\xe\0p\0r\0\x65\0m\0i\0u\0m\0\0\0\x1\0\0\0\0\x12\0p\0r\0\x65\0\x66\0\x65\0r\0r\0\x65\0\x64\0\0\0\x2\0\0\0\0\0\0\0\x10\0l\0\x61\0s\0t\0S\0\x65\0\x65\0n\0\0\0\xe\0%\x81=\0\0\0\x1a\0\x64\0o\0w\0n\0l\0o\0\x61\0\x64\0S\0p\0\x65\0\x65\0\x64\0\0\0\x6\x41x\xe7h\xd0\0\0\0\0\0\0\x1a\0\x64\0o\0w\0n\0l\0o\0\x61\0\x64\0\x43\0o\0u\0n\0t\0\0\0\x2\0\0\0\x44)"

[CompletedWindowTutorials]
InstallDialog=true

My Loot folder is located at:

 

E:\Program Files x86\LOOT

 

Mod organizer folder is located at:

 

Same as where my Skyrim SE is, which would be at: E:\Steam\steamapps\common\Skyrim Special Edition

 

pls help

Edited by Rayen42

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

FIXED:

 

With the power of orange juice and some biscuits, I managed to fix it:

 

If you are having this problem, first download "usvfs.7z" from tanin's Beta 2 on:

 

https://github.com/TanninOne/modorganizer/releases

 

COPY USVFS_x86.dll from the rar file but DO NOT replace usvfs_x64.dll from the rar file, keep the one that you already have 

 

Not only did this fix the usvfs_x86.dll error BUT also fixed LOOT and FNIS for me.

Edited by Rayen42

Share this post


Link to post
Share on other sites
  • 0

A couple of points I'll make about your installation method:

 

Why recreate a UAC style folder on your E: drive? ie. (E:\Program Files x86) Even though this not a UAC folder naming it such may cause issues later on. Rename it to something sensible like E:\Games\Tools\

 

Where is your MO installed? It looks like you have extracted everything into the Skyrim game folder. Bad idea. Remove it all and place it into the same newly created folder as your other tools: E:\Games\MO2\

Share this post


Link to post
Share on other sites
  • 0

Can someone explain me why I've MO 2.0.8.3 while the lastest version on github.com is 2.0.7 ?

While on Nexus Mods 2.0.8.3b?
I'm a bit confuse, which one is the "official" ?  :confusion:

Edited by MaximilianPs

Share this post


Link to post
Share on other sites
  • 0

The Github repo for @Tannin is still on 2.0.7 because he is no longer working on this tool, he was employed by Nexus many months ago to develop their new manager, Vortex. The release you need is on the fork of this repo maintained by @LePresidente, the links to it are shown on the Nexus page and it is clearly stated that all further progress will done on that fork.

Share this post


Link to post
Share on other sites
  • 0

Tannin release the 2.0.7 version just before he was hired by Nexus to create a new mod manager for Nexus so he stopped all development of Mod Organizer. LePresidente then forked Tanin's code on github to fix some of the issues to bring it up to 2.0.8.3. You can find 2.0.83 on LePresidente's fork on github at https://github.com/LePresidente/modorganizer/releases.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By irisquexo
      Hi guys I'm new here so hopefully this is the right place to post this.
       
      When I try launching Skyrim SE through Mod Organizer 2 I get the error "REL/Relocation.h(567): failed to open file"
       
      Before this error I was getting the error "REL/Relocation.h(548): failed to open file" but I uninstalled and reinstalled the engine fixes and SKSE libraries. After doing that and relaunching I get the error I mentioned above. Do you guys know what I could have done wrong? I'm really new to messing with mods so it's probably something I did wrong... I've made sure all plugins are enabled and all mods are installed with their masters except for the ones below because I can't find the appropriate mod that goes with it so maybe that could also be the issue. I'm pretty sure I have "Blues Skyrim" but the creator renamed it so that's why MO2 is detecting it as missing. Idk if that's the case with the other ones though.
       
      Missing masters:

      Master                                                                               Required By
       
      Blues Skyrim.esp                                                              Eli_Breezehome [PATCH - DOS (Director's Cut) SE VER1.4] (STD).esp
       
      Skyrim Better Roads - All In One - Merged.esp                Settlements Expanded SE - Skyrim Better Roads Patch.esp, Skyrim Better Roads - All In - One - Merged - PATCHED.esp
       
      Soljund's Sinkhole.esp                                                      Settlements Expanded SE - Soljunds Sinkhole Patch.esp
       
      Tes Arena - Skyrim Frontier Fortress.esp                         Settlements Expanded SE - Legendary Cities Patch - AIO.esp
       
      Whistling Mine.esp                                                           Settlements Expanded SE - Whistling Mine Patch.esp
       
       
       
      also another problem is when I run LOOT it gives me the error 
       
      Loot failed to run
      Errors:
      Cyclic interaction detected: ELE_SSE.esp --[Master]-> SoS_ELE_Patch.esp --[Group]-> Luminosity Lighting Overhaul.esp --[Master]-> SoS_Luminocity_Patch.esp --[Group]-> ELE_SSE.esp
       
       
       
      If anyone knows what I could do to fix this, that would be amazing. Thank you


    • By JackGee
      Hi there peoples,

      First time posting, so if this isn't allowed please just let me know. Looking for a bit of support, as been scratching my head for ages now and getting nowhere.

      I have used MO2 + xEdit in the past and never had any issues with it. However, decided to mod Fallout NV again. When trying to run FNVEdit through MO2, it doesn't seem to complete the action as LOOT tells me after cleaning that it still needs cleaned. I have made sure the installation directory for MO2 isn't in the Fallout folder. It's all on my C drive (SSD). Tried running as admin ect. Clearing read only. Just can't seem to get it working.

      Any advice or help is appreciated.

      Thanks 
    • By Kattmandu
      Since the release of Anniversary Edition, I renamed my Skyrim SE installation folder from 'Skyrim Special Edition' to 'Skyrim Special Edition Classic' before updating the game on Steam.  So now I have both folders in Steam\steamapps\common.
      I have setup MO2 to have two different instances of Skyrim SE (one being Anniversary Edition and the other being just before Anniversary Edition).  I'm using the same Base Folder (F:/Tools/MO2Base/Skyrim) for both instances so I don't have duplicate mods using up disk space.  However, I did create unique subfolders for 'Profiles' and 'Overwrite' (e.g. %BASE_DIR%/AE/profiles and %BASE_DIR%/SE/profiles).
      So, now I have FNIS installed and when I run it through the 'Skyrim Special Edition' instance, it runs as expected.  When I switch to the 'Skyrim Special Edition Classic' instance, FNIS gives me the following warning...
      FNIS Behavior V7.6   11/14/2021 2:35:15 PM
      Generator: F:\Games\Steam\steamapps\common\Skyrim Special Edition Classic\data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe
      Skyrim SE 64bit: ??.??.?? - F:\Games\Steam\steamapps\common\Skyrim Special Edition\ (Steam)
      >>Warning: Expected generator path: F:\Games\Steam\steamapps\common\Skyrim Special Edition\data\tools\GenerateFNIS_for_Users not found<<
      I'm also getting similar pathing error when trying to run DynDOLOD through MO2...
      Error: Can not find DynDOLOD Resources SE core files to create improved LOD.
      Current Data path F:\Games\Steam\steamapps\common\Skyrim Special Edition\Data\
      Is there a way to run these utilities through MO2 with Skyrim SE being in a folder other than 'Skyrim Special Edition'?
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.