Jump to content
  • 0
Sign in to follow this  
subshadow

.fomod based mods not installing through most recent version of Mod Organizer (v2.0.8.3)

Question

Although this doesn't pertain to Fallout 4 or SkyrimSE, it does have to do with the updated version of MO, not the last version TanninOne released.

 

I recently attempted to mod Fallout New Vegas using the 2.0.7 build and discovered that I was unable to download files using the "Download with Manager" link on the nexus, this was because the 2.0.7 build was requesting nxm links from nexusmods.com/FalloutNV/ instead of nexusmods.com/newvegas/ (similar to how it was requesting Special Edition nxm downloads from /SkyrimSE/ instead of /skyrimspecialedition/). Thankfully, this was addressed in the updated version LePresidente released on the SE nexus.  However, I found I was unable to open fomod based installers through any versions released by LePresidente. It could very well be something on my end that is preventing it, however, I have been troubleshooting and researching the issue the past couple of days and was unable to find a solution. So far I have disabled my anti-virus (BitDefender), completely uninstalled all instances of Mod Organizer from my system and reinstalled, uninstalled and reinstalled New Vegas, made sure I had full permissionary access to the files on my computer, launched as administrator and normally, checked to see if my .NET framework was up to date (however I don't think that is the issue), and tried previous versions of Mod Organizer.

 

I found that 2.0.7 could run .fomod installers fine, but all subsequent versions of Mod Organizer have had visible errors when installing a fomod file, or will just not do anything when double clicking to install, which is the case only with the most up to date version (2.0.8.3). I don't normally ask for assistance on these matters and try to solve the issues myself, but I'm at my witts end with this. The easy solution would to just install NMM or FOMM, but Mod Organizer is such a superior program with flexibility that the aforementioned managers don't have and avoids the mess that would accompany said options.

 

tl;dr

Most recent version of MO won't open fomod installers. Help me please.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Welcome to STEP @subshadow

 

As these new versions are still very much in beta @LePresidente has instructed that all issues should be posted in the GitHub issue tracker.

 

If previous versions of the MO2 build were working for you and you do not wish to provide details to him, I suggest returning to one of those versions.

If you are able to provide details via GitHub please be sure to include information about the mods you are trying to install. Fomods come in 2 styles, C# & XML. I'm assuming the mod in question was using a C# style fomod as they are more problematic for MO2.

Share this post


Link to post
Share on other sites
  • 0

Thanks for the reply, I was unaware that LePresidente wanted issues to be reported to the GitHub. I don't really know a whole lot about C# or XML, or how to identify which style the mod in question is, however it's not isolated to one mod but a multitude of different fomod based files (all I ahve tried so far to be specific). I would like to try and resolve the issue if possible so I will go ahead and post to the issue tracker on GitHub. Thank you again for your assistance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By irisquexo
      Hi guys I'm new here so hopefully this is the right place to post this.
       
      When I try launching Skyrim SE through Mod Organizer 2 I get the error "REL/Relocation.h(567): failed to open file"
       
      Before this error I was getting the error "REL/Relocation.h(548): failed to open file" but I uninstalled and reinstalled the engine fixes and SKSE libraries. After doing that and relaunching I get the error I mentioned above. Do you guys know what I could have done wrong? I'm really new to messing with mods so it's probably something I did wrong... I've made sure all plugins are enabled and all mods are installed with their masters except for the ones below because I can't find the appropriate mod that goes with it so maybe that could also be the issue. I'm pretty sure I have "Blues Skyrim" but the creator renamed it so that's why MO2 is detecting it as missing. Idk if that's the case with the other ones though.
       
      Missing masters:

      Master                                                                               Required By
       
      Blues Skyrim.esp                                                              Eli_Breezehome [PATCH - DOS (Director's Cut) SE VER1.4] (STD).esp
       
      Skyrim Better Roads - All In One - Merged.esp                Settlements Expanded SE - Skyrim Better Roads Patch.esp, Skyrim Better Roads - All In - One - Merged - PATCHED.esp
       
      Soljund's Sinkhole.esp                                                      Settlements Expanded SE - Soljunds Sinkhole Patch.esp
       
      Tes Arena - Skyrim Frontier Fortress.esp                         Settlements Expanded SE - Legendary Cities Patch - AIO.esp
       
      Whistling Mine.esp                                                           Settlements Expanded SE - Whistling Mine Patch.esp
       
       
       
      also another problem is when I run LOOT it gives me the error 
       
      Loot failed to run
      Errors:
      Cyclic interaction detected: ELE_SSE.esp --[Master]-> SoS_ELE_Patch.esp --[Group]-> Luminosity Lighting Overhaul.esp --[Master]-> SoS_Luminocity_Patch.esp --[Group]-> ELE_SSE.esp
       
       
       
      If anyone knows what I could do to fix this, that would be amazing. Thank you


    • By JackGee
      Hi there peoples,

      First time posting, so if this isn't allowed please just let me know. Looking for a bit of support, as been scratching my head for ages now and getting nowhere.

      I have used MO2 + xEdit in the past and never had any issues with it. However, decided to mod Fallout NV again. When trying to run FNVEdit through MO2, it doesn't seem to complete the action as LOOT tells me after cleaning that it still needs cleaned. I have made sure the installation directory for MO2 isn't in the Fallout folder. It's all on my C drive (SSD). Tried running as admin ect. Clearing read only. Just can't seem to get it working.

      Any advice or help is appreciated.

      Thanks 
    • By Kattmandu
      Since the release of Anniversary Edition, I renamed my Skyrim SE installation folder from 'Skyrim Special Edition' to 'Skyrim Special Edition Classic' before updating the game on Steam.  So now I have both folders in Steam\steamapps\common.
      I have setup MO2 to have two different instances of Skyrim SE (one being Anniversary Edition and the other being just before Anniversary Edition).  I'm using the same Base Folder (F:/Tools/MO2Base/Skyrim) for both instances so I don't have duplicate mods using up disk space.  However, I did create unique subfolders for 'Profiles' and 'Overwrite' (e.g. %BASE_DIR%/AE/profiles and %BASE_DIR%/SE/profiles).
      So, now I have FNIS installed and when I run it through the 'Skyrim Special Edition' instance, it runs as expected.  When I switch to the 'Skyrim Special Edition Classic' instance, FNIS gives me the following warning...
      FNIS Behavior V7.6   11/14/2021 2:35:15 PM
      Generator: F:\Games\Steam\steamapps\common\Skyrim Special Edition Classic\data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe
      Skyrim SE 64bit: ??.??.?? - F:\Games\Steam\steamapps\common\Skyrim Special Edition\ (Steam)
      >>Warning: Expected generator path: F:\Games\Steam\steamapps\common\Skyrim Special Edition\data\tools\GenerateFNIS_for_Users not found<<
      I'm also getting similar pathing error when trying to run DynDOLOD through MO2...
      Error: Can not find DynDOLOD Resources SE core files to create improved LOD.
      Current Data path F:\Games\Steam\steamapps\common\Skyrim Special Edition\Data\
      Is there a way to run these utilities through MO2 with Skyrim SE being in a folder other than 'Skyrim Special Edition'?
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.