Jump to content
  • 0
shah138

"Failed to write settings" every time I close Mod Organizer after playing Fallout 4

Question

I've completely uninstalled Fallout 4 and ModOrganizer and reinstalled them and this message keeps showing up.  I've used the program with Skyrim and FO4 months ago and this issue wasn't there.  The error specifically reads "An error occured trying to update MO settings to [directory]/Appdata/Local/ModOrganizer/Fallout 4/ModoRganizer.ini: The specified path is invalid. (errorcode 161)".  How can I fix this issue?

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Please specify the version of MO2 being used. There may be an issue with a specific version. I have not seen this as of yet. I have used all versions up to v2.0.8b4.

Share this post


Link to post
Share on other sites
  • 0

I have the same issue with 2.0.8.2b which is why I switched back to 2.0.8.1b as it doesn't have this error. Related to this (I think) is another issue that when starting up MO 2 after this message parts of my loadorder and priority list aren't checked, which was also not present in 2.0.8.1b.

Edited by El_Rizzo
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

I can also confirm that I am having the same issue as El_Rizzo where my load order would become unchecked after this error.  

Share this post


Link to post
Share on other sites
  • 0

If it is a bug that was introduced in 2.0.8.2b, will look though the commits and revert. Probably found it fixed something in SkyrimSE but broke something in fallout.

Share this post


Link to post
Share on other sites
  • 0

Glad to hear that :) I just wanna say that I really appreciate that you are working on MO2, because after using MO for Skyrim 2 years I just couldn't move back to NMM :)

Share this post


Link to post
Share on other sites
  • 0

I've been having this issue since 2.0.8.1, though only if i try to run more than one executable.  I get exactly one error free use of ANYTHING through MO2 (LOOT, Fallout4.exe, FO4Edit) but if i close that program and try to run it again, I get a cascade of errors, whining about ModOrganizer.ini not saving settings (which doesn't exist in the location it's searching for).

 

If I just close MO2 after running a program, and reload it, the problem doesn't come up.  

Edited by Barachiel

Share this post


Link to post
Share on other sites
  • 0

I'm having this same issue on 2.0.8.2.  Windows 10, FO4.  I haven't seen any actual impact on my ability to manage the game though.  I just have to shut down MO2 after every game exit, and go through 3-4 error alerts.
 

I know you've published a new version since the last post on this thread but, not knowing if this was addressed, I figured the info couldn't hurt.

Share this post


Link to post
Share on other sites
  • 0

I run 2.0.8.2 and have this issue with FO4 (win7) but is accompanied with a insufficient system resources error. Happens after running the game, however running wrye/fo4edit doesn't cause this issue (those apps do crash on exit however which appears to have no negative affect) EDIT: Actually now I notice that the UFS mounting system fails a few times when launching the game, nasty issue.

 

I can still run the game and all, just a matter of restarting MO2 each time. I also noticed that SkyrimSE doesn't appear to have this severe of a issue.

Edited by theriddick

Share this post


Link to post
Share on other sites
  • 0

Tested with 8.3 and same issue, in fact I don't believe my game is stable with many mods in it as the virtual filesystem appears to fail easily. Shrug, rip fo4...

Share this post


Link to post
Share on other sites
  • 0

Tested with 8.3 and same issue, in fact I don't believe my game is stable with many mods in it as the virtual filesystem appears to fail easily. Shrug, rip fo4...

Despite an earlier statement I made to the contrary, my game has become unplayably unstable and I'll be starting over.  I'll probably be using the version of MO2 abandoned by Tannin, which has its own barrel of issues, but that may be my only path forward with MO2 and FO4.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By irisquexo
      Hi guys I'm new here so hopefully this is the right place to post this.
       
      When I try launching Skyrim SE through Mod Organizer 2 I get the error "REL/Relocation.h(567): failed to open file"
       
      Before this error I was getting the error "REL/Relocation.h(548): failed to open file" but I uninstalled and reinstalled the engine fixes and SKSE libraries. After doing that and relaunching I get the error I mentioned above. Do you guys know what I could have done wrong? I'm really new to messing with mods so it's probably something I did wrong... I've made sure all plugins are enabled and all mods are installed with their masters except for the ones below because I can't find the appropriate mod that goes with it so maybe that could also be the issue. I'm pretty sure I have "Blues Skyrim" but the creator renamed it so that's why MO2 is detecting it as missing. Idk if that's the case with the other ones though.
       
      Missing masters:

      Master                                                                               Required By
       
      Blues Skyrim.esp                                                              Eli_Breezehome [PATCH - DOS (Director's Cut) SE VER1.4] (STD).esp
       
      Skyrim Better Roads - All In One - Merged.esp                Settlements Expanded SE - Skyrim Better Roads Patch.esp, Skyrim Better Roads - All In - One - Merged - PATCHED.esp
       
      Soljund's Sinkhole.esp                                                      Settlements Expanded SE - Soljunds Sinkhole Patch.esp
       
      Tes Arena - Skyrim Frontier Fortress.esp                         Settlements Expanded SE - Legendary Cities Patch - AIO.esp
       
      Whistling Mine.esp                                                           Settlements Expanded SE - Whistling Mine Patch.esp
       
       
       
      also another problem is when I run LOOT it gives me the error 
       
      Loot failed to run
      Errors:
      Cyclic interaction detected: ELE_SSE.esp --[Master]-> SoS_ELE_Patch.esp --[Group]-> Luminosity Lighting Overhaul.esp --[Master]-> SoS_Luminocity_Patch.esp --[Group]-> ELE_SSE.esp
       
       
       
      If anyone knows what I could do to fix this, that would be amazing. Thank you


    • By JackGee
      Hi there peoples,

      First time posting, so if this isn't allowed please just let me know. Looking for a bit of support, as been scratching my head for ages now and getting nowhere.

      I have used MO2 + xEdit in the past and never had any issues with it. However, decided to mod Fallout NV again. When trying to run FNVEdit through MO2, it doesn't seem to complete the action as LOOT tells me after cleaning that it still needs cleaned. I have made sure the installation directory for MO2 isn't in the Fallout folder. It's all on my C drive (SSD). Tried running as admin ect. Clearing read only. Just can't seem to get it working.

      Any advice or help is appreciated.

      Thanks 
    • By Kattmandu
      Since the release of Anniversary Edition, I renamed my Skyrim SE installation folder from 'Skyrim Special Edition' to 'Skyrim Special Edition Classic' before updating the game on Steam.  So now I have both folders in Steam\steamapps\common.
      I have setup MO2 to have two different instances of Skyrim SE (one being Anniversary Edition and the other being just before Anniversary Edition).  I'm using the same Base Folder (F:/Tools/MO2Base/Skyrim) for both instances so I don't have duplicate mods using up disk space.  However, I did create unique subfolders for 'Profiles' and 'Overwrite' (e.g. %BASE_DIR%/AE/profiles and %BASE_DIR%/SE/profiles).
      So, now I have FNIS installed and when I run it through the 'Skyrim Special Edition' instance, it runs as expected.  When I switch to the 'Skyrim Special Edition Classic' instance, FNIS gives me the following warning...
      FNIS Behavior V7.6   11/14/2021 2:35:15 PM
      Generator: F:\Games\Steam\steamapps\common\Skyrim Special Edition Classic\data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe
      Skyrim SE 64bit: ??.??.?? - F:\Games\Steam\steamapps\common\Skyrim Special Edition\ (Steam)
      >>Warning: Expected generator path: F:\Games\Steam\steamapps\common\Skyrim Special Edition\data\tools\GenerateFNIS_for_Users not found<<
      I'm also getting similar pathing error when trying to run DynDOLOD through MO2...
      Error: Can not find DynDOLOD Resources SE core files to create improved LOD.
      Current Data path F:\Games\Steam\steamapps\common\Skyrim Special Edition\Data\
      Is there a way to run these utilities through MO2 with Skyrim SE being in a folder other than 'Skyrim Special Edition'?
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.