Jump to content
  • 0
shah138

"Failed to write settings" every time I close Mod Organizer after playing Fallout 4

Question

I've completely uninstalled Fallout 4 and ModOrganizer and reinstalled them and this message keeps showing up.  I've used the program with Skyrim and FO4 months ago and this issue wasn't there.  The error specifically reads "An error occured trying to update MO settings to [directory]/Appdata/Local/ModOrganizer/Fallout 4/ModoRganizer.ini: The specified path is invalid. (errorcode 161)".  How can I fix this issue?

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Please specify the version of MO2 being used. There may be an issue with a specific version. I have not seen this as of yet. I have used all versions up to v2.0.8b4.

Share this post


Link to post
Share on other sites
  • 0

I have the same issue with 2.0.8.2b which is why I switched back to 2.0.8.1b as it doesn't have this error. Related to this (I think) is another issue that when starting up MO 2 after this message parts of my loadorder and priority list aren't checked, which was also not present in 2.0.8.1b.

Edited by El_Rizzo
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

I can also confirm that I am having the same issue as El_Rizzo where my load order would become unchecked after this error.  

Share this post


Link to post
Share on other sites
  • 0

If it is a bug that was introduced in 2.0.8.2b, will look though the commits and revert. Probably found it fixed something in SkyrimSE but broke something in fallout.

Share this post


Link to post
Share on other sites
  • 0

Glad to hear that :) I just wanna say that I really appreciate that you are working on MO2, because after using MO for Skyrim 2 years I just couldn't move back to NMM :)

Share this post


Link to post
Share on other sites
  • 0

I've been having this issue since 2.0.8.1, though only if i try to run more than one executable.  I get exactly one error free use of ANYTHING through MO2 (LOOT, Fallout4.exe, FO4Edit) but if i close that program and try to run it again, I get a cascade of errors, whining about ModOrganizer.ini not saving settings (which doesn't exist in the location it's searching for).

 

If I just close MO2 after running a program, and reload it, the problem doesn't come up.  

Edited by Barachiel

Share this post


Link to post
Share on other sites
  • 0

I'm having this same issue on 2.0.8.2.  Windows 10, FO4.  I haven't seen any actual impact on my ability to manage the game though.  I just have to shut down MO2 after every game exit, and go through 3-4 error alerts.
 

I know you've published a new version since the last post on this thread but, not knowing if this was addressed, I figured the info couldn't hurt.

Share this post


Link to post
Share on other sites
  • 0

I run 2.0.8.2 and have this issue with FO4 (win7) but is accompanied with a insufficient system resources error. Happens after running the game, however running wrye/fo4edit doesn't cause this issue (those apps do crash on exit however which appears to have no negative affect) EDIT: Actually now I notice that the UFS mounting system fails a few times when launching the game, nasty issue.

 

I can still run the game and all, just a matter of restarting MO2 each time. I also noticed that SkyrimSE doesn't appear to have this severe of a issue.

Edited by theriddick

Share this post


Link to post
Share on other sites
  • 0

Tested with 8.3 and same issue, in fact I don't believe my game is stable with many mods in it as the virtual filesystem appears to fail easily. Shrug, rip fo4...

Share this post


Link to post
Share on other sites
  • 0

Tested with 8.3 and same issue, in fact I don't believe my game is stable with many mods in it as the virtual filesystem appears to fail easily. Shrug, rip fo4...

Despite an earlier statement I made to the contrary, my game has become unplayably unstable and I'll be starting over.  I'll probably be using the version of MO2 abandoned by Tannin, which has its own barrel of issues, but that may be my only path forward with MO2 and FO4.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Vidistis
      Hello there, I've been trying to find a way to color the text for separators. The text color is either black and white, but sometimes it's black on a separator that shares the same color of others that have white text. I would really like to be able to control the color of both the separator bar and it's text.
    • By vabatta
      Hi everyone,

      I have a portable installation of MO2 on a different drive than the OS, same drive where Skyrim is installed, and since I updated to Windows 11 I can't start Skyrim through MO2 either with or without all mods, SKSE. If I start it from outside of MO2 in any way, it works fine (with SKSE too). What could be the issue?



    • By DangerousDeraz
      Hey everybody, i ran into an issue that i was hoping someone would help me with.
      last night when i was installing my mods from STEP 2.0.0 Guide, my PC accidentally turned off and on again, after it turned back on and i went to open MO2 i found all my mods rearranged alphabetically into the last separator, and all of them were unticked. as seen in the screenshots.
      Is there a way to revert this and not go through the menace of rearranging all of the 310 mods into their separators? 
      Thanks.  


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.