Jump to content
  • 0
Sign in to follow this  
LoutishXY

Having issues with Merge Plugins Standalone

Question

I am having issues using Merge Plugins Standalone(MPS) through Mod Organizer(MO) for Fallout New Vegas. First issue is when I go to Merge plugin settings to enable the " I'm using mod organizer" option, and after setting the correct path to the MO install folder, then selecting okay, I get an error stating "List index out of bounds (-3)" Then after adding MPS to MO, whenever I launch MPS I get an error stating "Access Violation at address 008EF331 in module 'MergePlugins.exe'. Read of address 00000004." On a side note, whenever I launch MPS on its own (NOT through MO) it starts/runs fine with no problems.

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

You can ignore the first List Index out of bounds error. It happens all the time on first run and is benign.

 

Regards the other problem try the fix suggested by Mator HERE

Share this post


Link to post
Share on other sites
  • 0

Hello all! I'm having issues with Merge Plugins. I've had previous experience with it back about a year ago when I was trying to consolidate mods in Skyrim, using an older computer, and it ran smoothly without a single hiccup.

 

I'm now playing FO4, using MO2, have launched Merge Plugins from MO, made both applications run with administrator rights, downloaded required programs for Merge Plugins, and have followed the video tutorial as well as read the s.t.e.p. guide. My MO2 folders are in different places, with mods being in appdata/local/modorganizer, and the main install directory originally being in programfiles until I moved it to the Fallout 4 directory.

 

I seem to be unable to move past editing the integrations screen, which is fairly early on in the tutorial. I have all fields pointing to the right directories yet the button "ok" is still greyed out, making me unable to save my progress. Detect integrations feature couldn't detect the FO4 papyrus flag paths even with the CreationKit installed, so I read a forum post that said to download the original TESV flag file and place it where needed, still not sure if that is correct. As soon as I enable "I'm using Mod Organizer" in the integrations screen, the "ok" button greys out and stays that way even when all fields are filled with correct info (with the exception of BsaOpt as that remains grey even when installed in FO4 directory). I also have an issue where if I try to navigate through files using Merge Plugins, the program crashes immediately. I had to manually copy/paste directories as a result. I'll attach a screenshot for reference.

 

kaioop.png

 

I've gone through many forums searching for an answer but I haven't found it yet, I see that this forum is still fairly active so I hope that someone here can put forth a possible solution. Thanks in advance!

Share this post


Link to post
Share on other sites
  • 0

kota1337:
You need to be using MO2 in portable mode to use Merge Plugins with it.

Share this post


Link to post
Share on other sites
  • 0

I apologize, I must have missed that solution somewhere between the tutorials/guides/and forum posts! I found a reddit thread where you posted the same solution, and now I understand.

 

I've started MO2 in portable mode and everything is fixed. Now I can proceed to the stressful (or rather very careful) task of merging but it will be so worth it. Thanks very much for helping me out Mator!

 

Have a great day  ::D:

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

hey Mator not sure this is the right place but i am having issues with merge plugins for SSE is appears no scripted mods such and ihud are being recompiled correctly can you confirm if i should be using the 32 bit or 64 bit of Champollion?

 

currently test with the 64 bit version since SSE is 64 bit a getting this message:

 

Decompiling scripts
  No files found matching F:\Skyrim Tools\Merge Plugins Standalone\temp\generalPex\*.pex
  No files found matching F:\Skyrim Tools\Merge Plugins Standalone\temp\pex\*.pex
 
Remapping FormIDs in scripts
  No files found matching F:\Skyrim Tools\Merge Plugins Standalone\temp\psc\*.psc
 
Compiling scripts
  No files found matching F:\Skyrim Tools\Merge Plugins Standalone\temp\psc\*.psc

Share this post


Link to post
Share on other sites
  • 0

Merge Plugins only recompiles Script Fragments.  If the plugin has no script fragments associated with it, Merge Plugins won't do anything.  If the scripts have Game.GetFromFile or similar calls you need to fix them with Ganda's Relinker.

 

I haven't tested SSE script handling thoroughly, so it's also possible it's broken because of some changes since Skyrim Classic (or due to the recent updates), but I doubt it.

Share this post


Link to post
Share on other sites
  • 0

Hi Mator,

 

First thank you for all your Support.

 

I justed googled about my issue and find the above written exact same issue as i have.

 

I follow lexys lotd guide and use mo2 portable and have the correct paths of compiler tes5flag etc..

It doesnt matter which plugins i merge i always have the above statements. But when i Activate the merged plugin and deactivate the plugins the merged.esp says missing masters. But these masters are included in the merged plugin.

 

Theres also a Video Tutorial on youtube for lexys lotd. When he is merging the plugins the build merge box shows dir example renaming form ids ,decompiling scripts and delete unneccesary masters.. But in my case its always the above written Text and the merged plugin in my case is wrong.

 

Please help i spend weeks and hours in this guide but i dont know why he doesnt merge like it should. Mo2 is portable.

Thank you

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.