Jump to content
  • 0
Sign in to follow this  
Toosdey

Anyway to make MO use normal .ini files?

Question

For FO4, I like to use the Fallout4Configurator tool, simply works a lot easier for me. But I THINK MO is overriding that changes it makes to the ini files with MO's customer ini files. Mind you, I admit I could be wrong on this, it's been a while since I've use either of these tools and admit I could be missing something more basic, but I was looking for some insight here. 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

I don't have Fallout 4 installed and I've not heard of the Fallout4Configurator (FO4C) but assuming it does what similar Skyrim tools do this is what will be happening:

  1. That tool edits the default INIs as stored in My Documents, ie. the ones the game uses when not run via MO.
  2. MO uses profile specific INIs that are created from the default, so if you use FO4C first and THEN create new profiles in MO, they should be based on the now modified INIs from FO4C.

If that tool has a setting that can be used to look for other INIs, you may be able to point it to those in the profile you are using.

 

Regardless of what happens MO is not overwriting any of the default INIs, all changes are made to copies in the active profile.

 

There is another method that I personally haven't tried that may suffice.

In MO's settings go to the plugins tab and edit "INI Editor" to be 'external=true' and 'associated=true'. If you have set up, if possible, FO4C as the default Windows tool to edit INIs it will be called instead of the INI editor.

Share this post


Link to post
Share on other sites
  • 0

Ill give that shot then. I think this general issue is why I cant get that god awful Bokeh, depth of field and all other shitty blur options to turn the hell off

Share this post


Link to post
Share on other sites
  • 0

I think the profile feature in the original MO2 was broken and they were not used only the My Games are used. I have not been following the current development closely by @LePresidente so I do not know if it has been fixed yet.

 

Unless you use the internal editor or configurator in MO, MO does not edit the fallout4.ini and fallout4prefs.ini directly. Instead it creates a file called initweaks.ini in the active profile. This file, which should not be edited by the user because it is dynamically created at each game run , should contain additions that are a combination of MO added things and any initweaks from mods and ini files added by mods. Again I am not sure this features is working at this time.

 

As for the configurator, is it this one? If so when run through MO it only changes the "MY Games" ini files even if the "local Game settings" is checked for the profile. This would have to be changed in the program to point to the active profile. Then again I believe the profile system in MO is still not working.

 

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By irisquexo
      Hi guys I'm new here so hopefully this is the right place to post this.
       
      When I try launching Skyrim SE through Mod Organizer 2 I get the error "REL/Relocation.h(567): failed to open file"
       
      Before this error I was getting the error "REL/Relocation.h(548): failed to open file" but I uninstalled and reinstalled the engine fixes and SKSE libraries. After doing that and relaunching I get the error I mentioned above. Do you guys know what I could have done wrong? I'm really new to messing with mods so it's probably something I did wrong... I've made sure all plugins are enabled and all mods are installed with their masters except for the ones below because I can't find the appropriate mod that goes with it so maybe that could also be the issue. I'm pretty sure I have "Blues Skyrim" but the creator renamed it so that's why MO2 is detecting it as missing. Idk if that's the case with the other ones though.
       
      Missing masters:

      Master                                                                               Required By
       
      Blues Skyrim.esp                                                              Eli_Breezehome [PATCH - DOS (Director's Cut) SE VER1.4] (STD).esp
       
      Skyrim Better Roads - All In One - Merged.esp                Settlements Expanded SE - Skyrim Better Roads Patch.esp, Skyrim Better Roads - All In - One - Merged - PATCHED.esp
       
      Soljund's Sinkhole.esp                                                      Settlements Expanded SE - Soljunds Sinkhole Patch.esp
       
      Tes Arena - Skyrim Frontier Fortress.esp                         Settlements Expanded SE - Legendary Cities Patch - AIO.esp
       
      Whistling Mine.esp                                                           Settlements Expanded SE - Whistling Mine Patch.esp
       
       
       
      also another problem is when I run LOOT it gives me the error 
       
      Loot failed to run
      Errors:
      Cyclic interaction detected: ELE_SSE.esp --[Master]-> SoS_ELE_Patch.esp --[Group]-> Luminosity Lighting Overhaul.esp --[Master]-> SoS_Luminocity_Patch.esp --[Group]-> ELE_SSE.esp
       
       
       
      If anyone knows what I could do to fix this, that would be amazing. Thank you


    • By JackGee
      Hi there peoples,

      First time posting, so if this isn't allowed please just let me know. Looking for a bit of support, as been scratching my head for ages now and getting nowhere.

      I have used MO2 + xEdit in the past and never had any issues with it. However, decided to mod Fallout NV again. When trying to run FNVEdit through MO2, it doesn't seem to complete the action as LOOT tells me after cleaning that it still needs cleaned. I have made sure the installation directory for MO2 isn't in the Fallout folder. It's all on my C drive (SSD). Tried running as admin ect. Clearing read only. Just can't seem to get it working.

      Any advice or help is appreciated.

      Thanks 
    • By Kattmandu
      Since the release of Anniversary Edition, I renamed my Skyrim SE installation folder from 'Skyrim Special Edition' to 'Skyrim Special Edition Classic' before updating the game on Steam.  So now I have both folders in Steam\steamapps\common.
      I have setup MO2 to have two different instances of Skyrim SE (one being Anniversary Edition and the other being just before Anniversary Edition).  I'm using the same Base Folder (F:/Tools/MO2Base/Skyrim) for both instances so I don't have duplicate mods using up disk space.  However, I did create unique subfolders for 'Profiles' and 'Overwrite' (e.g. %BASE_DIR%/AE/profiles and %BASE_DIR%/SE/profiles).
      So, now I have FNIS installed and when I run it through the 'Skyrim Special Edition' instance, it runs as expected.  When I switch to the 'Skyrim Special Edition Classic' instance, FNIS gives me the following warning...
      FNIS Behavior V7.6   11/14/2021 2:35:15 PM
      Generator: F:\Games\Steam\steamapps\common\Skyrim Special Edition Classic\data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe
      Skyrim SE 64bit: ??.??.?? - F:\Games\Steam\steamapps\common\Skyrim Special Edition\ (Steam)
      >>Warning: Expected generator path: F:\Games\Steam\steamapps\common\Skyrim Special Edition\data\tools\GenerateFNIS_for_Users not found<<
      I'm also getting similar pathing error when trying to run DynDOLOD through MO2...
      Error: Can not find DynDOLOD Resources SE core files to create improved LOD.
      Current Data path F:\Games\Steam\steamapps\common\Skyrim Special Edition\Data\
      Is there a way to run these utilities through MO2 with Skyrim SE being in a folder other than 'Skyrim Special Edition'?
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.