Jump to content
  • 0

Skyrim Launcher has stopped working - Windows 10 problem?





Coming to you fine folks for help as I'm at my wits end. I decided to do a fresh install of Skyrim, and have had nothing but problems. I'm guessing it's not a coincidence that I've got Windows 10, and the anniversary update. I wish I would have never installed Windows 10, but I'm stuck with it now.


So right now, I have a completely vanilla Skyrim install (but I do have DG, HF. DB, and Hi-Res pack), no mods, and when I try to launch the game via TESV.exe, I get the message "Skyrim Launcher has stopped working". I should note this is the only game I have a problem with on my system.


Things I have tried:

Drivers - All up to date

DirectX User runtimes - no help

Completely uninstalling and deleting Skyrim, then downloading fresh from Steam - Same problem

Google - no help

Running compatibility mode and as administrator - no help


Now here's where it get's really weird. I decided to install SKSE and try to launch via that. This includes installing the scripts and SKSE.ini. The game launches, but every texture is purple. (I do have the Hi-Res DLC installed too, along with all 3 Official DLC's). I am just baffled. I've been playing the game and modding since it came out, consider myself a knowledgeable and responsible modder, but I can't imagine what is going on.


So like I said, I "think" it's an issue between Skyrim and Windows 10, but I have no idea. 


A couple of things of note: My OS is on an SSD, and Skyrim and all other games including Steam are on a separate SSD.

My game worked fine as of a couple of weeks ago (anniversary update??).

System specs are in my signature.


If you need any further info please let me know, and thank you in advance!



Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 0

I'm sorry, I should have mentioned that I have run SkyrimLauncher.exe, and the same thing happens, I get the message "Skyrim launcher has stopped working", so it doesn't detect video settings.


Also I have run the user runtimes to no avail :(

Link to comment
Share on other sites

  • 0

I know that the latest Nvidia drivers broke a ton of dx9 games. Fallout 3 and New Vegas along with reports of Oblivion as well. I had to roll back to 368.81 because the newest 372.54 just refuses to work properly. Several people have already sent in reports to Nvidia so hopefully it gets fixed. It's also happening with a few Windows 7 and 8.1 users so I don't think it's necessarily Windows 10 specific. It could however be completely unrelated to the drivers. Though that is the first thing I would check. If you do happen to roll back, make sure you do a CLEAN install with Display Driver Uninstaller (DDU). Installing an older driver over a newer one can also mess things up even more.

Link to comment
Share on other sites

  • 0

Rolling back to driver 368.81 seems to have fixed it.


Though clicking on SkyrimLauncher.exe from inside the Skyrim folder still gives the "Skyrim Launcher has stopped working" message, but everything else seems to be working now.



Spoke too soon. Now I can launch the game, but when launching through SKSE AND using ENBoost, the purple textures are back. this is infuriating. 


Furthermore, I can only use ENB v 305 .dll, v 308 gives me the stopped working message. About to give up and just wait for the special edition in October.

Edited by Drax8
Link to comment
Share on other sites

  • 0

Maybe you could try installing Skyrim again from scratch with driver 368.81 already (clean) installed.


Anyway, for reference and people who experience sudden launch crashes; on page 17 in 'Release 370 Graphics Drivers for Windows, Version 372.90' - https://us.download.nvidia.com/Windows/372.90/372.90-win10-win8-win7-desktop-release-notes.pdf - the following is stated:


Application Issues


[Windows 10][bethesda Softworks games (Fallout 3, Fallout New Vegas, Skyrim)]
Games crash when launched. [1802925]




According to Nvidia's Manuel Guzman: "The new Windows 10 Anniversary Update had a specification change that required our display driver to output a different string from the previous drivers in the past. This has affected some games which were unfortunately developed with the assumption that the value would never change. We are working with Microsoft to find a solution."

( https://forums.geforce.com/default/topic/966915/geforce-drivers/official-372-90-game-ready-whql-display-driver-feedback-thread-released-9-21-16-/post/4980875/#4980875 )


It seems the problem is related to the change from WDDM 2.0 to WDDM 2.1.

Windows 10 Anniversary Update includes WDDM 2.1.

Driver 368.81 and earlier are still WDDM 2.0, so is said.


Must say on my already long existing Skyrim-installation I haven't noticed any problems with the latest driver branch and the Anniversary Update.

Edited by Ilkob
Link to comment
Share on other sites

  • 0

As far as I know the launchers still worked but when the game would attempt to start the renderer, that is where it crashed.


For the longest time I've had this issue of when ENB binary is in the directory, the launcher fails and the enboost process repeatedly opens until the system runs out of room or until you remove the d3d9 binary.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Privacy Policy, and Terms of Use.