Jump to content
  • 0
JUNKdeLUXE

Wiki pages are very slow

Question

I've been doing the Clear and Present Danger install during the last 2 weeks, and they (and wiki pages it link to) have been progressively had more and more load time.

 

The forums on the other hand still seem fine. 

 

Not sure what the problem is.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

We had a 4X increase in normal traffic, and had a configuration issue that was rectified. Should be performing a lot better since yesterday early evening.

Still really slow for me right now. Might want to check MySQL (DB size) and caching. Pingdom tests are not so good.

Share this post


Link to post
Share on other sites
  • 0

Current caching is good. I can't test during the day, but during lower peak usage, the wiki is loading fast for me. The larger culprit is being driven by a spike in in-bound connections that starts just after 9AM server time. This directly impacts server load. Increasing the number of processes to handle more connections will also directly impact server load, potentially more negatively than the current state.

 

You also have to take Pingdom with a grain of salt to a certain extent. It is connecting as if it is a first time user, which means there is no benefit of client side caching of all of the resources such as CSS, JS, images, and initial page view. There are a lot more resources being loaded for the Wiki compared to the Forum. A test via Pingdom in the past 10 minutes reported a little over 10 second load time, but a refresh in my browser was under 3 seconds.

 

There are some things I can look at implementing to help reduce the stress further, but will take some time to setup and test.

Share this post


Link to post
Share on other sites
  • 0

Good afternoon.. 

Not sure if this thread is still active, but I wanted to pass along that the pass day or so I've been getting a 504 Gateway Time-out whenever I try to access the main wiki page.

As others in this thread have stated, the forums are working just fine.

[ghost]

Share this post


Link to post
Share on other sites
  • 0

Yeah, it's happening during the daytime, but the problem is that S4N said he can't check it in the daytime. If this is all resource related and not software, we may have to start looking into new server. Can only wait for S4N to check it out.

Share this post


Link to post
Share on other sites
  • 0

Time to do something! I'm now being contacted on other outlets (Facebook for now) about the slow or inaccessible wiki. Plus 3 pages about this and reports over it. Whatever needs to be done we should discuss it here or in the Admin forums.

Share this post


Link to post
Share on other sites
  • 0

Testing is in the works to get a solution in place to help with the slowness. Likely won't be able to fully implement till the weekend assuming my testing pans out OK. Either way, there will be a last minute maintenance to implement when I'm ready, since I don't know when I'll be fully ready and I want to get this setup ASAP.

Share this post


Link to post
Share on other sites
  • 0

Slowness pertains only to the wiki and has to do with recent spike in wiki-page requests. As s4n stated, a fix is under development for implementation this weekend, which should resolve the wiki issue until we ramp up a new server later this year.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.