Jump to content

tooandrew

Watcher
  • Content Count

    19
  • Joined

  • Last visited

Community Reputation

0 Neutral

About tooandrew

  • Rank
    Citizen

Contact Methods

  • Discord
    b0nerMisn0mer

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Is there a way to run multiple instances of dyndolod at once? Shy of running one on a different computer? It takes so long to run its like really time consuming trying to dial in the grassbrightness setting to get everything matching the normal grass. Currently I'm running it on two computers - my third is a 6 year old laptop with a mobile i7, im sure itll be so slow i might as well not use it. But if you had an identical executable that had a different process name so i could run multiple instances concurrently on the same machine, that would probably save me a good deal of time
  2. i've gotten to a point where i believe all the billboards are showing up, they are just showing as the wrong color for grassbrightness i noticed blue and green are significantly higher than red. fiddling with them now.
  3. for me, installing .net framework 6.0 and rebooting fixed this. sheson said texgen doesnt use the framework though so maybe it was just the reboot
  4. tried with just gcid, same result. Do comparisons with a game that uses the same grass cache files to load full grass that DynDOLOD used to generation grass LOD, then each full grass should have a corresponding x plane if a billboard exists and density is 100%. It should make it easier to spot which type of grass does not have LOD. this might be an issue - i cannot get ngio extended grass mode to work, like, at all - but if the cache just didnt work at all there would be NO grass lods. there are some, just not certain types. that being said, i have tried many things to get it working and its just not happening - this whole process is insanely frustrating Double check that the 132 GRAS base records is about the expected amount from the loaded plugins. Double check that there are 5 billboard files (*.txt, *_1.dds, *_1_n.dds, *_2.dds, *_2_n.dds) for each (130 grass billboards * 5 = 650 files) - you can do that by only checking grass LOD billboard generation into an empty output folder. 132 grass entries from the folkvangr esp, specifically. one is missing a mesh, so 131, really. 130 were generated because i configured it to make billboards for all including underwater . there were 1238 billboards created total from all plugins, grass and trees both. there are 5 files per billboard Use programs that supports BC7 like SageThumbs /Paint.NET or change the compression format to DXT5 for the 4 channel textures with alpha/specular and DXT1 for 3 channel. paint.net shows the billboards, they do look like grass (albeit highly pixellated grass) How many lines/billboards are listed and is it about the expected amount of grasses that are above water and used in the worldspace. theres 120 lines in the tamriel lodgen plant log - between the 131 from folkvangr and the 11 from origin there are 142 grass billboards - im sure not all of them exist in tamriel. some of the ones that are missing in game are in the list. their textures do exist, and are not transparent. You only need to look at one from the area where you believe grass LOD is missing to check if there are more X planes that you actually see in the game. That would mean the grass position and billboard file for it exists but is transparent. Also check the verbose LODGen log for message like File not found *.DDS. We expect it to only mention grasses that are underwater (often have "water" in the name), the ones that TexGen does not generate because they have missing assets or are too small, not so high ground cover. there are no lines containing 'not found' in tamriel lodgen log. how do i identify which file is associated with which area? is there a console command or something? at any rate the grass is missing everywhere. theres lots of golden grass installed and only green grass lods https://dyndolod.info/Help/Grass-LOD In case the grass LOD brightness or color seems off (it might depend on weathers or ENB settings), try different Direct/Ambient settings for grass LOD billboards in TexGen. In addition or alternatively change the GrassBrightnessTop* and GrassBrightnessBottom* settings in ..\DynDOLOD\Edit Scripts\DynDOLOD\DynDOLOD_SSE.ini - those settings help if the color tone is off. Especially the image based lighting effect from ENB has a big impact on the brightness and color tone of the grass LOD. they match fine, the ones that exist. but most of them don't exist
  5. nevermind. i just have grass draw up high. looking into the distance in clear weather i see only the green grass is out there so its not specific to that spot
  6. on closer inspection it seems like the grass lod is loaded in game just not in a specific area - skyrimse skyrim vr is it possible there a conflict with the dyndolod 3 files provided with majestic mountains ?
  7. respectfully, ive read that document until my eyes feel like theyre bleeding, im doing weird things because it has not helped me. to show that i read it i will address each point individually - maybe you can show me where i am going wrong. Check in the mod manager that there are ..\Data\Grass\[Worldspace]*.CGID grass cache files for the worldspace in the load order. they're in there. both cgid and gid forms Make sure TexGen is generating grass LOD billboards for grasses by checking its log ..\DynDOLOD\Logs\TexGen_SSE_log.txt. Pay attention to error messages and fix them. Double-check the object bounds of the GRAS records in the plugins as explained abov grep "folkvangr" TexGen_TES5VR_log.txt show 130 billboards generated of the 132 grass entries listed in my config file - more than two types are missing grep "<Error:" shows one error for [00:57] <Error: File not found Meshes\landscape\grass\grass_fieldmisc_03.nif Folkvangr - Grass and Landscape Overhaul.esp Grass_FieldMisc_03 [GRAS:2002B50C]> fine, didnt come with the mod, so it wouldnt show up in game either. again, more than one grass type missing Check the grass LOD billboards textures in the TexGen output with an image viewer show grass and are not fully transparent. the textures are weird. i have never viewed textures before but in windows texture viewer nothing appears at all, while in Basic DDS image viewer i get colorful noise like the attached image. all of the other billboards from skyrim.esm etc behave the same way in these programs, so i guess the programs i have just don't know how to display them correctly? i found these in textures\terrain\lodgen\folkvangr - grass and landscape overhaul.esp is there an image viewer you reccommend? there are also four dds files for each entry Check the DynDOLOD debug log ..\DynDOLOD\Logs\DynDOLOD_SSE_Debug_log.txt contains <Notice: [Worldspace] Gathering grass data for object LOD> grepping the log shows the following [01:20] [DoObjectLOD] <Notice: [Tamriel] Gathering grass data for object LOD> [02:40] [DoObjectLOD] <Notice: [DLC2SolstheimWorld] Gathering grass data for object LOD> [03:05] [DoObjectLOD] <Notice: [MarkarthWorld] Gathering grass data for object LOD> [03:16] [DoObjectLOD] <Notice: [DLC01SoulCairn] Gathering grass data for object LOD> [03:27] [DoObjectLOD] <Notice: [DLC2ApocryphaWorld] Gathering grass data for object LOD> [03:31] [DoObjectLOD] <Notice: [SkuldafnWorld] Gathering grass data for object LOD> [03:38] [DoObjectLOD] <Notice: [Sovngarde] Gathering grass data for object LOD> [03:47] [DoObjectLOD] <Notice: [DeepwoodRedoubtWorld] Gathering grass data for object LOD> [03:51] [DoObjectLOD] <Notice: [DLC1HunterHQWorld] Gathering grass data for object LOD> [03:57] [DoObjectLOD] <Notice: [DLC01FalmerValley] Gathering grass data for object LOD> [04:04] [DoObjectLOD] <Notice: [JaphetsFollyWorld] Gathering grass data for object LOD> [04:07] [DoObjectLOD] <Notice: [Blackreach] Gathering grass data for object LOD> Check the DynDOLOD log ..\DynDOLOD\Logs\DynDOLOD_SSE_log.txt that there were no errors in the LODGen log and check the LODGen log ..\DynDOLOD\Logs\LODGen_SSE_[Worldspace]_log.txt directly that its last line is Code: 0. there are no errors whatsoever in the dydndolod log all of the lodgen logs end in Code: 0 Check the object LOD atlas ..\DynDOLOD_Output\Textures\DynDOLOD\LOD\DynDOLOD_[Worldspace].dds contains some of the grass LOD billboards generated by TexGen. every texture i look at looks like some variation of the attached image. i can't tell if this particular mess of pixels is mixed in with the big mess of pixels in the dyndolod texture Check the export file ..\DynDOLOD\Edit Scripts\Export\LODGen_SSE_Export_[Worldspace].txt contains a line like GrassMap=..\DynDOLOD\Edit Scripts\Export\LODGen_SSE_Grass_Map_[Worldspace].txt. Check that GrassDensity is not 0. If it is very low, grass LOD may be very thin to non-existent. from LODGen_TES5VR_Export_Tamriel GrassMap=C:\skyrimvr\dyndolod\Edit Scripts\Export\LODGen_TES5VR_Grass_Map_Tamriel.txt GrassDensity=16 (same happened when it was set to 100) Check that ..\DynDOLOD\Edit Scripts\Export\LODGen_SSE_Grass_Map_[Worldspace].txt contains lines with grass LOD billboard texture names and paths in it. it does. Open ..\DynDOLOD_Output\Meshes\Terrain\[Worldspace]\Objects\[Worldspace].4.x.y.bto and check visually if there is grass LOD in there. The many tiny X planes will be obvious. every one i've looked at has the x planes, but there are too many to be looked at individually To find a BTO that contains grass LOD, set expert=1 and verbose=1 in the ..\DynDOLOD\Edit Scripts\DynDOLOD\DynDOLOD_SSE.ini to start DynDOLOD in expert mode. Select the worldspace and click Execute LODGen. Once its done, check the LODGen log ..\DynDOLOD\Logs\LODGen_SSE_[Worldspace]_log.txt for lines like "Found z grass placements for LOD level 4 coord [x, y]". Check the BTO for the mentioned coordinates. i set those settings. ill check that file after i regenerate texgen and dyndolod when this grass cache finishes generating - the ones ive made until now were configured to use the list from the xedit script that lists world areas with grass - im letting it cache the whole game this time, just in case
  8. https://drive.google.com/drive/folders/1Eo9hTqahzjKDNuypYo1CzS62dBqc4hSM?usp=sharing logs. bugreport empty
  9. im stumped. all the grass has object bounds via ck now, texgen has configuration files, all the billboards are showing up in texgen preview and it's still not displaying in game. some kinds of grass goes out as far as the eye can see, others pop up as i approach. i tried disabling ignorelargebillboards, i tried halving the MinGrassModelHeight and MinGrassModelVolume i wanted to add GRAS to basesignatures but dyndolod errors out when i do that. also at one point it made a dyndolod.esm that had ai-overhaul.esp as a master, so that's weird. when i recal'd bounds with ck it said some of them did not have normal maps https://pastebin.com/u7CPVTS2 - could this be why? does anyone have any more ideas or am i just crap out of luck on this one?
  10. im stumped. all the grass has object bounds via ck now, texgen has configuration files, all the billboards are showing up in texgen preview and it's still not displaying in game. some kinds of grass goes out as far as the eye can see, others pop up as i approach. i tried disabling ignorelargebillboards, i tried halving the MinGrassModelHeight and MinGrassModelVolume i wanted to add GRAS to basesignatures but dyndolod errors out when i do that. also at one point it made a dyndolod.esm that had ai-overhaul.esp as a master, so that's weird. when i recal'd bounds with ck it said some of them did not have normal maps https://pastebin.com/u7CPVTS2 - could this be why? does anyone have any more ideas or am i just crap out of luck on this one?
  11. I got the billboard generation to work but it still doesnt appear in game with a new dyndolod build. Regenerated grass cache to no avail. Edit: just saw the thing about object bounds in the other thread. Will try setting that up tomorrow Edit2: forgive how dense i am. My reading comprehension is clearly not what it once was
  12. so with DynDOLOD_TES5VR_TexGen_Billboards_FolkvangrGrassandLandscapeOverhaulesp.txt all the models show up in preview in texgen now, so presumably they are being generated now - in the TexGen_Output\textures\terrain\lodgen\folkvangr - grass and landscape overhaul.esp folder there are way more files. but they're still not showing up in game. i will try regenerating grass cache i guess, then run dyndolod again
  13. still didnt work. any other tips? wait, remove the hyphen from DynDOLOD_TES5VR_TexGen_Billboards_Folkvangr-GrassandLandscapeOverhaulesp or from DynDOLOD_SSE_TexGen_Billboards_Folkvangr - Grass and Landscape Overhaulesp
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.